Bug 64460 - Wrong libebml include path in libmatroska-0.6.3_2 port
Summary: Wrong libebml include path in libmatroska-0.6.3_2 port
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Mario Sergio Fujikawa Ferreira
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-19 15:40 UTC by Aron Stansvik
Modified: 2004-03-20 01:47 UTC (History)
0 users

See Also:


Attachments
file.diff (720 bytes, patch)
2004-03-19 15:40 UTC, Aron Stansvik
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Stansvik 2004-03-19 15:40:17 UTC
I noticed that libmatroska-0.6.3_2 failed on a missing libebml header. It seems it uses a wrong include path for libebml. The fix below works for me, I don't know if it breaks things for other releases, but looking at the libebml port, I don't think it should. Maybe this is not the correct way to fix this problem, I'm a ports newbie.

How-To-Repeat: 'portinstall libmatroska' with current ports tree.
Comment 1 Kirill Ponomarev freebsd_committer 2004-03-19 16:09:17 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lioux

Over to maintainer.
Comment 2 Mario Sergio Fujikawa Ferreira freebsd_committer 2004-03-20 01:26:02 UTC
	I cannot reproduce this on a -STABLE system

FreeBSD HERE.here 4.9-STABLE FreeBSD 4.9-STABLE #21: Thu Mar 18 18:40:42 BRT 2004     lioux@HERE.here:/usr/src/sys/compile/LIOUX  i386

	Could you try updating to the latest ports tree via CVSup?
Then, try

	portupgrade -f 'libebml*'

Then, try again

	portinstall multimedia/libmatroska

	I cannot understand what might be going wrong. Can you
provide a build log? We might be able to get a better hang on
what might be going wrong. :)

	Try

$ cd /usr/ports/multimedia/libmatroska
$ script log make

	Then reply attaching the log message.

	Regards,

-- 
Mario S F Ferreira - DF - Brazil - "I guess this is a signature."
feature, n: a documented bug | bug, n: an undocumented feature
Comment 3 Mario Sergio Fujikawa Ferreira freebsd_committer 2004-03-20 01:47:22 UTC
State Changed
From-To: open->closed

Committed, thanks!