Bug 65529 - urwfonts package lacks instructions
Summary: urwfonts package lacks instructions
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Jimmy Olgeni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-14 16:50 UTC by Jason Bacon
Modified: 2004-05-01 17:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Bacon 2004-04-14 16:50:20 UTC
	When installing urwfonts-1.0 from the ports, it displays a helpful
	message directing the installer to update FontPath in XF86Config.  
	The message does not appear when installing from the package.  
	This causes problems with OpenOffice-1.1, and likely many other 
	apps, since the fonts are there but the X server isn't aware of 
	them.  I'd suggest putting this message in all fonts ports and 
	packages for the sake of non-FreeBSD-gurus who wouldn't be 
	aware of the need to edit their XF86Config to activate new fonts.

Fix: 

Under

		Section "Files"
	
	Add

		FontPath /usr/X11R6/lib/X11/fonts/URW

	to XF86Config, and restart the X server.  
	( Log out and type Ctrl+Alt+Backspace )

	While you're there, you might want to look for any other fonts
	directories that are missing from the FontPath.  Note that some
	may not be under /usr/X11R6/lib/X11/fonts.
How-To-Repeat: 	pkg_add -r urwfonts
	Run openoffice-1.1
	Try typing something in Times 96pt font
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2004-04-14 19:39:31 UTC
Responsible Changed
From-To: freebsd-ports-bugs->olgeni

Over to maintainer.
Comment 2 Jimmy Olgeni freebsd_committer 2004-05-01 17:15:54 UTC
State Changed
From-To: open->closed

Setup instructions moved to pkg-message, thanks for the report!