Bug 71097 - Port conflict (net/trafshow and net/trafshow4)
Summary: Port conflict (net/trafshow and net/trafshow4)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-29 11:10 UTC by Riccardo Torrini
Modified: 2004-10-14 09:22 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Torrini 2004-08-29 11:10:36 UTC
	
	net/trafshow and net/trafshow4 installs same executable (bin/trafshow).
	Both Makefile are missing CONFLICTS= line.
	Also installing trafshow4 create a /var/db/pkg/trashow-4... that
	confuse pkg_version, we need to change PORTNAME of net/trafshow4 from
	trafshow to trafshow4 (or remove one of the versions and rename the
	other)

Fix: 

Change PORTNAME of net/trafshow4

	# diff -u0 Makefile.orig Makefile
	--- Makefile.orig       Sun Aug  8 07:45:12 2004
	+++ Makefile    Sun Aug 29 11:52:53 2004
	@@ -8 +8 @@
	-PORTNAME=      trafshow
	+PORTNAME=      trafshow4

	Then remove and reinstall net/trafshow4, this change the ORIGIN line
	of /var/db/pkg/trafshow-4.0/+CONTENTS and make pkg_version happy.
How-To-Repeat: 	( make sure to have neither net/trafshow nor net/trafshow4 installed)
	# cd /usr/ports/net/trafshow4 && make install clean
	# pkg_version -vL=
	trafshow-4.0		<   needs updating (port has 3.1_4,1)
Comment 1 Oliver Eikemeier 2004-08-29 11:37:53 UTC
Riccardo Torrini wrote:

> 	net/trafshow and net/trafshow4 installs same executable 
> (bin/trafshow).
> 	Both Makefile are missing CONFLICTS= line.

true. Also net/trafshow4 needs to specify LATEST_LINK=.	

> 	Also installing trafshow4 create a /var/db/pkg/trashow-4... that
> 	confuse pkg_version, we need to change PORTNAME of net/trafshow4 from
> 	trafshow to trafshow4 (or remove one of the versions and rename the
> 	other)

No, this is correct as is.

>> How-To-Repeat:
> 	( make sure to have neither net/trafshow nor net/trafshow4 installed)
> 	# cd /usr/ports/net/trafshow4 && make install clean
> 	# pkg_version -vL=
> 	trafshow-4.0		<   needs updating (port has 3.1_4,1)

I can't reproduce that. This would be a bug in pkg_version(1), but it 
seems like you have an old version of net/trafshow installed.

>> Fix:
> 	Change PORTNAME of net/trafshow4
>
> 	# diff -u0 Makefile.orig Makefile
> 	--- Makefile.orig       Sun Aug  8 07:45:12 2004
> 	+++ Makefile    Sun Aug 29 11:52:53 2004
> 	@@ -8 +8 @@
> 	-PORTNAME=      trafshow
> 	+PORTNAME=      trafshow4

No, this is wrong. The ports version is *not* part of PORTNAME, and 
ports doings so are wrong (expect when the vendor _explicitly_ names 
it's software that way, like libxml2).

-Oliver
Comment 2 Sergey Matveychuk freebsd_committer 2004-08-29 13:02:41 UTC
Dear maintainer, take this PR into account please.

-- 
Sem.
Comment 3 Sergey Matveychuk freebsd_committer 2004-08-29 13:04:22 UTC
State Changed
From-To: open->feedback

Over to maintainer.
Comment 4 Riccardo Torrini 2004-08-29 13:36:27 UTC
On Sun, Aug 29, 2004 at 12:37:53PM +0200, Oliver Eikemeier wrote:

>> Also installing trafshow4 create a /var/db/pkg/trashow-4... that
>> confuse pkg_version, we need to change PORTNAME of net/trafshow4
>> from trafshow to trafshow4 ...

> No, this is correct as is.

A lot of ports use this, why is wrong?


>> # cd /usr/ports/net/trafshow4 && make install clean
>> # pkg_version -vL=
>> trafshow-4.0		<   needs updating (port has 3.1_4,1)

> I can't reproduce that. This would be a bug in pkg_version(1), but
> it seems like you have an old version of net/trafshow installed.

Me too  :-(  Maybe the last world fixed this, sorry for wasting time.
Anyway the CONFLICTS line is still missing  0=)


-- 
Riccardo.
Comment 5 Ryan Thompson 2004-09-22 19:21:55 UTC
Hi Sergey,

Sorry for the slow response. My life blew up. Fortunately, my servers
are still running. :-)

First, the trafshow vs trafshow4 change was made to provide both
branches simultaneously. Trafshow 3.x is still the "stable" one, and
trafshow4 has problems on at least FreeBSD, and a couple of other OSes
as well. I haven't had much time to look into it myself, and a few
people that offered to do testing haven't gotten back to me yet, either.

The real problem that we have, now, I gather, is the lack of CONFLICTS
line. I'd say, go ahead and add it to both ports (trafshow and
trafshow4). That was an oversight on my part, thanks mostly to my
blowing up life.

- Ryan

Sergey Matveychuk wrote to FreeBSD-gnats-submit@FreeBSD.org and...:

> Dear maintainer, take this PR into account please.
>
>

-- 
   Ryan Thompson <ryan@sasknow.com>

   SaskNow Technologies - http://www.sasknow.com
   901-1st Avenue North - Saskatoon, SK - S7K 1Y4

         Tel: 306-664-3600   Fax: 306-244-7037   Saskatoon
   Toll-Free: 877-727-5669     (877-SASKNOW)     North America
Comment 6 Sergey Matveychuk freebsd_committer 2004-09-23 15:21:04 UTC
State Changed
From-To: feedback->open

Feedback received.
Comment 7 Edwin Groothuis freebsd_committer 2004-10-14 09:22:36 UTC
State Changed
From-To: open->closed

Committed, thanks!