Bug 72494 - [patch] Linuxpluginwrapper needs after the library version change (libm)
Summary: [patch] Linuxpluginwrapper needs after the library version change (libm)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Norikatsu Shigemura
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-10 22:30 UTC by Amir
Modified: 2004-10-11 18:17 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.55 KB, patch)
2004-10-10 22:30 UTC, Amir
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Amir 2004-10-10 22:30:15 UTC
	libm in -current, and after beta7 was bumped
	linuxpluginwrapper sample /etc/libmap.conf needs to be updated.
	or else, the mapping wont work, and pluging will fail to work.

	my fix _doesn't_ support pre-beta7 5 branch such as 5.2.1.

Fix: apply this patch to sample libmap.conf file:
How-To-Repeat: 	try to use the plugings.
Comment 1 Thierry Thomas freebsd_committer 2004-10-10 23:05:32 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nork


Over to maintainer.
Comment 2 Norikatsu Shigemura freebsd_committer 2004-10-11 03:47:14 UTC
On Sun, 10 Oct 2004 23:20:49 +0200 (IST)
Amir Shalem <amir@active.ath.cx> wrote:
> >Number:         72494
> >Category:       ports
> >Synopsis:       [patch] Linuxpluginwrapper needs after the library version change (libm)

	Thank you for your report.  But I'm asking to commit.
	Please test following patch.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Index: Makefile
===================================================================
RCS file: /home/ncvs/ports/www/linuxpluginwrapper/Makefile,v
retrieving revision 1.28
diff -u -r1.28 Makefile
--- Makefile	30 Aug 2004 15:40:41 -0000	1.28
+++ Makefile	10 Oct 2004 12:02:14 -0000
@@ -6,9 +6,9 @@
 #
 
 PORTNAME=	linuxpluginwrapper
-PORTVERSION=	20040831
+PORTVERSION=	20041010
 PORTREVISION=	0
-CATEGORIES=	www linux
+CATEGORIES=	www linux emulators
 MASTER_SITES=	http://people.FreeBSD.org/~nork/distfiles/ \
 		${MASTER_SITE_LOCAL}
 MASTER_SITE_SUBDIR=	nork
@@ -28,6 +28,7 @@
 .endif
 
 ONLY_FOR_ARCHS=	i386
+MAKE_ENV=	EXAMPLESDIR=${EXAMPLESDIR} INSTALL_DATA="${INSTALL_DATA}"
 
 USE_XLIB=	yes
 USE_REINPLACE=	yes
@@ -37,8 +38,10 @@
 .endif
 CONFLICTS=	flashpluginwrapper-*
 
-.if		${OSVERSION} >= 500000
-LIBMAPCONF=	${WRKSRC}/misc/libmap.conf-FreeBSD5.x
+.if		${OSVERSION} >= 503001
+LIBMAPCONF=	${WRKSRC}/misc/libmap.conf-FreeBSD5-stable
+.elif		${OSVERSION} >= 500000
+LIBMAPCONF=	${WRKSRC}/misc/libmap.conf-FreeBSD5-current
 .else
 LIBMAPCONF=	${WRKSRC}/misc/libmap.conf-FreeBSD4.x
 .endif
Index: distinfo
===================================================================
RCS file: /home/ncvs/ports/www/linuxpluginwrapper/distinfo,v
retrieving revision 1.12
diff -u -r1.12 distinfo
--- distinfo	30 Aug 2004 15:40:41 -0000	1.12
+++ distinfo	10 Oct 2004 11:48:15 -0000
@@ -1,2 +1,2 @@
-MD5 (linuxpluginwrapper-20040831.tar.gz) = 93154f1119ee7853cfc279b64008885a
-SIZE (linuxpluginwrapper-20040831.tar.gz) = 13139
+MD5 (linuxpluginwrapper-20041010.tar.gz) = 3ddc99418f83c7e1a3b47e4e9911bb35
+SIZE (linuxpluginwrapper-20041010.tar.gz) = 13176
Index: pkg-message
===================================================================
RCS file: /home/ncvs/ports/www/linuxpluginwrapper/pkg-message,v
retrieving revision 1.2
diff -u -r1.2 pkg-message
--- pkg-message	29 Feb 2004 13:52:25 -0000	1.2
+++ pkg-message	10 Oct 2004 11:47:53 -0000
@@ -9,6 +9,10 @@
 	to
 libpthread.so.0			pluginwrapper/flash6.so
 
+** PLEASE NOTICE TO USER USING FROM 5.0 TO 5.3-BETA6 **
+libm.so was version-bumped on 5.3-BETA7. Please change libm.so.2
+to libm.so.3.
+
 ================================================================
 
 
Index: pkg-plist
===================================================================
RCS file: /home/ncvs/ports/www/linuxpluginwrapper/pkg-plist,v
retrieving revision 1.6
diff -u -r1.6 pkg-plist
--- pkg-plist	22 Aug 2004 05:39:42 -0000	1.6
+++ pkg-plist	10 Oct 2004 11:44:54 -0000
@@ -4,6 +4,9 @@
 lib/pluginwrapper/java3d.so
 lib/pluginwrapper/java3d_snd.so
 lib/pluginwrapper/pips.so
+%%EXAMPLESDIR%%/libmap.conf-FreeBSD5-stable
+%%EXAMPLESDIR%%/libmap.conf-FreeBSD5-current
+%%EXAMPLESDIR%%/libmap.conf-FreeBSD4.x
 @unexec	/bin/rm -f    %%X11BASE%%/lib/browser_plugins/nppdf.so
 @unexec	/bin/rm -f    %%X11BASE%%/lib/browser_plugins/flashplayer.xpt
 @unexec	/bin/rm -f    %%X11BASE%%/lib/browser_plugins/libflashplayer.so
@@ -13,3 +16,4 @@
 @exec	/bin/ln -sf %%LOCALBASE%%/lib/linux-flashplugin6/flashplayer.xpt    %%X11BASE%%/lib/browser_plugins/
 @exec	/bin/ln -sf %%LOCALBASE%%/lib/linux-flashplugin6/libflashplayer.so  %%X11BASE%%/lib/browser_plugins/
 @dirrm lib/pluginwrapper
+@dirrm %%EXAMPLESDIR%%
Comment 3 Norikatsu Shigemura freebsd_committer 2004-10-11 03:55:43 UTC
On Mon, 11 Oct 2004 11:47:14 +0900 (JST)
Norikatsu Shigemura <nork@FreeBSD.org> wrote:
> > >Number:         72494
> > >Category:       ports
> > >Synopsis:       [patch] Linuxpluginwrapper needs after the library version change (libm)
> 	Thank you for your report.  But I'm asking to commit.
	                                              ~~~~~~ portmgr@
	Oops, I missed.
Comment 4 Norikatsu Shigemura freebsd_committer 2004-10-11 18:17:46 UTC
State Changed
From-To: open->closed

Committed, thanks!