Bug 75046 - pear & pear2 cmds will fail if libaries are already loaded
Summary: pear & pear2 cmds will fail if libaries are already loaded
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-14 10:00 UTC by Markus Seifert
Modified: 2004-12-14 18:44 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Seifert 2004-12-14 10:00:46 UTC
The pear and pear2 scripts will fail if 'prce.so' and/or 'xml.so' are already loaded. 
The Problem is in the patch for pearcmd (patch-scripts::pearcmd.php). No checking is done if the libaries are already loaded.

Fix: 

It should look something like this: 

if(!function_exists('preg_match')){
  @dl('pcre.so');	
}
 
if(!function_exists('utf8_decode')){
  @dl('xml.so');
}

Maybe with some additional Errorhandling if the Libaries do not exist :)
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2004-12-14 18:10:33 UTC
State Changed
From-To: open->feedback

To which port(s) does this PR apply?
Comment 2 Thierry Thomas freebsd_committer 2004-12-14 18:42:47 UTC
State Changed
From-To: feedback->closed


Committed with PR ports/75063 from the maintainer. 
Thanks for your notification! 

Mark: this was devel/pear-PEAR and affected every pear-* ports.