Bug 76590 - adding -mapall in nfs exports requires reboot
Summary: adding -mapall in nfs exports requires reboot
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 5.3-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: Rick Macklem
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-23 04:10 UTC by Matthias Buelow
Modified: 2017-11-06 22:49 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Buelow 2005-01-23 04:10:19 UTC
      Adding a -mapall option to an entry in /etc/exports doesn't seem to have any effect, even when restarting the nfs server and mountds.  Only after rebooting the server the change comes into effect.  It is nonsensical that a change of nfsd export attributes requires a system reboot, instead of just an nfs server restart.

How-To-Repeat:       I have the following line in /etc/exports:

/usr -mapall=mkb:mkb -network 192.168.0.0 -mask 255.255.255.0

Before that, I already exported it without the mapall directive.
Mounting on clients worked in both cases but after adding the mapall directive, no remapping was done.  I also tried with numerical ids, without groups, and various permutations thereof.
I restarted nfsd with /etc/rc.d/nfsd restart, /etc/rc.d/mountd restart, and even stopped and started the servers manually.
The filesystem was unmounted on the client during restarts.
I noticed that nfsiod wasn't affected by these restarts.
Comment 1 mbuna 2005-02-14 23:12:28 UTC
Hi,

I noticed exactly the same problem. But I have a simple workaround.

After modifying /etc/exports, just do the old way:

kill -s HUP `cat /var/run/mountd.pid`

Perhaps mountd's restart script is broken?

Hope that helps,
Stephane
Comment 2 Rick Macklem freebsd_committer 2017-11-06 22:49:14 UTC
The command "/etc/rc.d/mountd reload" seems to work and posts a SIGHUP
to the mountd daemon, which makes it reload /etc/exports.

I have no idea if the 5.3 shell scripts were busted, but I am closing this
PR.