Bug 76805 - [CHANGE-REQUEST] print/apsfilter dependency change from shells/bash2 to shells/bash
Summary: [CHANGE-REQUEST] print/apsfilter dependency change from shells/bash2 to shell...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: andreas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-29 04:30 UTC by Michael C.Shultz
Modified: 2005-01-30 11:54 UTC (History)
1 user (show)

See Also:


Attachments
apsfilter-7.2.5_6.diff (629 bytes, patch)
2005-01-29 04:30 UTC, Michael C.Shultz
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael C.Shultz 2005-01-29 04:30:20 UTC
	
	From an email by one of my portmanager users:

"I am aware of apsfilter's dependency on bash-2.05b.007_2. The problem is
that  bash has to write it files to the same location. There is no way,
at least that I am aware of, to have two versions of bash installed.
Besides, why would I want two versions. Furthermore, apsfilter runs just
fine with the newer version of bash. I intend to contact the maintainer
of apsfilter to see if he can find a solution to this problem also."

This seems easy enough to implement so only if the maintainer concurs
please consider updating apsfilter with the attached apsfilter-7.2.5_6.diff.

Fix: I've added a WITH_BASH2 option in case someone
has good reason for this and changed the default
bash dependency from shells/bash2 to shells/bash.
Makefile.diff is attached.

How-To-Repeat: 
	N/A
Comment 1 Mark Linimon 2005-01-29 04:36:27 UTC
Yes, well, IIRC shells/bash was marked deprecated some time ago due
to being obsolete, but also IIRC someone objected.

Is there really a pressing reason to keep it around?

mcl
Comment 2 Michael C.Shultz 2005-01-29 04:58:36 UTC
Here is from http://www.freshports.org/shells/bash

port moved here from shells/bash3 on 2004-08-11
REASON: move latest stable version to unnumbered directory

The most recent update is 19 Nov 2004 to version 3.0.16_1

I don't see anything in its Makefile indicating it is depreciated.

-Mike
Comment 3 Pav Lucistnik freebsd_committer 2005-01-29 16:34:30 UTC
Responsible Changed
From-To: freebsd-ports-bugs->andreas

Over to maintainer.
Comment 4 andreas freebsd_committer 2005-01-30 11:36:05 UTC
State Changed
From-To: open->closed

closing PR, applied your suggested patch, thanks for reporting this issue