Bug 77356 - avr-libc 1.2.1 installs but does not install include/
avr-libc 1.2.1 installs but does not install include/
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Daichi GOTO
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 18:30 UTC by dkelly
Modified: 2005-09-14 05:00 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dkelly 2005-02-10 18:30:12 UTC
Originally noticed the lack of /usr/local/avr/include/ after an upgrade, no matter that /var/db/pkg/avr-binutils-2.15_1/+CONTENTS said there should be one.

Seems to be two problems:

1) pdflatex is missing causing the make to fail.
2) when portinstall/portupgrade is used the above error is not noticed.

Fix: 

Creating a bogus pdflatex in my path didn't help.
How-To-Repeat: portinstall avr-libc

Seems we are lacking pdflatex:
# cd /usr/ports/devel/avr-libc
# make
..
cd latex_pdf_src && \
        sed -e '/{demo.eps}/s/demo.eps/demo.pdf/' \
        group__demo__project.tex > tmp.$ && \
        mv -f tmp.$ group__demo__project.tex
cd latex_pdf_src && gmake refman.pdf
gmake[2]: Entering directory `/usr/ports/devel/avr-libc/work/avr-libc-1.2.1/build/doc/api/latex_pdf_src'
pdflatex refman.tex
gmake[2]: pdflatex: Command not found
gmake[2]: *** [refman.pdf] Error 127
gmake[2]: Leaving directory `/usr/ports/devel/avr-libc/work/avr-libc-1.2.1/build/doc/api/latex_pdf_src'
gmake[1]: *** [avr-libc-user-manual.pdf] Error 2
gmake[1]: Leaving directory `/usr/ports/devel/avr-libc/work/avr-libc-1.2.1/build/doc/api'
gmake: *** [all-recursive] Error 1
*** Error code 1

Stop in /usr/ports/devel/avr-libc/work/avr-libc-1.2.1/build.
dkelly@Opus {1052}
Comment 1 Mark Linimon freebsd_committer 2005-02-10 23:29:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->joerg

Over to maintainer.
Comment 2 j 2005-02-15 09:46:26 UTC
How could you possibly get away with starting the build at all?

pdflatex is part of teTeX, and teTeX is properly listed as a
prerequisite for the port (BUILD_DEPENDS).

Perhaps I should change the check for teTeX from "latex" to
"pdflatex"?  Is there any other package that would possibly install a
"latex" command these days?  Hmm, teTeX conflicts with latex2e-*, so
maybe you've got one of those installed?

As for the portupgrade not noticing the build failure, we might pass
the PR on to the portupgrade maintainer once the above has been
clarified.

-- 
cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)
Comment 3 dkelly 2005-02-16 02:10:39 UTC
On Feb 15, 2005, at 3:46 AM, Joerg Wunsch wrote:

> How could you possibly get away with starting the build at all?

Surprised me too. Ran portupgrade on one machine and saw success along 
with a new avr-libc but didn't try to use that avr-libc for a while 
until after running portupgrade on another machine and found avr-libc 
was broken.

> pdflatex is part of teTeX, and teTeX is properly listed as a
> prerequisite for the port (BUILD_DEPENDS).

I think latex and family are in a state of disarray on FreeBSD at the 
moment. Removed doxygen and now rebuild of doxygen breaks on latex.

> Perhaps I should change the check for teTeX from "latex" to
> "pdflatex"?  Is there any other package that would possibly install a
> "latex" command these days?  Hmm, teTeX conflicts with latex2e-*, so
> maybe you've got one of those installed?
>
> As for the portupgrade not noticing the build failure, we might pass
> the PR on to the portupgrade maintainer once the above has been
> clarified.

I think that is a key component of my initial problem which prompted 
opening this PR. Having run cvsupdate a time or two since I can no 
longer reproduce the portupgrade no-error where there really was an 
error situation. So it seems to have cleared up.

Using "-DNOPORTDOCS" gets my avr-libc binaries and include files back 
into operational condition.

--
David Kelly N4HHE, dkelly@HiWAAY.net
========================================================================
Whom computers would destroy, they must first drive mad.
Comment 4 Joerg Wunsch freebsd_committer 2005-02-16 11:30:03 UTC
Responsible Changed
From-To: joerg->knu

I've made the avr-libc port depend on pdflatex as well as on 
latex now, to make absolutely sure both are installed. 

Over to the maintainer of portupgrade, so he can analyze why 
portupgrade didn't detect the build failure.
Comment 5 Mark Linimon freebsd_committer 2005-07-18 23:24:27 UTC
Responsible Changed
From-To: knu->daichi

Over to new maintainer of sysutils/portupgrade.
Comment 6 Daichi GOTO freebsd_committer 2005-09-13 14:29:32 UTC
State Changed
From-To: open->feedback

Over to new maintainer.
Comment 7 dkelly 2005-09-14 00:06:19 UTC
Lets close this as whatever was happening before is no longer a  
problem with current versions.
Comment 8 Daichi GOTO freebsd_committer 2005-09-14 04:59:34 UTC
State Changed
From-To: feedback->closed

Submitter request. Thanks!