Bug 79235 - [maintainer update] sysutils/dtc: v0.17.0.3 of Domain Technologie Control (DTC) web hosting control panel
Summary: [maintainer update] sysutils/dtc: v0.17.0.3 of Domain Technologie Control (DT...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Sam Lawrance
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-25 18:00 UTC by Thomas Goirand
Modified: 2006-05-16 10:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Goirand 2005-03-25 18:00:05 UTC

How-To-Repeat: This is a major update of this GPL web control panel for admin and
accounting hosting services. The old port that was uploaded last year is
totaly outdated, and thanks to one of my users who helped debugging last
stuff, I can commit today.
All files are available in ftp://ftp.gplhost.com/pub/dtc/bsd

Tell me when you think it's ok, so I can fix freeze version number
corresponding to the port (incrementing dev version).

The port seems in good health, but there is something very anoying I
cannot resolv myself, because the problems concern another port:
mod_log_sql. If I try to use mod_log_sql2 (in fact version 1.100) like
as normal, then apache crashes in loop when I start it, and error.log
grows fastly. If I use mod_log_sql, then it wants to use mysql client
3.23, and the rest of the installation uses 4.1 (not my choice, the
panel don't care the MySQL version...). What I had to do is change
this line:

File is /usr/ports/www/mod_log_sql/Makefile:

LIB_DEPENDS=    mysqlclient.10:${PORTSDIR}/databases/mysql323-client

  should be changed to:

LIB_DEPENDS=    mysqlclient.14:${PORTSDIR}/databases/mysql41-client

If you do that, and the use mod_log_sql instead of mod_log_sql2 in my
port dependancies, then you have no problem at all.

Another problem I encounter. Is there a version of the Linux TAR program
under BSD, or a version of BSD tar for Linux? The problem is that the one
on linux and the one in BSD make files of different size (even when you
don't ask for gzip compression), so it can lead to size missmatch in my
port if I make the port on FreeBSD (with my customs sh scripts) who will
download in it's turn the package made on gplhost (debian). That's what
happened last time, I just understood 3 month later... What's the
solution? By the way I can live with that problem...

I'm available thrue msn: thomasgoirand@hotmail.com or skype: z_i_g_o or
IRCNet under the channel #dtc-dev if you need me.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2005-04-03 08:04:34 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports-bugs

This is a ports PR. 

To the submitter: please help us out by assigned ports PRs to the 'ports' 
category so that they can be tracked properly.  It is most helpful if 
the port category and name appear in the Synopsis.  We also prefer that 
GNATS submissions have their lines wrapped at 70 characters.  Finally, 
it would be optimal if you could include patches to update the port via 
using diff -ruN between the new version of the port and the old port. 

Please see the Porter's Handbook for more details on how to do this at 
http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/index.html. 
Also of interest might be the Problem Report documentation at 
http://www.freebsd.org/doc/en_US.ISO8859-1/articles/problem-reports/article.html. 

Thanks.
Comment 2 Thomas Goirand 2005-04-10 20:37:23 UTC
Hello,

first I want you to know I feel terribly sorry I didn't follow the
guidelines. In fact, I though I did, I've been writting the port
submit reading that article you are pointing to. Maybe I've
missed something, aspecialy the port category. I'm not sure I
understood, because I don't see any feild named "category". Would
you mind tell me what field your are talking about? For that one, I
think it would be nice if you add a section on port submitting in
the doc (category section), saying all what should be done, maybe
it's a bit confusing for a FreeBSD newbie like me.

About the wrap to 70 chars, I was really sorry I did it too, I just
didn't know it wouldn't do the line breaks, and I couldn't change it
after submitting could I? Is there a way of edditing what I did?

BTW here is the requested diff, on my Singapore server. Tell me if I
did it wrong (I was thinking that maybe I did it in wrong directory...).

http://node6501.gplhost.com/dtcBSDport-0.17.0.3.diff

Thanks for your your reply, and understanding about the fact I work
on other OS normaly (namely debian) and that I do that only for others.
I promiss I wont do the same mistakes once more.

Regards,

    Thomas Goirand
Comment 3 Florent Thoumie freebsd_committer 2005-05-31 12:38:59 UTC
Responsible Changed
From-To: freebsd-ports-bugs->flz

Grab.
Comment 4 Florent Thoumie freebsd_committer 2005-05-31 14:01:32 UTC
State Changed
From-To: open->feedback

It seems there are conflicts somewhere in your port. 

http://www.xbsd.org/tb/errors/5-amd64-freebsd/dtc-0.17.0.3.log
Comment 5 Thomas Goirand 2005-07-08 03:15:45 UTC
Please try again with latest CVS version:

cd /usr/ports
wget ftp://ftp.gplhost.com/pub/dtc/bsd/dtcBSDport-0.17.0.4.tar.gz
tar -xvzf dtcBSDport-0.17.0.4.tar.gz
cd sysutils/dtc
make install

This new version works with mod_log_sql2, apache2 and mysql 4.1.

Thomas
Comment 6 Florent Thoumie freebsd_committer 2005-07-24 19:37:59 UTC
Responsible Changed
From-To: flz->freebsd-ports

Return to the pool, feedback has been received some time ago.
Comment 7 Florent Thoumie freebsd_committer 2005-07-24 19:46:41 UTC
Responsible Changed
From-To: freebsd-ports->freebsd-ports-bugs

Refile.
Comment 8 Kris Kennaway freebsd_committer 2005-07-30 02:35:12 UTC
State Changed
From-To: feedback->open

Feedback received
Comment 9 Sergey Matveychuk freebsd_committer 2005-10-13 17:28:41 UTC
Please use useful macros like USE_PHP. You can find them in 
/usr/ports/MK/bsd.php.mk file (read comments in the file).

-- 
Sem.
Comment 10 Sergey Matveychuk freebsd_committer 2005-10-13 17:34:38 UTC
And provide a unify diff for updates please (diff -u).

-- 
Sem.
Comment 11 Sam Lawrance freebsd_committer 2005-11-10 12:58:48 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lawrance

Take
Comment 12 Sam Lawrance freebsd_committer 2006-05-13 08:26:27 UTC
State Changed
From-To: open->feedback

Sorry this has taken so long.  I have tried to clean up 
your submission, could you please try the patch so far: 

http://people.freebsd.org/~lawrance/patch-dtc 

and let me know how it goes?  It applies against the 
current version of the port.
Comment 13 Sam Lawrance freebsd_committer 2006-05-16 10:27:36 UTC
State Changed
From-To: feedback->closed

Committed, thanks!