Bug 79863 - [maintainer-update] devel/ocaml-pcre : change dependancy to pcre-utf8
Summary: [maintainer-update] devel/ocaml-pcre : change dependancy to pcre-utf8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-13 14:20 UTC by Burelle Marwan
Modified: 2005-04-15 13:15 UTC (History)
1 user (show)

See Also:


Attachments
diff-ocaml-pcre (448 bytes, text/plain)
2005-04-13 14:20 UTC, Burelle Marwan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Burelle Marwan 2005-04-13 14:20:12 UTC

Many ocaml programs assume pcre is built with utf8 support, so I change the dependancy to the slave port of pcre with utf8 enabled.
Comment 1 Volker Stolz freebsd_committer 2005-04-15 08:54:39 UTC
Due to the way LIB_DEPENDS-checking works, you won't notice if the plain  
pcre-version has already been installed. Will this be a problem? If yes,  
we'll have to think about how to dinstinguish both pcre-versions, e.g.  
through a cookie-file.

Volker
Comment 2 Burelle Marwan 2005-04-15 10:13:46 UTC
On Fri, Apr 15, 2005 at 09:54:39AM +0200, Volker Stolz wrote:
> Due to the way LIB_DEPENDS-checking works, you won't notice if the plain  
> pcre-version has already been installed. Will this be a problem? If yes,  
> we'll have to think about how to dinstinguish both pcre-versions, e.g.  
> through a cookie-file.


Yes, this is a problem, in fact not for ocaml-pcre itself, but for
some application using, in especially CDuce (which is important for me
as I work on it.)

The dependence over pcre with utf8 support was requirement for the
first version of the port I submit and some people (on ports@, and
also Thierry Thomas by private mail) suggest using (and creating) a
slave port pcre-utf8, since the slave port arrives just after that
discussion, I changed the ocaml-pcre port.

Anyway, instead of cookie-file, we could just test libpcre.so.0 with :

   nm ${LOCALBASE}/libpcre.so.0 | grep -i utf8

If utf8 support isn't present, the result is empty.

Is it a safe way (in this case, one can use it's own libpcre) ?

   Marwan.

-- 
Burelle Marwan,
Equipe Bases de Donnees - LRI
http://www.cduce.org
(burelle@lri.fr | Marwan.Burelle@ens.fr)
Comment 3 Pav Lucistnik freebsd_committer 2005-04-15 13:14:59 UTC
State Changed
From-To: open->closed

Committed, thanks!