Bug 79869 - [MAINTAINER] databases/firebird-devel: Add pkg-install
Summary: [MAINTAINER] databases/firebird-devel: Add pkg-install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Sergey Matveychuk
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-13 16:50 UTC by Renato Botelho
Modified: 2005-04-23 21:11 UTC (History)
0 users

See Also:


Attachments
firebird-devel-2.0.a1.patch (4.30 KB, patch)
2005-04-13 16:50 UTC, Renato Botelho
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Renato Botelho 2005-04-13 16:50:24 UTC
- Add pkg-install and remove NO_PACKAGE line from Makefile

Added file(s):
- pkg-install

Generated with FreeBSD Port Tools 0.63
Comment 1 Sergey Matveychuk freebsd_committer 2005-04-16 22:12:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sem

One more PR I should care.
Comment 2 Sergey Matveychuk freebsd_committer 2005-04-16 23:10:22 UTC
On 5.4-RC1:

gmake[3]: Entering directory 
`/usr/ports/databases/firebird-devel/work/firebird2/gen'
c++   -I../src/include/gen -I../src/include -O -fno-builtin -DNDEBUG 
-DFREEBSD -pipe -MMD -fPIC  -DPROD_BUILD -c 
../src/common/classes/alloc.cpp -o 
../temp/libfbcommon/common/classes/alloc.o
In file included from 
../src/common/classes/../../include/../common/classes/tree.h:48,
                  from 
../src/common/classes/../../include/../common/classes/alloc.h:50,
                  from ../src/common/classes/../../include/firebird.h:79,
                  from ../src/common/classes/alloc.cpp:39:
../src/common/classes/../../include/../common/classes/vector.h: In 
member function `bool Firebird::SortedVector<Value, Capacity, Key, 
KeyOfValue, Cmp>::find(const Key&, int&)':
../src/common/classes/../../include/../common/classes/vector.h:116: 
error: `count' undeclared (first use this function)
../src/common/classes/../../include/../common/classes/vector.h:116: 
error: (Each undeclared identifier is reported only once for each 
function it appears in.)
../src/common/classes/../../include/../common/classes/vector.h:119: 
error: `data' undeclared (first use this function)
In file included from 
../src/common/classes/../../include/../common/classes/alloc.h:50,
                  from ../src/common/classes/../../include/firebird.h:79,
                  from ../src/common/classes/alloc.cpp:39:
../src/common/classes/../../include/../common/classes/tree.h: In static 
member function `static const Key& Firebird::BePlusTree<Value, Key, 
Allocator, KeyOfValue, Cmp, LeafCount, 
NodeCount>::NodeList::generate(void*, void*)':
../src/common/classes/../../include/../common/classes/tree.h:210: error: 
expected primary-expression before ')' token
../src/common/classes/../../include/../common/classes/tree.h:210: error: 
expected `)' before "item"
../src/common/classes/../../include/../common/classes/tree.h:210: error: 
expected `)' before ';' token
gmake[3]: *** [../temp/libfbcommon/common/classes/alloc.o] ïÛÉÂËÁ 1
gmake[3]: Leaving directory 
`/usr/ports/databases/firebird-devel/work/firebird2/gen'
gmake[2]: *** [libfbcommon] ïÛÉÂËÁ 2
gmake[2]: Leaving directory 
`/usr/ports/databases/firebird-devel/work/firebird2/gen'
gmake[1]: *** [../gen/firebird/bin/gpre_static] ïÛÉÂËÁ 2
gmake[1]: Leaving directory 
`/usr/ports/databases/firebird-devel/work/firebird2/gen'
gmake: *** [firebird] ïÛÉÂËÁ 2
*** Error code 2

Stop in /usr/ports/databases/firebird-devel.

--
Sem.
Comment 3 Sergey Matveychuk freebsd_committer 2005-04-16 23:14:37 UTC
State Changed
From-To: open->feedback

Ask for feedback
Comment 4 Renato Botelho 2005-04-18 13:03:23 UTC
I can't reproduce this error, I compile it on a 5.3-RELEASE-p9 and on a
5.4-RC2 and all works fine here.

I'll try to find any machine with 5.4-RC1 and try to compile this.

Thanks
-- 
Renato Botelho <freebsd at galle dot com dot br>
AIM: RBGargaBR | ICQ: 54596223
GnuPG Key: http://www.galle.com.br/~renato/pubkey.asc

Politicians are the same all over.  They promise to build a bridge even
where there is no river.
		-- Nikita Khrushchev
Comment 5 Sergey Matveychuk freebsd_committer 2005-04-23 21:11:16 UTC
State Changed
From-To: feedback->closed

Committed, thanks!