Bug 80040 - [sound] [hang] Use of sound mixer causes system freeze with uaudio driver
Summary: [sound] [hang] Use of sound mixer causes system freeze with uaudio driver
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-17 21:00 UTC by Winfried Maus
Modified: 2018-01-03 05:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Maus 2005-04-17 21:00:37 UTC
After installing the latest available uaudio module (downloaded 2005-04-16), uaudio finally worked with the Creative Labs Sound Blaster mp3+, but two problems remained:

1. Using Gnome's sound mixer on that device causes an immediate system freeze.

2. According to the uaudio driver, the device can only play at 48000Hz which results in asynchronous sound when playing movies with Totem or other video players.

Fix: 

Sorry, no solution known.
How-To-Repeat: 1. Plug a Creative mp3+ to the system.
2. Launch esd -r 48000 or artsd -r 48000.
3. Use a sound mixer: System Freeze.
4. After reboot and restarting the sound daemons as described above, try to playback an Xvid or Divx movie with Totem - the sound will always be asynchronous.
Comment 1 Remko Lodder freebsd_committer 2010-07-14 17:07:31 UTC
State Changed
From-To: open->feedback

Hello, is this still relevant for recent FreeBSD versions?
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:14 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped