Bug 80382 - esound port esddsp does not work in 5.x (bus error) - works in 4.x
esound port esddsp does not work in 5.x (bus error) - works in 4.x
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
Depends on:
  Show dependency treegraph
Reported: 2005-04-27 01:50 UTC by jpe_45305
Modified: 2005-04-27 04:39 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description jpe_45305 2005-04-27 01:50:14 UTC
Attempts to use esddsp from the esound port results in a bus error at the first attempt by the program to write a file (i.e. esddsp vi works until you use w) and gives a bus error immediately with programs such as xgalaga.  Under 4.11, with otherwise identical software installed from ports, it works as expected.


could not identify source of problem.  My theory is possibly incorrect typing of parameters passed to libc when not redirected by esddsp's libs.
How-To-Repeat: on 5.3 machine,
cd /usr/ports/audio/esound
make install
esd -tcp -port 5001 -as 30 -public -promiscuous &
set ESPEAKER localhost:5001
esddsp xgalaga
bus error
Comment 1 Joe Marcus Clarke freebsd_committer 2005-04-27 04:38:36 UTC
State Changed
From-To: open->closed

Fixed.  In the future, when you get crashes, please include a backtrace 
with debugging symbols.  See http://www.freebsd.org/gnome/docs/bugging.html 
for more details on creating adequate bug reports.