Bug 80454 - java/poseidon doesn't work with java/linux-sun-jdk14
java/poseidon doesn't work with java/linux-sun-jdk14
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: hq
Depends on:
  Show dependency treegraph
Reported: 2005-04-29 13:40 UTC by adam
Modified: 2005-07-25 17:22 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description adam 2005-04-29 13:40:02 UTC
poseidon-   A popular UML CASE tool
linux-sun-jdk- Sun Java Development Kit 1.4 for Linux
When using "poseidon for uml" from the company "gentleware" with the java-Version from linux-sun-jdk Port it hangs in the poseidon splash-screen at the point: "Installing language resources"

The upcomming windows from the license-Manager and so on are working.
After pressing the "Start Poseidon" the following steps are successful executed: "Booting MDR and MOF", "General Setup", "Loading UML 1.4".

On every system tested, the problem happens, but every other java-Application works well - for example: argouml or eclipse.

Thank you for your effort,
H. Adam

How-To-Repeat: Use poseidon-Port in combination with linux-sun-jdk.
Comment 1 Thierry Thomas freebsd_committer 2005-04-29 17:43:58 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports

Set category to ports.
Comment 2 Mark Linimon freebsd_committer 2005-04-29 20:01:22 UTC
Responsible Changed
From-To: freebsd-ports->freebsd-ports-bugs

Canonicalize assignment and clarify Synopsis.
Comment 3 hq freebsd_committer 2005-05-01 03:57:50 UTC
Responsible Changed
From-To: freebsd-ports-bugs->hq

I'll handle this.
Comment 4 hq freebsd_committer 2005-05-01 15:16:51 UTC
Dear maintainer,

Could you please report on this issue?


Comment 5 tux 2005-05-01 23:41:44 UTC
Herve Quiroz wrote:
> Dear maintainer,
> Could you please report on this issue?

it seems there is a bug in Poseidon.
I cannot fix it, but I'll submit it to Gentleware.

So long...

mail tux@pinguru.net
icq  123851585
web  http://arme-und-beine.de
Comment 6 herve.quiroz 2005-05-02 13:50:54 UTC
Hi Gerrit,

On Mon, May 02, 2005 at 12:41:44AM +0200, Gerrit Beine wrote:
> it seems there is a bug in Poseidon.
> I cannot fix it, but I'll submit it to Gentleware.

Thanks for the feedback.

Now, shall we forbid the use of this JDK by setting:

JAVA_VENDOR=	ibm bsdjava freebsd blackdown

Or maybe just a test to mark the port as IGNORE if the faulty JDK gets
chosen by bsd.java.mk (not much chance as the default JDK is

Comment 7 hq freebsd_committer 2005-06-10 19:09:18 UTC
State Changed
From-To: open->feedback

java/poseidon has just been updated to version 3.1 

Could you please report whether this issue is still relevant with the new 
Comment 8 adam 2005-07-01 12:42:43 UTC

the problem is still relevant with the new poseidon-Version. Even the
upcomming windows from the license-Manager doesnt show up anymore. The
application just hangs after start leaving the cpu in 100% load.
I also tested with linux-sun-jdk15, the application here works in
principle but crashes randomly.

Heiko Adam  
Bunatwiete 6 - App: 3.2.2.AB, D-21073 Hamburg
Phone:  +49 (40) 594 666 35    Mail:   adam@adamweb.de
Mobile: +49 (175) 877 14 86    Site:   www.adamweb.de
Mitgliedschaften: GI, VDI

 _|    _|_|_|    _|_|_|_|_|     Systemadministration IfM
 _|    _|        _|  _|  _|    Bundesstrasse 53, Raum 135
 _|    _|_|_|    _|  _|  _|         D-20146 Hamburg 
 _|    _|        _|      _|    Phone: +49 (40) 42838-7476 
 _|    _|        _|      _|   Mail: adam@ifm.uni-hamburg.de
Comment 9 hq freebsd_committer 2005-07-25 17:12:10 UTC
State Changed
From-To: feedback->closed

I just commited a patch to forbid any *-sun-jdk* 

Thanks for your contribution!