Bug 80843 - [patch] psm(4): Suggested fix for psm0 / handle driver load failure on some KVM's.
Summary: [patch] psm(4): Suggested fix for psm0 / handle driver load failure on some K...
Status: Closed Unable to Reproduce
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-doc (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-10 03:20 UTC by Harry Coin
Modified: 2014-11-24 19:48 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.74 KB, patch)
2005-05-10 03:20 UTC, Harry Coin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Harry Coin 2005-05-10 03:20:02 UTC
psm0, the PS/2 mouse driver, failed to load under all current versions of 5.4, but had no problem on the same box on 5.3.  Research showed that the KBD_RESETDELAY kernel option was too small to allow mice connected via a KVM (keyboard, mouse and monitor shared among several system boxes) to reset via the aux port on the atkbd driver. 

The doc change below shows how KVM users can cause psm0 to load under 5.4.

1) I notice that the psm0 documentation actually documents options that actually only are referenced in the atkbdc driver, and are not used in the psm driver at all, except via a prodcedure call.  That can't be good.

2) I agree it would be well to make the KBD_RESETDELAY option something folks can tune from the command line, over against having to compile and install a separate kernel.

3) It would be even better to have the KBD reset delay automagically increase by 50% each pass through a failed reset attempt and have debug writes noting it.  Even three or four times through the loop wouldn't cause a meaningful boot time delay, and the change wouldn't affect existing users at all.

HTH

Harry

How-To-Repeat:       Just boot.  Happens every time with the generic 5.4 kernel and Dlink KVM.
Comment 1 Remko Lodder freebsd_committer 2007-12-08 22:32:06 UTC
Responsible Changed
From-To: freebsd-doc->philip

hey Philip, I recall you did something with psm? Can you have a look at this please?
Comment 2 Philip Paeps freebsd_committer 2014-11-24 19:37:14 UTC
I haven't looked at input in ages.  It may well be that this can be closed as overcome by events.
Comment 3 Allan Jude freebsd_committer 2014-11-24 19:48:18 UTC
Unable to reproduce on current versions of FreeBSD using an Avocent IP-KVM