Bug 82420 - Update port: cad/brlcad
Summary: Update port: cad/brlcad
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Thierry Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-19 17:30 UTC by rsmith
Modified: 2005-07-03 10:09 UTC (History)
0 users

See Also:


Attachments
file.diff (3.46 KB, patch)
2005-06-19 17:30 UTC, rsmith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rsmith 2005-06-19 17:30:20 UTC
	New version of brlcad: 7.2.6. Is confirmed to build and run on
	amd64, so I removed that arch from the ones to IGNORE. Might also
	run on other 64-bit platforms, but I have been unable to test that.

Fix: Apply the following patch:
---------------------- patch brlcad-7.2.4 -> 7.2.6 ------------------------
Comment 1 Thierry Thomas freebsd_committer 2005-06-20 22:53:04 UTC
State Changed
From-To: open->feedback


1) There is a line beginning by '@unexec rm' in pkg-plist, 
but no corresponding '@exec'; then, when you install brlcad 
as a package by pkg_add, the file /usr/local/bin/mged is not 
installed. Perhaps could you install it as $PREFIX/bin/mged 
and add a '@exec ln'? 

2) Some @dirrm were missing, and portlint suggest to use 
%%DATADIR%%, could you please check the following patch? 

--- brlcad.diff begins here --- 
diff -urN cad/brlcad.orig/pkg-plist cad/brlcad/pkg-plist 
--- cad/brlcad.orig/pkg-plist	Mon Jun 20 23:48:30 2005 
+++ cad/brlcad/pkg-plist	Mon Jun 20 22:22:34 2005 
@@ -1254,45 +1254,45 @@ 
share/README.MacOSX 
share/anim.txt 
share/benchmark.tr 
-share/brlcad/db/axis.g 
-share/brlcad/db/bldg391.g 
-share/brlcad/db/boolean-ops.g 
-share/brlcad/db/castle.g 
-share/brlcad/db/cornell.g 
-share/brlcad/db/cray.g 
-share/brlcad/db/crod.g 
-share/brlcad/db/cube.g 
-share/brlcad/db/demo.g 
-share/brlcad/db/galileo.g 
-share/brlcad/db/havoc.g 
-share/brlcad/db/kman.g 
-share/brlcad/db/ktank.g 
-share/brlcad/db/lgt-test.g 
-share/brlcad/db/m35.g 
-share/brlcad/db/moss.g 
-share/brlcad/db/pic.g 
-share/brlcad/db/prim.g 
-share/brlcad/db/sphflake.g 
-share/brlcad/db/star.g 
-share/brlcad/db/tank_car.g 
-share/brlcad/db/terra.g 
-share/brlcad/db/truck.g 
-share/brlcad/db/wave.g 
-share/brlcad/db/woodsman.g 
-share/brlcad/db/world.g 
-share/brlcad/db/xmp.g 
-share/brlcad/pix/bldg391.log 
-share/brlcad/pix/bldg391.pix 
-share/brlcad/pix/m35.log 
-share/brlcad/pix/m35.pix 
-share/brlcad/pix/moss.log 
-share/brlcad/pix/moss.pix 
-share/brlcad/pix/sphflake.log 
-share/brlcad/pix/sphflake.pix 
-share/brlcad/pix/star.log 
-share/brlcad/pix/star.pix 
-share/brlcad/pix/world.log 
-share/brlcad/pix/world.pix 
+%%DATADIR%%/db/axis.g 
+%%DATADIR%%/db/bldg391.g 
+%%DATADIR%%/db/boolean-ops.g 
+%%DATADIR%%/db/castle.g 
+%%DATADIR%%/db/cornell.g 
+%%DATADIR%%/db/cray.g 
+%%DATADIR%%/db/crod.g 
+%%DATADIR%%/db/cube.g 
+%%DATADIR%%/db/demo.g 
+%%DATADIR%%/db/galileo.g 
+%%DATADIR%%/db/havoc.g 
+%%DATADIR%%/db/kman.g 
+%%DATADIR%%/db/ktank.g 
+%%DATADIR%%/db/lgt-test.g 
+%%DATADIR%%/db/m35.g 
+%%DATADIR%%/db/moss.g 
+%%DATADIR%%/db/pic.g 
+%%DATADIR%%/db/prim.g 
+%%DATADIR%%/db/sphflake.g 
+%%DATADIR%%/db/star.g 
+%%DATADIR%%/db/tank_car.g 
+%%DATADIR%%/db/terra.g 
+%%DATADIR%%/db/truck.g 
+%%DATADIR%%/db/wave.g 
+%%DATADIR%%/db/woodsman.g 
+%%DATADIR%%/db/world.g 
+%%DATADIR%%/db/xmp.g 
+%%DATADIR%%/pix/bldg391.log 
+%%DATADIR%%/pix/bldg391.pix 
+%%DATADIR%%/pix/m35.log 
+%%DATADIR%%/pix/m35.pix 
+%%DATADIR%%/pix/moss.log 
+%%DATADIR%%/pix/moss.pix 
+%%DATADIR%%/pix/sphflake.log 
+%%DATADIR%%/pix/sphflake.pix 
+%%DATADIR%%/pix/star.log 
+%%DATADIR%%/pix/star.pix 
+%%DATADIR%%/pix/world.log 
+%%DATADIR%%/pix/world.pix 
share/cvs.txt 
share/description.txt 
share/ged.tr 
@@ -1548,6 +1548,9 @@ 
@dirrm tclscripts/lib 
@dirrm tclscripts/geometree 
@dirrm tclscripts 
+@dirrm %%DATADIR%%/pix 
+@dirrm %%DATADIR%%/db 
+@dirrm %%DATADIR%% 
@dirrm share 
@dirrm sample_applications 
@dirrm pro-engineer/text/usascii/resource 
--- brlcad.diff ends here --- 

Regards, 



Comment 2 Thierry Thomas freebsd_committer 2005-06-20 22:53:04 UTC
Responsible Changed
From-To: freebsd-ports-bugs->thierry


Take it.
Comment 3 Thierry Thomas freebsd_committer 2005-06-21 21:18:45 UTC
On Tue 21 jun 05 at 19:08:59 +0200, Roland Smith <rsmith@xs4all.nl>
 wrote:
> > 1) There is a line beginning by '@unexec rm' in pkg-plist,
> > but no corresponding '@exec'; then, when you install brlcad
> > as a package by pkg_add, the file /usr/local/bin/mged is not
> > installed. Perhaps could you install it as $PREFIX/bin/mged
> > and add a '@exec ln'?
> 
> There is already a mged binary in $PREFIX/bin, so that won't work. What
> I will do, is change the makefile to copy mged.sh to
> $PREFIX/bin/mged.sh, add that to the packing list, and create a link.
> 
> > 2) Some @dirrm were missing, and portlint suggest to use
> > %%DATADIR%%, could you please check the following patch?
> 
> Applied. See appended plist and Makefile.


Thanks, but you forgot to install /usr/local/brlcad/bin/mged.sh ;)

And usually a 'diff -urN' is prefered: it's easier to see the changes.

Regards,
-- 
Th. Thomas.
Comment 4 erikg 2005-06-25 19:13:49 UTC
Greetings

There seems to be a few files missing....

.../brlcad/include/brlcad/config.h
.../brlcad/bin/cakeinclude.sh
.../brlcad/bin/copyright.sh
.../brlcad/bin/footer.sh
.../brlcad/bin/header.sh
.../brlcad/bin/ldAix.sh
.../brlcad/bin/make_deb.sh
.../brlcad/bin/make_dmg.sh
.../brlcad/bin/make_pkg.sh
.../brlcad/bin/make_rpm.sh
.../brlcad/bin/make_tar.sh
.../brlcad/bin/make_bz2.sh
.../brlcad/bin/make_tgz.sh
.../brlcad/bin/make_zip.sh
.../brlcad/bin/vers.sh
.../brlcad/html/ReleaseNotes/Rel5.0/Summary/index.htm
.../brlcad/html/manuals/Anim_Tutorial/Butler.html
.../brlcad/html/manuals/Anim_Tutorial/Murdza.html

otherwise, it looks good to me... going to have to keep a closer eye (no
freshmeat announcement)

thanks

	-Erik


On Thu, Jun 23, 2005 at 12:02:08AM +0200, Thierry Thomas wrote:
> Hello Erik,
> 
> Roland Smith has submitted a PR to upgrade brlcad: you can check it at
> <http://www.freebsd.org/cgi/query-pr.cgi?pr=82420>.
> 
> I have attached the latest diff, to make things easier; could you please
> check it?
> 
> Best regards,
> -- 
> Th. Thomas.

> diff -urN cad/brlcad.orig/Makefile cad/brlcad/Makefile
> --- cad/brlcad.orig/Makefile	Fri May 13 07:35:38 2005
> +++ cad/brlcad/Makefile	Wed Jun 22 22:17:02 2005
> @@ -6,7 +6,7 @@
>  #
>  
>  PORTNAME=	brlcad
> -PORTVERSION=	7.2.4
> +PORTVERSION=	7.2.6
>  CATEGORIES=	cad
>  MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
>  MASTER_SITE_SUBDIR=	brlcad
> @@ -200,13 +200,13 @@
>  BROKEN=		"Does not compile on FreeBSD-${OSREL}"
>  .endif
>  
> -.if ${ARCH} != i386
> +.if !(${ARCH} == i386 || ${ARCH} == amd64)
>  IGNORE=		Dumps core on ${ARCH}!
>  .endif
>  
>  .ifndef WITHOUT_OPTIMIZATION
>  CONFIGURE_ARGS+=	--disable-debug
> -.if !(${ARCH} == alpha || ${ARCH} == sparc64)
> +.if !(${ARCH} == alpha || ${ARCH} == sparc64 || ${ARCH} == amd64)
>  CONFIGURE_ARGS+=	--enable-optimized
>  .endif
>  .else
> @@ -228,6 +228,6 @@
>  		${WRKSRC}/mged.sh
>  
>  post-install:
> -	@${INSTALL_SCRIPT} ${WRKSRC}/mged.sh ${LOCALBASE}/bin/mged
> +	@${INSTALL_SCRIPT} ${WRKSRC}/mged.sh ${PREFIX}/bin/mged.sh
>  
>  .include <bsd.port.post.mk>
> diff -urN cad/brlcad.orig/distinfo cad/brlcad/distinfo
> --- cad/brlcad.orig/distinfo	Thu May 12 23:17:12 2005
> +++ cad/brlcad/distinfo	Mon Jun 20 22:16:10 2005
> @@ -1,2 +1,2 @@
> -MD5 (brlcad-7.2.4.tar.bz2) = e8a5939948cc6667e6a29e7ec4f74dfe
> -SIZE (brlcad-7.2.4.tar.bz2) = 17126828
> +MD5 (brlcad-7.2.6.tar.bz2) = d4e8b256e033740db78b16b28d3f7d8b
> +SIZE (brlcad-7.2.6.tar.bz2) = 17117541
> diff -urN cad/brlcad.orig/pkg-plist cad/brlcad/pkg-plist
> --- cad/brlcad.orig/pkg-plist	Thu May 12 23:18:24 2005
> +++ cad/brlcad/pkg-plist	Wed Jun 22 23:33:54 2005
> @@ -26,6 +26,7 @@
>  bin/awf
>  bin/azel
>  bin/bary
> +bin/benchmark
>  bin/binfo
>  bin/bot-bldxf
>  bin/bot-raw
> @@ -62,7 +63,6 @@
>  bin/cad_boundp
>  bin/cad_parea
>  bin/cadbug.sh
> -bin/cakeinclude.sh
>  bin/cat-fb
>  bin/cell-fb
>  bin/chan_add
> @@ -73,7 +73,6 @@
>  bin/comgeom-g
>  bin/contours
>  bin/conv-vg2g
> -bin/copyright.sh
>  bin/cray.sh
>  bin/crop
>  bin/cubitorle
> @@ -145,7 +144,6 @@
>  bin/fhor
>  bin/files-tape
>  bin/firpass
> -bin/footer.sh
>  bin/g-acad
>  bin/g-dxf
>  bin/g-euclid
> @@ -172,7 +170,6 @@
>  bin/graytorle
>  bin/halftone
>  bin/hd
> -bin/header.sh
>  bin/i-a
>  bin/i-d
>  bin/i-f
> @@ -188,22 +185,15 @@
>  bin/istat
>  bin/jack-g
>  bin/kurt
> -bin/ldAix.sh
>  bin/lgt
>  bin/loop
>  bin/mac-pix
>  bin/machinetype.sh
> -bin/make_bz2.sh
> -bin/make_deb.sh
> -bin/make_dmg.sh
> -bin/make_pkg.sh
> -bin/make_rpm.sh
> -bin/make_tar.sh
> -bin/make_tgz.sh
> -bin/make_zip.sh
>  bin/mcut
>  bin/mergechan
>  bin/mged
> +bin/mged.sh
> +@exec ln -s %D/%F %%LOCALBASE%%/bin/mged
>  bin/mk_bolt
>  bin/mk_gastank
>  bin/mk_handle
> @@ -227,6 +217,7 @@
>  bin/painttorle
>  bin/patch-g
>  bin/pcd-pix
> +bin/perf.sh
>  bin/picket_fence
>  bin/pipe
>  bin/pipetest
> @@ -435,7 +426,6 @@
>  bin/vcrtorle
>  bin/vdeck
>  bin/vegitation
> -bin/vers.sh
>  bin/viewpoint-g
>  bin/wall
>  bin/wasatchrle
> @@ -1266,6 +1256,45 @@
>  share/README.MacOSX
>  share/anim.txt
>  share/benchmark.tr
> +%%DATADIR%%/db/axis.g
> +%%DATADIR%%/db/bldg391.g
> +%%DATADIR%%/db/boolean-ops.g
> +%%DATADIR%%/db/castle.g
> +%%DATADIR%%/db/cornell.g
> +%%DATADIR%%/db/cray.g
> +%%DATADIR%%/db/crod.g
> +%%DATADIR%%/db/cube.g
> +%%DATADIR%%/db/demo.g
> +%%DATADIR%%/db/galileo.g
> +%%DATADIR%%/db/havoc.g
> +%%DATADIR%%/db/kman.g
> +%%DATADIR%%/db/ktank.g
> +%%DATADIR%%/db/lgt-test.g
> +%%DATADIR%%/db/m35.g
> +%%DATADIR%%/db/moss.g
> +%%DATADIR%%/db/pic.g
> +%%DATADIR%%/db/prim.g
> +%%DATADIR%%/db/sphflake.g
> +%%DATADIR%%/db/star.g
> +%%DATADIR%%/db/tank_car.g
> +%%DATADIR%%/db/terra.g
> +%%DATADIR%%/db/truck.g
> +%%DATADIR%%/db/wave.g
> +%%DATADIR%%/db/woodsman.g
> +%%DATADIR%%/db/world.g
> +%%DATADIR%%/db/xmp.g
> +%%DATADIR%%/pix/bldg391.log
> +%%DATADIR%%/pix/bldg391.pix
> +%%DATADIR%%/pix/m35.log
> +%%DATADIR%%/pix/m35.pix
> +%%DATADIR%%/pix/moss.log
> +%%DATADIR%%/pix/moss.pix
> +%%DATADIR%%/pix/sphflake.log
> +%%DATADIR%%/pix/sphflake.pix
> +%%DATADIR%%/pix/star.log
> +%%DATADIR%%/pix/star.pix
> +%%DATADIR%%/pix/world.log
> +%%DATADIR%%/pix/world.pix
>  share/cvs.txt
>  share/description.txt
>  share/ged.tr
> @@ -1521,6 +1550,9 @@
>  @dirrm tclscripts/lib
>  @dirrm tclscripts/geometree
>  @dirrm tclscripts
> +@dirrm %%DATADIR%%/pix
> +@dirrm %%DATADIR%%/db
> +@dirrm %%DATADIR%%
>  @dirrm share
>  @dirrm sample_applications
>  @dirrm pro-engineer/text/usascii/resource




-- 
        -Erik <erik@smluc.org> [http://math.smsu.edu/~erik]

The opinions expressed by me are not necessarily opinions. In all probability,
they are random rambling, and to be ignored. Failure to ignore may result in
severe boredom or confusion. Shake well before opening. Keep Refrigerated.
Comment 5 Thierry Thomas freebsd_committer 2005-06-27 20:19:27 UTC
On Sat 25 jun 05 at 20:13:49 +0200, Erik Greenwald <erikg@smluc.org>
 wrote:
> Greetings

Hello,

> There seems to be a few files missing....
> 
> .../brlcad/include/brlcad/config.h
> .../brlcad/bin/cakeinclude.sh
> .../brlcad/bin/copyright.sh
> .../brlcad/bin/footer.sh
> .../brlcad/bin/header.sh
> .../brlcad/bin/ldAix.sh
> .../brlcad/bin/make_deb.sh
> .../brlcad/bin/make_dmg.sh
> .../brlcad/bin/make_pkg.sh
> .../brlcad/bin/make_rpm.sh
> .../brlcad/bin/make_tar.sh
> .../brlcad/bin/make_bz2.sh
> .../brlcad/bin/make_tgz.sh
> .../brlcad/bin/make_zip.sh
> .../brlcad/bin/vers.sh
> .../brlcad/html/ReleaseNotes/Rel5.0/Summary/index.htm
> .../brlcad/html/manuals/Anim_Tutorial/Butler.html
> .../brlcad/html/manuals/Anim_Tutorial/Murdza.html
> 
> otherwise, it looks good to me... going to have to keep a closer eye (no
> freshmeat announcement)

Considering Roland's answer, do you approve the submitted patch?

Truly yours,
-- 
Th. Thomas.
Comment 6 Thierry Thomas freebsd_committer 2005-07-03 10:08:39 UTC
State Changed
From-To: feedback->closed


Committed, thanks!