Bug 83979 - update cad/impact port to version 1.6.1
Summary: update cad/impact port to version 1.6.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Herve Quiroz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-24 05:00 UTC by giffunip
Modified: 2005-08-29 19:00 UTC (History)
0 users

See Also:


Attachments
file.diff (1.37 KB, patch)
2005-07-24 05:00 UTC, giffunip
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description giffunip 2005-07-24 05:00:27 UTC
      Version 1.6.1 has several bugfixes and a general cleanup. The port was changed slightly to better conform to the Java porting standards.

Fix: Patch follows:
How-To-Repeat:       Still remaining is the problem of having this port work automatically with cad/gmsh and cad/linux-gid. I still don't know well how to tackle this without invading other ports' workspace, but it would make the port much better.
Comment 1 Herve Quiroz freebsd_committer 2005-08-09 17:18:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->hq

I'll handle this.
Comment 2 Hervé Quiroz 2005-08-09 17:37:34 UTC
Hi Pedro,

I made some more improvements to the port. Could you please review them?
The changes are the following:

- Add 'java' category
- Use INSTALL_DATA rather than CP
- Remove junk files before installing (*.bat)
- Use %%DATADIR%% in launcher scripts (already included in SUB_LIST by
  bsd.port.mk)
- Pass JAVA_VERSION to javavmwrapper in launcher scripts


Index: Makefile
===================================================================
RCS file: /home/ncvs/ports/cad/impact/Makefile,v
retrieving revision 1.1
diff -u -r1.1 Makefile
--- Makefile	4 Mar 2005 07:36:48 -0000	1.1
+++ Makefile	9 Aug 2005 16:36:54 -0000
@@ -7,8 +7,8 @@
 #
 
 PORTNAME=	impact
-PORTVERSION=	0.5.3
-CATEGORIES=	cad
+PORTVERSION=	0.6.1
+CATEGORIES=	cad java
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	${PORTNAME}
 DISTNAME=	Impact-${PORTVERSION}
@@ -22,20 +22,23 @@
 JAVA_VERSION=	1.4+
 NO_BUILD=	yes
 
+DATADIR=	${JAVASHAREDIR}/${PORTNAME}
 SUB_FILES=	impact impactgui
-SUB_LIST=	DIR=${PREFIX}/impact
 
 PLIST_FILES=	bin/impact bin/impactgui
 
+post-extract:
+	${FIND} ${WRKSRC} -name \*.bat -print -exec ${RM} {} \;
+
 do-install:
-	@${MKDIR} ${PREFIX}/impact
-	${CP} -R ${WRKSRC}/ ${PREFIX}/impact
+	cd ${WRKSRC} && ${FIND} . -type d -exec ${MKDIR} ${DATADIR}/{} \;
+	cd ${WRKSRC} && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
 	${INSTALL_SCRIPT} ${WRKDIR}/impact ${WRKDIR}/impactgui ${PREFIX}/bin
 
 post-install:
-	@${FIND} ${PREFIX}/impact ! -type d | \
+	@${FIND} ${DATADIR} ! -type d | \
 		${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
-	@${FIND} ${PREFIX}/impact -type d | ${SORT} -r | \
+	@${FIND} ${DATADIR} -type d | ${SORT} -r | \
 		${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
 
 .include <bsd.port.mk>
Index: distinfo
===================================================================
RCS file: /home/ncvs/ports/cad/impact/distinfo,v
retrieving revision 1.1
diff -u -r1.1 distinfo
--- distinfo	4 Mar 2005 07:36:48 -0000	1.1
+++ distinfo	9 Aug 2005 16:36:54 -0000
@@ -1,2 +1,2 @@
-MD5 (Impact-0.5.3.zip) = 45fbc9e4e17daeb7ff06d0118eb11298
-SIZE (Impact-0.5.3.zip) = 5150450
+MD5 (Impact-0.6.1.zip) = c06f34619bfe878fc8aa24f5f5c19d0a
+SIZE (Impact-0.6.1.zip) = 3670738
Index: files/impact.in
===================================================================
RCS file: /home/ncvs/ports/cad/impact/files/impact.in,v
retrieving revision 1.1
diff -u -r1.1 impact.in
--- files/impact.in	4 Mar 2005 07:36:48 -0000	1.1
+++ files/impact.in	9 Aug 2005 16:36:54 -0000
@@ -2,6 +2,6 @@
 #
 # $FreeBSD: ports/cad/impact/files/impact.in,v 1.1 2005/03/04 07:36:48 ijliao Exp $
 
-cd %%DIR%%/bin
-"%%LOCALBASE%%/bin/java" -Xmx500m run.Impact $1
+cd %%DATADIR%%/bin
+JAVA_VERSION="%%JAVA_VERSION" "%%LOCALBASE%%/bin/java" -Xmx500m run.Impact "$@"
 cd -
Index: files/impactgui.in
===================================================================
RCS file: /home/ncvs/ports/cad/impact/files/impactgui.in,v
retrieving revision 1.1
diff -u -r1.1 impactgui.in
--- files/impactgui.in	4 Mar 2005 07:36:48 -0000	1.1
+++ files/impactgui.in	9 Aug 2005 16:36:54 -0000
@@ -2,6 +2,6 @@
 #
 # $FreeBSD: ports/cad/impact/files/impactgui.in,v 1.1 2005/03/04 07:36:48 ijliao Exp $
 
-cd %%DIR%%/bin
-"%%LOCALBASE%%/bin/java" -Xmx500m gui.ImpactGUI
+cd %%DATADIR%%/bin
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -Xmx500m gui.ImpactGUI
 cd -
Comment 3 Herve Quiroz freebsd_committer 2005-08-09 17:49:15 UTC
State Changed
From-To: open->feedback

Original submitter asked for a review
Comment 4 Pedro F. Giffuni 2005-08-09 20:29:37 UTC
Hi Herve;

--- Herve Quiroz <herve.quiroz@esil.univ-mrs.fr> ha scritto: 

> Hi Pedro,
> 
> I made some more improvements to the port. Could you please review them?

Thanks! Please note that I didn't submit the original port though, I just made
a quick attempt to update it ;-).

> The changes are the following:
> 
> - Add 'java' category
OK
> - Use INSTALL_DATA rather than CP
OK
> - Remove junk files before installing (*.bat)
Bad idea: the .bat files are actually scripts for for cad/linux-gid. the .geo
stuff and probably some others are plugins for cad/gmsh. It's uncertain how
these should be installed: in tochnog I attempted to install the configuration
files in the directory where linux-gid expects them, I know think this stuff
should be left in DATADIR and softlinked by the linux-gid or gmsh port. 

> - Use %%DATADIR%% in launcher scripts (already included in SUB_LIST by
>   bsd.port.mk)
> - Pass JAVA_VERSION to javavmwrapper in launcher scripts
> 
OK.

While here I got to ask, do you have any opinion on the java warnings while
running this port? It seems to run fine but it's somewhat bothersome to have
all that verbosity.

thanks for the cleanups and for looking at this,

    Pedro.


		
___________________________________ 
Yahoo! Messenger: chiamate gratuite in tutto il mondo 
http://it.beta.messenger.yahoo.com
Comment 5 Hervé Quiroz 2005-08-17 14:31:04 UTC
Hi Pedro,

On Tue, Aug 09, 2005 at 09:29:37PM +0200, pfgshield-freebsd@yahoo.com wrote:
> > - Remove junk files before installing (*.bat)
> Bad idea: the .bat files are actually scripts for for cad/linux-gid. the .geo
> stuff and probably some others are plugins for cad/gmsh. It's uncertain how
> these should be installed: in tochnog I attempted to install the configuration
> files in the directory where linux-gid expects them, I know think this stuff
> should be left in DATADIR and softlinked by the linux-gid or gmsh port. 

Thanks for the information. I will update the patch accordingly.

> While here I got to ask, do you have any opinion on the java warnings while
> running this port? It seems to run fine but it's somewhat bothersome to have
> all that verbosity.

I have no idea either. I am not using the application so I don't know
whether this is the intended behavior or not.

FYI, the ports freeze will be active at least one more week...

Herve
Comment 6 Herve Quiroz freebsd_committer 2005-08-29 19:00:26 UTC
State Changed
From-To: feedback->closed

Patch commited with the discussed modifications. 

Thanks for your contribution!