Bug 84678 - [PATCH] fix build of audio/festival on 6.x and 7.x
Summary: [PATCH] fix build of audio/festival on 6.x and 7.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Trevor Johnson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-08 20:30 UTC by Jason E. Hale
Modified: 2005-09-15 01:44 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (700 bytes, patch)
2005-08-08 20:30 UTC, Jason E. Hale
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jason E. Hale 2005-08-08 20:30:13 UTC
audio/festival version 1.4.1_2 does not build on 6.x and 7.x due to missing
config files which are linked in the ports Makefile for 4.x and 5.x only. On 6.0, the build will fail
due to a missing /usr/ports/audio/festival/work/speech_tools/config/systems/ix86_FreeBSD6.0.mak file.
7.0 would probably fail due to a missing
/usr/ports/audio/festival/work/speech_tools/config/systems/ix86_FreeBSD7.0.mak file.

Fix: Here is a patch to the Makefile that will include 6.x and 7.x in the file linking.  The build and install
are successful on 6.0-BETA1 with this patch.
How-To-Repeat: try to build on 6.x or 7.x the build will fail.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2005-08-08 22:36:02 UTC
Responsible Changed
From-To: freebsd-ports-bugs->trevor

Over to maintainer.
Comment 2 Pav Lucistnik freebsd_committer 2005-09-15 01:44:43 UTC
State Changed
From-To: open->closed

Committed, thanks!