Bug 84681 - mod_fastcgi doesn't install with apache2
Summary: mod_fastcgi doesn't install with apache2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Sam Lawrance
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-08 21:20 UTC by Ben Calvert
Modified: 2005-10-02 09:09 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Calvert 2005-08-08 21:20:16 UTC
make install fails for www/mod_fastcgi when using apache2 with the following message:
-----------------------
$ make install
===>  Installing for mod_fastcgi-2.4.2
===>   Generating temporary packing list
===>  Checking if www/mod_fastcgi already installed
cd /usr/ports/www/mod_fastcgi/work/mod_fastcgi-2.4.2 ; /usr/local/sbin/apxs -i -a -n fastcgi mod_fastcgi.so
/usr/local/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/share/apache2/build/libtool' mod_fastcgi.so /usr/local/libexec/apache2
/usr/local/share/apache2/build/libtool --mode=install cp mod_fastcgi.so /usr/local/libexec/apache2/
cp mod_fastcgi.so /usr/local/libexec/apache2/mod_fastcgi.so
cp: mod_fastcgi.so: No such file or directory
apxs:Error: Command failed with rc=65536
Comment 1 bsdbug 2005-08-28 15:20:17 UTC
Having just come across this problem myself it is actually quite easy to 
fix.
The cause of the problem is that mod_fastcgi.so is being created in:
/usr/ports/www/mod_fastcgi/work/mod_fastcgi-2.4.2/.lib
The very first install command changes to:
/usr/ports/www/mod_fastcgi/work/mod_fastcgi-2.4.2 and then attempts to 
work on mod_fastcgi.so in that directory.

To do the install stage yourself:

cd /usr/ports/www/mod_fastcgi/work/mod_fastcgi-2.4.2
cp ./.lib/mod_fastcgi.so ./
/usr/local/sbin/apxs -i -a -n fastcgi mod_fastcgi.so

Regards,
Colin.
Comment 2 Sam Lawrance freebsd_committer 2005-09-01 01:15:10 UTC
State Changed
From-To: open->feedback

Asked maintainer to investigate 


Comment 3 Sam Lawrance freebsd_committer 2005-09-01 01:15:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lawrance

Track
Comment 4 Sam Lawrance freebsd_committer 2005-09-01 01:15:16 UTC
Dear maintainer of port www/mod_fastcgi, can you please investigate this
problem report:
http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/84681

Thanks!
Comment 5 Sam Lawrance freebsd_committer 2005-09-28 09:00:09 UTC
State Changed
From-To: feedback->analyzed

Maintainer has timed out.
Comment 6 Sam Lawrance freebsd_committer 2005-10-02 09:08:09 UTC
State Changed
From-To: analyzed->closed

A fix was committed.  The installation would have worked had 
you set WITH_APACHE2.