Bug 87848 - duplicate LATEST_LINK for net/cvsup[-without-gui] on amd64
Summary: duplicate LATEST_LINK for net/cvsup[-without-gui] on amd64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Polstra
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-22 18:50 UTC by Vasil Dimov
Modified: 2005-11-17 21:21 UTC (History)
1 user (show)

See Also:


Attachments
cvsup_dup.diff (592 bytes, patch)
2005-10-22 18:50 UTC, Vasil Dimov
no flags Details | Diff
file.diff (446 bytes, patch)
2005-10-22 18:50 UTC, Vasil Dimov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vasil Dimov 2005-10-22 18:50:11 UTC
On amd64 cvsup turns itself into cvsup-without-gui causing warnings
during make index and duplicate LATEST_LINK.

Fix: Many can be invented, but this one seems to be really simple.
How-To-Repeat: 
# uname -m
amd64
# make -C /usr/ports/net/cvsup -V LATEST_LINK
cvsup-without-gui
# make -C /usr/ports/net/cvsup-without-gui -V LATEST_LINK
cvsup-without-gui
Comment 1 Edwin Groothuis freebsd_committer 2005-10-22 18:51:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->jdp

Over to maintainer
Comment 2 Bjoern A. Zeeb freebsd_committer 2005-10-22 19:28:34 UTC
Responsible Changed
From-To: jdp->bz

Nice try - second shot; amd64 version is mine.
Comment 3 Bjoern A. Zeeb 2005-10-23 10:25:20 UTC
On Sat, 22 Oct 2005, Vasil Dimov wrote:

> On amd64 cvsup turns itself into cvsup-without-gui causing warnings
> during make index and duplicate LATEST_LINK.
>
> >Fix:
>
> Many can be invented, but this one seems to be really simple.

The problem is that X11 version is not supported on amd64 (and without
GUI version is only supported 'unofficially' using patches and backlevel
version).

It is intended that net/cvsup ist building the without-gui version
and I'd prefer to not touch more places (especially other ports like
net/cvsup-without-gui) just because of amd64.

Would following patch do the trick and be ok?


RCS file: /local/mirror/FreeBSD/r/pcvs/ports/net/cvsup/Makefile,v
retrieving revision 1.62
diff -u -p -r1.62 Makefile
--- Makefile    21 Sep 2005 05:33:21 -0000      1.62
+++ Makefile    23 Oct 2005 09:20:47 -0000
@@ -41,6 +41,9 @@ TARGET=               FBSD_SPARC64
 M3FLAGS+=      -DNOGUI
 BUILD_DEPENDS= ${PREFIX}/lib/m3/pkg/tcp/${TARGET}/libm3tcp.a:${PORTSDIR}/lang/ezm3
 PKGNAMESUFFIX= -without-gui
+.if !defined(WITHOUT_X11) && ${ARCH} == "amd64"
+NO_LATEST_LINK=        yes
+.endif
 COMMENT=       General network file distribution system optimized for CVS (non-GUI version)
 DESCR=         ${PKGDIR}/pkg-descr.nogui
 .else
Comment 4 Vasil Dimov 2005-10-24 08:38:57 UTC
On Sun, Oct 23, 2005 at 09:25:20AM +0000, Bjoern A. Zeeb wrote:
> On Sat, 22 Oct 2005, Vasil Dimov wrote:
> 
> > On amd64 cvsup turns itself into cvsup-without-gui causing warnings
> > during make index and duplicate LATEST_LINK.
> >
> > >Fix:
> >
> > Many can be invented, but this one seems to be really simple.
> 
> The problem is that X11 version is not supported on amd64 (and without
> GUI version is only supported 'unofficially' using patches and backlevel
> version).
> 
> It is intended that net/cvsup ist building the without-gui version
> and I'd prefer to not touch more places (especially other ports like
> net/cvsup-without-gui) just because of amd64.
> 
> Would following patch do the trick and be ok?
> 
> 
> RCS file: /local/mirror/FreeBSD/r/pcvs/ports/net/cvsup/Makefile,v
> retrieving revision 1.62
> diff -u -p -r1.62 Makefile
> --- Makefile    21 Sep 2005 05:33:21 -0000      1.62
> +++ Makefile    23 Oct 2005 09:20:47 -0000
> @@ -41,6 +41,9 @@ TARGET=               FBSD_SPARC64
>  M3FLAGS+=      -DNOGUI
>  BUILD_DEPENDS= ${PREFIX}/lib/m3/pkg/tcp/${TARGET}/libm3tcp.a:${PORTSDIR}/lang/ezm3
>  PKGNAMESUFFIX= -without-gui
> +.if !defined(WITHOUT_X11) && ${ARCH} == "amd64"
> +NO_LATEST_LINK=        yes
> +.endif
>  COMMENT=       General network file distribution system optimized for CVS (non-GUI version)
>  DESCR=         ${PKGDIR}/pkg-descr.nogui
>  .else
> 

This patch fixes the problem with LATEST_LINK, but warning during make
index is still emitted.

note that ``&& ${ARCH} == "amd64"'' is not necessary, because that
condition is always true:

if A || B {
	if !A && B {
		something
	}
}

is the same as

if A || B {
	if !A {
		something
	}
}

anyway, it improves readability in our case.
Comment 5 Bjoern A. Zeeb freebsd_committer 2005-10-24 08:52:43 UTC
On Mon, 24 Oct 2005, Vasil Dimov wrote:

>  This patch fixes the problem with LATEST_LINK, but warning during make
>  index is still emitted.

Good news.  I guess I cannot do anything more as said amd64 is not fully
(officially) supported. So I'll get that patch committed.

>  note that ``&& ${ARCH} == "amd64"'' is not necessary, because that
>  condition is always true:

yes but it's for "documentation purposes". Else no one would ever
understand they this is there;)
Comment 6 Bjoern A. Zeeb freebsd_committer 2005-10-24 11:30:25 UTC
Responsible Changed
From-To: bz->freebsd-ports-bugs

Can someone from the ports team please commit the proposed patch, 
I am not a ports committer.
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2005-10-25 17:31:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->jdp

Over to maintainer.
Comment 8 Florent Thoumie freebsd_committer 2005-11-17 21:21:30 UTC
State Changed
From-To: open->closed

Committed. Thanks!