Bug 87881 - Update port: sysutils/am-utils to 6.1.3
Summary: Update port: sysutils/am-utils to 6.1.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Andrej Zverev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-23 20:20 UTC by fmysh
Modified: 2005-12-29 21:42 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.46 KB, patch)
2005-10-23 20:20 UTC, fmysh
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description fmysh 2005-10-23 20:20:16 UTC
	Update to 6.1.3
Comment 1 Andrej Zverev freebsd_committer 2005-10-23 21:58:18 UTC
Responsible Changed
From-To: freebsd-ports-bugs->az

I'll take it.
Comment 2 Andrej Zverev freebsd_committer 2005-10-24 09:53:57 UTC
This port have build errors,could you check this ?


cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c conf_tok.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c am_ops.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amd.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_auto.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_direct.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_error.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_generic.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_host.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_link.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_linkx.c
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include -O -pipe    -O -pipe -c amfs_nfsl.c
amfs_nfsl.c: In function `amfs_nfsl_match':
amfs_nfsl.c:121: `nfs_ops' undeclared (first use in this function)
amfs_nfsl.c:121: (Each undeclared identifier is reported only once
amfs_nfsl.c:121: for each function it appears in.)
amfs_nfsl.c: In function `amfs_nfsl_init':
amfs_nfsl.c:145: `nfs_ops' undeclared (first use in this function)
amfs_nfsl.c: In function `amfs_nfsl_mount':
amfs_nfsl.c:164: `nfs_ops' undeclared (first use in this function)
amfs_nfsl.c: In function `amfs_nfsl_umount':
amfs_nfsl.c:183: `nfs_ops' undeclared (first use in this function)
amfs_nfsl.c: In function `amfs_nfsl_umounted':
amfs_nfsl.c:203: `nfs_ops' undeclared (first use in this function)
amfs_nfsl.c: In function `amfs_nfsl_ffserver':
amfs_nfsl.c:231: `nfs_ops' undeclared (first use in this function)
*** Error code 1

Also it contain error due configure stage. What do you think about it ?

configure: WARNING: nfs/nfsmount.h: present but cannot be compiled
configure: WARNING: nfs/nfsmount.h:     check for missing prerequisite headers?
configure: WARNING: nfs/nfsmount.h: see the Autoconf documentation
configure: WARNING: nfs/nfsmount.h:     section "Present But Cannot Be Compiled"
configure: WARNING: nfs/nfsmount.h: proceeding with the preprocessor's result
configure: WARNING: nfs/nfsmount.h: in the future, the compiler will take precedence
configure: WARNING:     ## ---------------------------------------------------------------------- ##
configure: WARNING:     ## Report this to https://bugzilla.am-utils.org/ or am-utils@am-utils.org ##
configure: WARNING:     ## ---------------------------------------------------------------------- ##
checking for nfs/nfsmount.h... yes



-- 
WBR,
Andrej
Comment 3 Andrej Zverev freebsd_committer 2005-10-24 09:55:34 UTC
State Changed
From-To: open->feedback

Build errors, working with originator
Comment 4 fmysh 2005-10-27 11:53:25 UTC
Hi Andrej, thank you for handling the PR.

I guess that this error is caused by the kernel that has no NFS feature.
In such environment configure script produces a wrong configuration.
I tested on 6.0-RC1 with "kldload nfs" and successfully built.

The following target may work on 5.x and later.
pre-configure:
         @/sbin/kldload nfsclient || ${TRUE}

--
Fumiyoshi


On 2005/10/24, at 17:53, Andrej Zverev wrote:

> This port have build errors,could you check this ?
>
>
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c conf_tok.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c am_ops.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amd.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_auto.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_direct.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_error.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_generic.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_host.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_link.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_linkx.c
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I../include   -I/usr/local/include  
> -O -pipe    -O -pipe -c amfs_nfsl.c
> amfs_nfsl.c: In function `amfs_nfsl_match':
> amfs_nfsl.c:121: `nfs_ops' undeclared (first use in this function)
> amfs_nfsl.c:121: (Each undeclared identifier is reported only once
> amfs_nfsl.c:121: for each function it appears in.)
> amfs_nfsl.c: In function `amfs_nfsl_init':
> amfs_nfsl.c:145: `nfs_ops' undeclared (first use in this function)
> amfs_nfsl.c: In function `amfs_nfsl_mount':
> amfs_nfsl.c:164: `nfs_ops' undeclared (first use in this function)
> amfs_nfsl.c: In function `amfs_nfsl_umount':
> amfs_nfsl.c:183: `nfs_ops' undeclared (first use in this function)
> amfs_nfsl.c: In function `amfs_nfsl_umounted':
> amfs_nfsl.c:203: `nfs_ops' undeclared (first use in this function)
> amfs_nfsl.c: In function `amfs_nfsl_ffserver':
> amfs_nfsl.c:231: `nfs_ops' undeclared (first use in this function)
> *** Error code 1
>
> Also it contain error due configure stage. What do you think about  
> it ?
>
> configure: WARNING: nfs/nfsmount.h: present but cannot be compiled
> configure: WARNING: nfs/nfsmount.h:     check for missing  
> prerequisite headers?
> configure: WARNING: nfs/nfsmount.h: see the Autoconf documentation
> configure: WARNING: nfs/nfsmount.h:     section "Present But Cannot  
> Be Compiled"
> configure: WARNING: nfs/nfsmount.h: proceeding with the  
> preprocessor's result
> configure: WARNING: nfs/nfsmount.h: in the future, the compiler  
> will take precedence
> configure: WARNING:     ##  
> ---------------------------------------------------------------------- 
>  ##
> configure: WARNING:     ## Report this to https://bugzilla.am- 
> utils.org/ or am-utils@am-utils.org ##
> configure: WARNING:     ##  
> ---------------------------------------------------------------------- 
>  ##
> checking for nfs/nfsmount.h... yes
>
>
>
> -- 
> WBR,
> Andrej
>
>
Comment 5 Pav Lucistnik freebsd_committer 2005-12-29 21:42:30 UTC
State Changed
From-To: feedback->closed

Committed, thanks! (Compiled here without problem.)