Bug 89009 - boost-1.33.0 depends on icu-3.2 and install icu-3.4
Summary: boost-1.33.0 depends on icu-3.2 and install icu-3.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Simon Barner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-14 15:30 UTC by Vladimir Guzma
Modified: 2005-11-14 18:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Guzma 2005-11-14 15:30:10 UTC
The latest version of icu is 3.4. But when boost searches for libs it looks for:
 LIB_DEPENDS+=   icuuc.32:${PORTSDIR}/devel/icu.
So if the icu3.2 is found, it will be upgraded to 3.4 and then boost fails, not finding icuuc.32 - which is from version 3.2.

Fix: 

Change Makefile to
LIB_DEPENDS+=   icuuc.34:${PORTSDIR}/devel/icu
How-To-Repeat: Deinstall icu, deinstall boost and do portinstall boost.
Comment 1 Simon Barner freebsd_committer 2005-11-14 16:07:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->barner

I'll take it.
Comment 2 Simon Barner freebsd_committer 2005-11-14 18:26:36 UTC
State Changed
From-To: open->closed

Committed. Thanks for reporting!