Bug 89023 - USE_BDB doesn't set name of Berkely dB, or location of the include directory
USE_BDB doesn't set name of Berkely dB, or location of the include directory
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Yen-Ming Lee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 17:20 UTC by Scot Hetzel
Modified: 2007-03-20 01:00 UTC (History)
0 users

See Also:


Attachments
database-patch (2.92 KB, text/plain)
2005-11-14 17:27 UTC, Scot Hetzel
no flags Details
sasl2-patch (1013 bytes, text/plain)
2005-11-14 17:27 UTC, Scot Hetzel
no flags Details
kdesdk3-patch (1.04 KB, text/plain)
2005-11-14 17:27 UTC, Scot Hetzel
no flags Details
databases.diff (4.07 KB, patch)
2005-11-18 16:06 UTC, Scot Hetzel
no flags Details | Diff
db-bsd.database.mk-diff (7.18 KB, text/plain)
2006-01-06 15:27 UTC, Scot Hetzel
no flags Details
db-ports.gz (43.54 KB, application/x-gzip)
2006-01-06 15:27 UTC, Scot Hetzel
no flags Details
db-ports.gz (50.03 KB, application/x-gzip)
2006-01-12 16:40 UTC, Scot Hetzel
no flags Details
UPDATING.dbx (1.36 KB, text/plain)
2006-01-12 16:40 UTC, Scot Hetzel
no flags Details
db-ports4.gz (50.20 KB, application/x-gzip)
2006-02-02 15:40 UTC, Scot Hetzel
no flags Details
db-changes (5.56 KB, text/plain)
2006-02-02 15:40 UTC, Scot Hetzel
no flags Details
UPDATING.dbx (1.36 KB, text/plain)
2006-02-02 15:40 UTC, Scot Hetzel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Scot Hetzel 2005-11-14 17:27:48 UTC
Attached is the patch to bsd.database.mk for USE_BDB to provide the
BDB_LIB_NAME and BDB_INCLUDE_DIR variables.  As well as dealing with
the WITH_BDB_VER variable.

Also, attached are patches to two ports that make use of the changes
provided in the bsd.database.mk patch.

I've CC the maintaines of these ports so that they can see how this
change affects their ports.
--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 2 Mark Linimon freebsd_committer 2005-11-14 18:15:47 UTC
Responsible Changed
From-To: freebsd-ports-bugs->vsevolod

Over to maintainer of bsd.database.mk for evaluation.
Comment 3 itetcu 2005-11-14 18:19:15 UTC
On Mon, 14 Nov 2005 11:27:48 -0600
Scot Hetzel <swhetzel@gmail.com> wrote:

> Attached is the patch to bsd.database.mk for USE_BDB to provide the
> BDB_LIB_NAME and BDB_INCLUDE_DIR variables.  As well as dealing with
> the WITH_BDB_VER variable.
> 
> Also, attached are patches to two ports that make use of the changes
> provided in the bsd.database.mk patch.
> 
> I've CC the maintaines of these ports so that they can see how this
> change affects their ports.


Many thanks.


-- 
IOnut
Unregistered ;) FreeBSD "user"
Comment 4 Scot Hetzel 2005-11-18 16:06:03 UTC
On 11/14/05, Scot Hetzel <swhetzel@gmail.com> wrote:
> Attached is the patch to bsd.database.mk for USE_BDB to provide the
> BDB_LIB_NAME and BDB_INCLUDE_DIR variables.  As well as dealing with
> the WITH_BDB_VER variable.
>

I came accross a problem with my first patch for USE_BDB in
bsd.database.mk.  Theere was no way to specify to build with a
specific version of BDB, when  WITH_BDB_VER and BROKEN_WITH_BDB are
set.  This would have caused users to have trouble building ports that
required a specific version.

I have worked arround the problem by adding WANT_BDB_VER.  What it
does is override any values assigned to WITH_BDB_VER or USE_BDB.  This
variable is then used to specify the version of Berkeley DB the port
needs to build with.

I have also gone thru the entire ports collection and have updated all
of the db* and sqlite* ports to use bsd.database.mk.

While I was going thru the BDB using ports, I ran across many
variables used to decide which BDB port to use.  I have added these
variables to USE_BDB, and have them set an IGNORE error that they have
been obsoleted.

I also found several ports that required USE_MYSQL|PGSQL and have
updated a few of them.

Should I submit the changes as one diff to the ports tree in one PR or
multiple PRs?

Scot

Attached is the diff to bsd.database.mk

--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 5 Vsevolod Stakhov freebsd_committer 2005-11-23 14:09:05 UTC
On Fri, 18 Nov 2005 10:06:03 -0600
Scot Hetzel <swhetzel@gmail.com> wrote:

> On 11/14/05, Scot Hetzel <swhetzel@gmail.com> wrote:
> > Attached is the patch to bsd.database.mk for USE_BDB to provide the
> > BDB_LIB_NAME and BDB_INCLUDE_DIR variables.  As well as dealing with
> > the WITH_BDB_VER variable.
> >
> I came accross a problem with my first patch for USE_BDB in
> bsd.database.mk.  Theere was no way to specify to build with a
> specific version of BDB, when  WITH_BDB_VER and BROKEN_WITH_BDB are
> set.  This would have caused users to have trouble building ports that
> required a specific version.
> 
> I have worked arround the problem by adding WANT_BDB_VER.  What it
> does is override any values assigned to WITH_BDB_VER or USE_BDB.  This
> variable is then used to specify the version of Berkeley DB the port
> needs to build with.
> 
> I have also gone thru the entire ports collection and have updated all
> of the db* and sqlite* ports to use bsd.database.mk.

Thank you for this work!
 
> While I was going thru the BDB using ports, I ran across many
> variables used to decide which BDB port to use.  I have added these
> variables to USE_BDB, and have them set an IGNORE error that they have
> been obsoleted.
> 
> I also found several ports that required USE_MYSQL|PGSQL and have
> updated a few of them.
> 
> Should I submit the changes as one diff to the ports tree in one PR or
> multiple PRs?

Please send changes as single PR and make CC to ports maintainers.
Comment 6 Scot Hetzel 2006-01-06 15:27:54 UTC
The db-bsd.database.mk-diff updates the functionality of USE_BDB to
return with the BDB_INCLUDE_DIR, BDB_LIB_NAME.

The db-ports.gz is a patch to all of the ports that were not using the
bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.

I have tested that all of these ports will build using
bsd.database.mk.  Maintainers please send in your approval for these
changes.

NOTE:
1. A few of the ports have additional patches that allow them to build
with newer version of Berkeley DB.
2. Create the security/xca/files directory before applying patch the
db-ports patch

Thanks,

Scot W. Hetzel
============================================================
Index: KNOBS
- Add BDB to KNOBS

Index: Mk/bsd.database.mk
  USE_BDB will return the first BDB version found, when it is defined as either:

  USE_BDB=yes
  USE_BDB=3+

  So when you have db41 and db43 installed, USE_BDB will set the port to db41.
  By defining WITH_BDB_HIGHEST when building the port, USE_BDB will
set the port to db43.

- Added BROKEN_WITH_BDB
  - var to set the version(s) of Berkeley DB that the port won't use/compile

- Added WANT_BDB_VAR
  - var that MAINTAINER can set to specify that the port will only use
a specific BDB port

- Added WITH_BDB_VER and <UNIQUENAME>_WITH_BDB_VER
  - WITH_BDB_VER is a global port variable to select the version of
BDB all ports will use
  - <UNIQUENAME>_WITH_BDB_VER is a port specific variable that
overrides WITH_BDB_VER
  NOTE: If a port uses WITH_BDB_VER after a '.include bsd.port.pre.mk' to select
  BDB version, then the port must add:

  .if defined(${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER)
  WITH_BDB_VER=	${${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER}
  .endif

  before '.include bsd.port.pre.mk'

- Added BDB_LIB_NAME and BDB_LIB_CXX_NAME
  - used to define the BDB library (i.e. db-4.2, db_cxx-4.2)

- Added BDB_INCLUDE_DIR and BDB_LIB_DIR
  - used to specify the location of the BDB headers and libraries

- Added OBSOLETE_BDB_VAR
  - used to define old variables that no longer select BDB or the BDB version.
    If a variable was used to select a BDB version, and is defined
when making the port,
    then the following message is displayed:

    Obsolete variable(s) ${BAD_VAR} use WITH_BDB_VER or
${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER
    to select the Berkeley DB version

    If the variable was used to add BDB as an option to LIB_DEPENDS
    (.i.e. OPTIONS=, WITH_BERKELEYDB), then the port defines IGNORE as either:

    Use 'make config' to enable Berkeley DB support.
	or
    Use WITH_BDB to enable Berkeley DB support.

    then bsd.database.mk adds the "Obsolete variable..." to IGNORE.

NOTE:  When creating a new port, try to minimize the use of:

USE_BDB=	yes
WITH_BDB_VER?=	3
.if ${WITH_BDB_VER} == 3
SET_SOME_VAR=	x
.elif ${WITH_BDB_VER} > 3
SET_SOME_VAR=	y
.endif

As it prevents the port from automatically detecting the available BDB
version that is installed
examples of ports that do require this are:

mail/lmtpd
mail/popular
misc/libhome
net/openldap22-server
net/openldap23-server

As they set variables to different values (i.e CONFIGURE_ARGS)

============================================================

Index: archivers/rpm4/Makefile
glewis@FreeBSD.org

	M archivers/rpm4/Makefile

Index: astro/roadmap/Makefile
nick@netdot.net

	M astro/roadmap/Makefile

Index: audio/libsndfile/Makefile
ahze@FreeBSD.org

	M audio/libsndfile/Makefile

Index: audio/lplayer/Makefile
sylvioc@gmail.com

	M audio/lplayer/Makefile

Index: audio/xmms-imms/Makefile
green@FreeBSD.org

	M audio/xmms-imms/Makefile

Index: chinese/libtabe/Makefile
kcwu@ck.tp.edu.tw

	M chinese/libtabe/Makefile

Index: chinese/p5-Lingua-ZH-TaBE/Makefile
clsung@FreeBSD.org

	M chinese/p5-Lingua-ZH-TaBE/Makefile

Index: chinese/xcin25/Makefile
kcwu@ck.tp.edu.tw

	M chinese/xcin25/Makefile

Index: chinese/xsim/Makefile
ports@FreeBSD.org

	M chinese/xsim/Makefile
	A chinese/xsim/files/patch-configure

Index: comms/kpsk/Makefile	1.0	http://kpsk.sourceforge.net
ports@FreeBSD.org

	M comms/kpsk/Makefile
   	A comms/kpsk/files/patch-kpsk_logcore.cpp - fix for Berkeley DB 4.1+

Index: databases/dbtool/Makefile	1.6	http://www.daemon.de/DBTOOL/
ports@FreeBSD.org
  - removed unneeded REINPLACE_CMDS
    - Author changed all occurances of stdin to from_stdin in version 1.5.
    - No '==' in configure script
  - Fails to build with Berkeley DB, caused by DB variable being
defined in dbtool.h
    and then used in <db.h> when <db_cxx.h> is included.
    FIXED: renamed DB and PW to DB_ENV_VAR and PW_ENV_VAR.

	M databases/dbtool/Makefile
	A databases/dbtool/files/patch-config.cc - fix Berkeley DB build
	A databases/dbtool/files/patch-dbtool.cc - fix Berkeley DB build
	A databases/dbtool/files/patch-dbtool.h - fix Berkeley DB build
	A databases/dbtool/files/patch-engine.cc - fix for Berkeley DB 4.1+

Index: databases/p5-BerkeleyDB/Makefile
clsung@FreeBSD.org

	M databases/p5-BerkeleyDB/Makefile

Index: databases/py-bsddb/Makefile
perky@FreeBSD.org

	M databases/py-bsddb/Makefile
	M databases/py-bsddb/files/setup.py

Index: databases/py-bsddb3/Makefile
perky@FreeBSD.org

	M databases/py-bsddb3/Makefile
	M databases/py-bsddb3/distinfo

Index: databases/rdfdb/Makefile	0.46	http://www.guha.com/rdfdb
ports@FreeBSD.org

	M databases/rdfdb/Makefile
	A databases/rdfdb/files/patch-librdf::db.c - fix for Berkeley DB 4.1+
	M databases/rdfdb/files/patch-makefile

Index: databases/ruby-bdb/Makefile
knu@FreeBSD.org

	M databases/ruby-bdb/Makefile

Index: deskutils/gtkjournal/Makefile
adamw@FreeBSD.org

	M deskutils/gtkjournal/Makefile

Index: deskutils/ktagebuch/Makefile
markus@FreeBSD.org

	M deskutils/ktagebuch/Makefile

Index: deskutils/logjam/Makefile
mike.patterson@unb.ca

	M deskutils/logjam/Makefile

Index: deskutils/mcatalog/Makefile
bsd-sharp-list@forge.novell.com

	M deskutils/mcatalog/Makefile

Index: devel/apr/Makefile	1.2.2	http://apr.apache.org
rodrigc@crodrigues.org
 - the configure script for apr-util, fails to find gdbm.
   FIXED: added APR_UTIL_CONF_ARGS+=--with_gdbm=${LOCALBASE},
 - side effect - causes the detection of Berkeley DB to use db4.3
   instead of db4.2 when both db4.2 and db4.3 are installed. Caused
   by the gdbm detection adding -I/usr/local/include to CPPFLAGS.
   FIXED: patched the gdbm detection routine to save the old CPPFLAGS,
   and then restoring the old CPPFLAGS, before trying to detect the next
   library (patch-apr-util_build_dbm.m4, patch-apr-util_configure).

	M devel/apr/Makefile
	A devel/apr/files/patch-apr-util_build_dbm.m4
	A devel/apr/files/patch-apr-util_configure

Index: devel/cvstrac/Makefile
bms@FreeBSD.org

	M devel/cvstrac/Makefile

Index: devel/ice/Makefile
shoesoft@gmx.net

	M devel/ice/Makefile
	M devel/ice/files/patch-Make.rules

Index: devel/kdesdk3/Makefile
kde@FreeBSD.org

	M devel/kdesdk3/Makefile

Index: devel/libopensync/Makefile
ahze@FreeBSD.org

	M devel/libopensync/Makefile

Index: devel/tcl-neo/Makefile
mi@aldan.algebra.com

	M devel/tcl-neo/Makefile

Index: dns/bind9-dlz/Makefile
dinoex@FreeBSD.org

	M dns/bind9-dlz/Makefile
	M dns/bind9-dlz/files/configure.bind9-dlz
	M dns/bind9-dlz/files/db42-bind922.patch - update to db43
	M dns/bind9-dlz/files/db42-bind931.patch - update to db43

Index: dns/fastresolve/Makefile
martin@matuska.org

	M dns/fastresolve/Makefile

Index: dns/powerdns/Makefile
tremere@cainites.net

	M dns/powerdns/Makefile

Index: editors/nvi-devel/Makefile
dd@FreeBSD.org

	M editors/nvi-devel/Makefile

Index: editors/poedit/Makefile
ports@FreeBSD.org

	M editors/poedit/Makefile

Index: finance/gnucash/Makefile
ports@FreeBSD.org
 - configure script fails to detect the db library, but does detect headers
   FIXED: Hard coded DB_LIBS in configure script, and then used post-patch
   to set DB_LIBS to the correct BDB_LIB_NAME.

	M finance/gnucash/Makefile
	M finance/gnucash/files/patch-configure

Index: finance/qhacc/Makefile
ports@FreeBSD.org

	M finance/qhacc/Makefile

Index: finance/qtstalker/Makefile
lioux@FreeBSD.org

	M finance/qtstalker/Makefile

Index: games/amy/Makefile
thorsten@tgreiner.net

	M games/amy/Makefile

Index: games/gcompris2/Makefile
gnome@FreeBSD.org

	M games/gcompris2/Makefile

Index: graphics/f-spot/Makefile
bsd-sharp-list@forge.novell.com

	M graphics/f-spot/Makefile

Index: lang/gambas/Makefile
thierry@FreeBSD.org

	M lang/gambas/Makefile

Index: lang/munger/Makefile
jimmy@jamesbailie.com

	M lang/munger/Makefile

Index: lang/pike72/Makefile	7.2.570	http://pike.roxen.com
kiwi@oav.net

	M lang/pike72/Makefile
	A lang/pike72/files/patch-modules_Mysql_mysql.c - fix for MySQL 4.1+

Index: lang/scriba/Makefile	2.0b0	http://www.scriptbasic.com
ports@FreeBSD.org

	M lang/scriba/Makefile
	M lang/scriba/files/patch-extensions-bdb-interface.c - fix for BDB 4.1+
	A lang/scriba/files/patch-extensions-mysql-interface.c - fix for MySQL 4.1+
	M lang/scriba/files/patch-make_gcc.jim

Index: lang/tinycobol/Makefile
ports@FreeBSD.org

	M lang/tinycobol/Makefile
	A lang/tinycobol/files/patch-configure

Index: mail/avenger/Makefile
dm+bugs+avenger@mailavenger.org

	M mail/avenger/Makefile

Index: mail/bmf/Makefile
seanc@FreeBSD.org

	M mail/bmf/Makefile

Index: mail/bogofilter/Makefile
matthias.andree@gmx.de

	M mail/bogofilter/Makefile

Index: mail/bogofilter-qdbm/Makefile
matthias.andree@gmx.de

	M mail/bogofilter-qdbm/Makefile

Index: mail/bogofilter-sqlite/Makefile
matthias.andree@gmx.de

	M mail/bogofilter-sqlite/Makefile

Index: mail/drac/Makefile
ports@FreeBSD.org

	M mail/drac/Makefile
	M mail/drac/files/patch-aa

Index: mail/dspam/Makefile
itetcu@people.tecnik93.com

	M mail/dspam/Makefile

Index: mail/dspam-devel/Makefile
itetcu@people.tecnik93.com

	M mail/dspam-devel/Makefile

Index: mail/exim/Makefile
krion@FreeBSD.org

	M mail/exim/Makefile

Index: mail/isync/Makefile
ports@FreeBSD.org

	M mail/isync/Makefile

Index: mail/kiltdown/Makefile
ports@FreeBSD.org

	M mail/kiltdown/Makefile

Index: mail/lmtpd/Makefile
kiwi@oav.net
 - if BDB is in libhome, and BDB is selected in lmtpd, setting WITH_BDB_VER has
   no effect as the version used in libhome is used.
 - if no BDB is in libhome, and BDB is selected in lmtpd, the compile will fail.
   FIXED
 - changed default BDB from db3 to db41, makes WITH_BDB_HIGHEST work
with this port.

	M mail/lmtpd/Makefile

Index: mail/mutt-devel/Makefile
udo.schweigert@siemens.com
 - When multiple versions of BDB 4.x are installed, and WITH_BDB_VER > 4, the
   library is set to -ldb4 instead of requested library. FIXED
 - unneeded patch files/patch-hcache-db, replaced by REINPLACE_CMD in post-patch

	M mail/mutt-devel/Makefile
	R mail/mutt-devel/patch-hcache-db

Index: mail/mutt-ng/Makefile
vsevolod@FreeBSD.org
 - When multiple versions of BDB 4.x are installed, and WITH_BDB_VER > 4, the
   library is set to -ldb4 instead of requested library.
   FIXED replaced by REINPLACE_CMD in post-patch

	M mail/mutt-ng/Makefile
	M mail/mutt-ng/files/patch-configure

Index: mail/perdition/Makefile
clement@FreeBSD.org
 - Add BDB_INCLUDE_DIR to CFLAGS
 - Set db library in post-patch
 - remove no longer needed patches

	M mail/perdition/Makefile
	R mail/perdition/files/patch-makebdb-Makefile.in
	R mail/perdition/files/patch-makebdb-makebdb.c
	R mail/perdition/files/patch-perdition-db-bdb-Makefile.in
	R mail/perdition/files/patch-perdition-db-bdb-perditiondb_bdb.h

Index: mail/popular/Makefile
pav@FreeBSD.org

	M mail/popular/Makefile
	M mail/popular/pkg-plist
	M mail/popular/files/patch-configure

Index: mail/postfix-current/Makefile
mnag@FreeBSD.org

	M mail/postfix-current/Makefile

Index: mail/prayer/Makefile
ports@FreeBSD.org

	M mail/prayer/Makefile

Index: mail/qsf/Makefile
ports@FreeBSD.org

	M mail/qsf/Makefile

Index: mail/sendmail/Makefile
dinoex@FreeBSD.org

	M mail/sendmail/Makefile

Index: mail/smx/Makefile
dinoex@FreeBSD.org

	M mail/smx/Makefile

Index: mail/spamprobe/Makefile
ports@FreeBSD.org

	M mail/spamprobe/Makefile

Index: misc/hotkeys/Makefile
amp0928@rit.edu

	M misc/hotkeys/Makefile

Index: misc/krecipes/Makefile
hank@millerfarm.com

	M misc/krecipes/Makefile

Index: misc/libhome/Makefile
kiwi@oav.net
 - changed default BDB from db3 to db41, makes WITH_BDB_HIGHEST work
with this port.

	M misc/libhome/Makefile

Index: net/cdonkey/Makefile	0.9.0	http://cdonkey.suche.org
ports@FreeBSD.org

	M net/cdonkey/Makefile
	A net/cdonkey/files/patch-db_macro.h - fix for BDB 4.2+

Index: net/dctc/Makefile	0.84.1	http://ac2i.homelinux.com/dctc
ports@FreeBSD.org
 - Fails to find db41 library. FIXED
 - Fails to find db_env_create in db-4.2. (db-4.2 port built with uniquenames)
   FIXED - added post-patch to change db_env_create to
db_env_create_4002 in configure

	M net/dctc/Makefile
	  net/dctc/files/fix-configure.in - add check for db$major$minor
	A net/dctc/files/patch-configure - add check for db$major$minor

Index: net/dctc-gui/Makefile	0.66	http://ac2i.homelinux.com/dctc
lioux@FreeBSD.org
 - Fails to find db41 library. FIXED
 - Fails to find db_env_create in db-4.2. (db-4.2 port built with uniquenames)
   FIXED - added post-patch to change db_env_create to
db_env_create_4002 in configure

	M net/dctc-gui/Makefile
	  net/dctc-gui/files/fix-configure.in - add check for db$major$minor
	A net/dctc-gui/files/patch-configure - add check for db$major$minor

Index: net/gift-openft/Makefile
shoesoft@gmx.net

	M net/gift-openft/Makefile
	M net/gift-openft/files/patch-configure

Index: net/gnunet/Makefile
ports@FreeBSD.org

	M net/gnunet/Makefile

Index: net/netatalk/Makefile	2.0.3	http://netatalk.sourceforge.net
marcus@FreeBSD.org

	M net/netatalk/Makefile
	  net/netatalk/files/fix-macros_db3-check.m4	- fix for BDB 4.3+
	A net/netatalk/files/patch-bin_cnid_cnid_index.c	- fix for BDB 4.3+
	M net/netatalk/files/patch-configure	- fix for BDB 4.3+
	A net/netatalk/files/patch-etc_cnid_dbd_dbif.c	- fix for BDB 4.3+

Index: net/openldap22-server/Makefile
vsevolod@FreeBSD.org

	M net/openldap22-server/Makefile

Index: net/openldap23-server/Makefile
vsevolod@FreeBSD.org

	M net/openldap23-server/Makefile

Index: net/rtg/Makefile
so14k@so14k.com

	M net/rtg/Makefile

Index: net/torrentflux/Makefile
ports@FreeBSD.org

	M net/torrentflux/Makefile

Index: net-im/jabberd/Makefile
kirk@strauser.com

	M net-im/jabberd/Makefile

Index: net-im/sulci/Makefile
dsh@vlink.ru

	M net-im/sulci/Makefile

Index: news/inn/Makefile	2.4.1	http://www.isc.org/products/INN
clement@FreeBSD.org

	M news/inn/Makefile
	M news/inn/files/patch-configure
	A news/inn/files/patch-frontends::ovdb_stat.c	- fix for BDB 4.3+
	A news/inn/files/patch-storage::ovdb::ovdb-private.h	- fix for BDB 4.2+
	A news/inn/files/patch-storage::ovdb::ovdb.c	- fix for BDB 4.3+

Index: news/inn-current/Makefile	20040118	http://www.isc.org/products/INN
clement@FreeBSD.org

	M news/inn-current/Makefile
	M news/inn-current/files/patch-configure
	A news/inn-current/files/patch-frontends::ovdb_stat.c	- fix for BDB 4.3+
	A news/inn-current/files/patch-storage::ovdb::ovdb.c	- fix for BDB 4.3+

Index: news/inn-stable/Makefile	20040707	http://www.isc.org/products/INN
clement@FreeBSD.org

	M news/inn-stable/Makefile
	M news/inn-stable/files/patch-configure
	A news/inn-stable/files/patch-frontends::ovdb_stat.c	- fix for BDB 4.3+
	A news/inn-stable/files/patch-storage::ovdb::ovdb.c	- fix for BDB 4.3+

Index: news/klibido/Makefile
conrads@cox.net

	M news/klibido/Makefile

Index: print/panda/Makefile
ports@FreeBSD.org
 - Fails to find db_create in db-4.2. (db-4.2 port built with uniquenames)
   FIXED - added post-patch to change db_create to db_create_4002 in configure
 - Add BDB_INCLUDE_DIR to CPPFLAGS and BDB_LIB_DIR to LDFLAGS
 - No longer need to patch the configure script, due to post-patch
replacing -ldb

	M print/panda/Makefile
	R print/panda/files/patch-configure

Index: security/cyrus-sasl2/Makefile
ume@FreeBSD.org

	M security/cyrus-sasl2/Makefile

Index: security/cyrus-sasl2-saslauthd/Makefile
ume@FreeBSD.org

	M security/cyrus-sasl2-saslauthd/Makefile

Index: security/finger_mysql/Makefile
onatan@gmail.com

	M security/finger_mysql/Makefile

Index: security/pks/Makefile
gtodd@bellanet.org

	M security/pks/Makefile

Index: security/sks/Makefile
johans@stack.nl

	M security/sks/Makefile

Index: security/xca/Makefile	0.5.1	http://www.hohnstaedt.de/xca.html
curly@e-card.bg

	M security/xca/Makefile
	A security/xca/files/patch-widgets::MainWindow.cpp - fix for BDB 4.3+
	A security/xca/files/patch-widgets::MainWindow.h - fix for BDB 4.3+

Index: sysutils/bacula-server/Makefile
Lars.Koeller@Uni-Bielefeld.DE

	M sysutils/bacula-server/Makefile

Index: sysutils/cfengine2/Makefile
sergei@FreeBSD.org
 - when multiple db* are installed, port would link with db41 and db
   specified by WITH_BDB_VER.
   FIXED: Fixed with post-patch of configure script

	M sysutils/cfengine2/Makefile

Index: sysutils/sge/Makefile
brooks@FreeBSD.org
 - fix build for other versions of Berkeley DB besides 4.2

	M sysutils/sge/Makefile
	M sysutils/sge/pkg-plist
	M sysutils/sge/files/aimk.private
	M sysutils/sge/files/patch-scripts_distinst

Index: textproc/modlogan/Makefile
netchild@FreeBSD.org

	M textproc/modlogan/Makefile

Index: textproc/redland/Makefile
chuck@pkix.net

	M textproc/redland/Makefile

Index: textproc/refdb/Makefile
paulh@logicsquad.net

	M textproc/refdb/Makefile

Index: www/crawl/Makefile
petef@FreeBSD.org
 - crawl wasn't building with any version of db*, due to it patching
   wrong file (configure.in instead of configure). FIXED

	M www/crawl/Makefile

Index: www/dpsearch/Makefile
ports@FreeBSD.org

	M www/dpsearch/Makefile

Index: www/mnogosearch/Makefile
lawrance@FreeBSD.org

	M www/mnogosearch/Makefile

Index: www/mnogosearch31/Makefile
ports@FreeBSD.org

	M www/mnogosearch31/Makefile

Index: www/mod_mysqluserdir/Makefile
apache@FreeBSD.org

	M www/mod_mysqluserdir/Makefile

Index: www/mod_v2h/Makefile
apache@FreeBSD.org

	M www/mod_v2h/Makefile

Index: www/oops/Makefile
marck@FreeBSD.org

	M www/oops/Makefile

Index: www/squidguard/Makefile	1.2.0	http://www.squidguard.org/
ports@tyfon.net
 - Fails to find db_version in db-4.2. (db-4.2 port built with uniquenames)
   FIXED - added post-patch to change db_version to db_version_4002 in configure
 - Use post-patch target to replace db library with BDB_LIB_NAME in configure

	M www/squidguard/Makefile
	R www/squidguard/files/patch-ab
	A www/squidguard/files/patch-src_main.c - fix for BDB 4.2
	A www/squidguard/files/patch-src_sgDB.c - fix for BDB 4.1+
Comment 7 rodrigc 2006-01-07 02:59:54 UTC
On Fri, Jan 06, 2006 at 09:27:54AM -0600, Scot Hetzel wrote:
> Maintainers please send in your approval for these
> changes.

Approved for devel/apr.

--
Craig Rodrigues        
rodrigc@crodrigues.org
Comment 8 dirk.meyer 2006-01-07 10:23:17 UTC
Thanks for the work,

but don't commit sendmail, smx or bind9-dlz.
all patches break the build of this ports.

sendmail:
 broken suffix (empy)
 broken inlcude (empty?)
 broken depedency (4.1 is requested)

smx:
 broken suffix (empty)
 broken inlcude (empty?)
 broken depedency (4.1 is requested)
 BDB 4.0 should not allowed

bind9-dlz:
 Thanks for reportion a bug, commited.
 we can not link with Mysql4 or Mysql5 (GPL license)
 there is no way to set restricted in this case.
 broken suffix (empty)
 broken inlcude (empty?)

kind regards Dirk

- Dirk Meyer, Im Grund 4, 34317 Habichtswald, Germany
- [dirk.meyer@dinoex.sub.org],[dirk.meyer@guug.de],[dinoex@FreeBSD.org]
Comment 9 kiwi 2006-01-07 11:26:22 UTC
Agreed with my ports :

mail/lmtpd
misc/libhome
lang/pike72
Comment 10 Scot Hetzel 2006-01-07 22:17:57 UTC
On 1/7/06, Dirk Meyer <dirk.meyer@dinoex.sub.org> wrote:
> Thanks for the work,
>
> but don't commit sendmail, smx or bind9-dlz.
> all patches break the build of this ports.
>
> sendmail:
>  broken suffix (empy)
>  broken inlcude (empty?)
>  broken depedency (4.1 is requested)
>
> smx:
>  broken suffix (empty)
>  broken inlcude (empty?)
>  broken depedency (4.1 is requested)
>  BDB 4.0 should not allowed
>
> bind9-dlz:
>  Thanks for reportion a bug, commited.
>  we can not link with Mysql4 or Mysql5 (GPL license)
>  there is no way to set restricted in this case.
>  broken suffix (empty)
>  broken inlcude (empty?)
>
> kind regards Dirk
>
Thanks for the report, I'll look into fixing these problems.

Scot

--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 11 brooks 2006-01-08 16:37:53 UTC
On Fri, Jan 06, 2006 at 09:27:54AM -0600, Scot Hetzel wrote:
> Maintainers please send in your approval for these
> changes.

Fine for sysutils/sge

-- Brooks
Comment 12 lofi freebsd_committer 2006-01-09 07:22:23 UTC
Scot Hetzel schrieb:
> The db-bsd.database.mk-diff updates the functionality of USE_BDB to
> return with the BDB_INCLUDE_DIR, BDB_LIB_NAME.
> 
> The db-ports.gz is a patch to all of the ports that were not using the
> bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.

Sorry for responding late, the kde@freebsd.org mailing list has been out
of order for a few days. There has been a large update to the KDE ports
in the meantime, you'll probably have to modify your patch to kdesdk a
little and also modify devel/kdevelop, as it has now grown a dependency
on db4 as well.

Cheers,
-- 
   ,_,   | Michael Nottebrock               | lofi@freebsd.org
 (/^ ^\) | FreeBSD - The Power to Serve     | http://www.freebsd.org
   \u/   | K Desktop Environment on FreeBSD | http://freebsd.kde.org
Comment 13 Adam Weinberger freebsd_committer 2006-01-09 07:40:30 UTC
Whatever you think is best to do with my ports, please do.

# Adam


-- 
Adam Weinberger
adamw@magnesium.net || adamw@FreeBSD.org
adamw@vectors.cx    ||   adamw@gnome.org
http://www.vectors.cx
It's not stupid. It's "advanced."  -- Almighty Tallest
Comment 14 Scot Hetzel 2006-01-09 15:45:08 UTC
On 1/6/06, Henry Miller <hank@millerfarm.com> wrote:
> Actually looking at PR91361, it looks like this PR does the same thing.
> (krecipes can compile with either sqlite 2 or 3)
>

=3D=3D
PR 91361 was commited on 01/07/06.  My patch to misc/krecipies is no
longer required.

Scot
--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 15 Ralf van der Enden 2006-01-09 15:54:08 UTC
I agree with your changes for dns/powerdns

Regards,
Ralf
Comment 16 Thierry Thomas freebsd_committer 2006-01-09 18:13:48 UTC
On Fri  6 jan 06 at 16:27:54 +0100, Scot Hetzel <swhetzel@gmail.com>
 wrote:

> Index: lang/gambas/Makefile
> thierry@FreeBSD.org
> 
> 	M lang/gambas/Makefile


Agreed.
-- 
Th. Thomas.
Comment 17 conrads 2006-01-09 21:45:08 UTC
Please feel free to modify news/klibido.

Thanks!

-- 
Conrad J. Sabatier <conrads@cox.net> -- "In Unix veritas"
Comment 18 Scot Hetzel 2006-01-09 21:47:19 UTC
On 1/9/06, Graham Todd <gtodd@bellanet.org> wrote:
> I agree with changes for security/pks with these caveats:
>
> There are some CFLAGS+=3D and LIB_DEPENDS statements in security/pks/Make=
file
> that make it use bdb20. Bugs and/or compile problems were found in pks fo=
r
> later BDB versions (4.0 and 4.1) so this was seen a work around. After ed=
iting
> the Makefile to replace the LIB_DEPENDS and the CFLAGS+=3D lines with:
>
> USE_BDB=3D        2
>
> pks will compile so this should be added to the port Makefile. NB: with n=
o
> Berkley DB installed and using:
>
> USE_BDB=3D        YES
>
> the port pulls db41 (the default) and builds and it and pks; but pks link=
s
> against a db2-sleepycat that is included in the $WRKSRC directory
>

To default to a specific version of Berkeley DB you need to also add:

WANT_BDB_VER=3D 2

> There is a post-patch: section in the port Makefile to ${REINPLACE} the
> embedded db2 in the source Makefile.in with {$LOCALBASE}/include/db2 ... =
if
> that could be changed to point at the value of USE_BDB then it would all =
work
> out even better :)
>
:
>
> Sorry I haven't been able to figure out how to get the value of USE_BDB
> stuffed into the post-patch: section or the port Makefile.
>
You use ${BDB_LIB_NAME} and ${BDB_INCLUDE_DIR} in the post-patch.

Which is what the patch in db-ports does.  You also need a
Mk/bsd.database.mk that can define the values of the variables.
(You'll need to apply the db-bsd.database.mk-diff patch from
/usr/ports.)


--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 19 clsung freebsd_committer 2006-01-10 03:24:18 UTC
Approved for chinese/p5-Lingua-ZH-TaBE, databases/p5-BerkeleyDB
On Fri, Jan 06, 2006 at 09:27:54AM -0600, Scot Hetzel wrote:
> The db-bsd.database.mk-diff updates the functionality of USE_BDB to
> return with the BDB_INCLUDE_DIR, BDB_LIB_NAME.
> 
> The db-ports.gz is a patch to all of the ports that were not using the
> bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.
> 
> I have tested that all of these ports will build using
> bsd.database.mk.  Maintainers please send in your approval for these
> changes.
> 
> NOTE:
> 1. A few of the ports have additional patches that allow them to build
> with newer version of Berkeley DB.
> 2. Create the security/xca/files directory before applying patch the
> db-ports patch
> 
> Thanks,


-- 
Cheng-Lung Sung - clsung@
Comment 20 clement freebsd_committer 2006-01-10 14:52:02 UTC
On Fri, Jan 06, 2006 at 09:27:54AM -0600, Scot Hetzel wrote:
> The db-bsd.database.mk-diff updates the functionality of USE_BDB to
> return with the BDB_INCLUDE_DIR, BDB_LIB_NAME.
> 
> The db-ports.gz is a patch to all of the ports that were not using the
> bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.


Approved for clement@ and apache@ ports.

BTW I don't maintain perdition anymore, please contact new maintainer.

Thanks for your work.
clem
Comment 21 tmclaugh freebsd_committer 2006-01-11 00:23:16 UTC
On Fri, 2006-01-06 at 09:27 -0600, Scot Hetzel wrote:
<snip>
> 
> The db-ports.gz is a patch to all of the ports that were not using the
> bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.
> 
<snip>

The changes to deskutils/mcatalog and graphics/f-spot are fine with me.

Tom

-- 
| tmclaugh at sdf.lonestar.org             tmclaugh at FreeBSD.org |
| FreeBSD                                   http://www.FreeBSD.org |
| BSD#                    http://www.mono-project.com/Mono:FreeBSD |
Comment 22 itetcu 2006-01-11 22:01:44 UTC
On Fri, 6 Jan 2006 09:27:54 -0600
Scot Hetzel <swhetzel@gmail.com> wrote:

> The db-bsd.database.mk-diff updates the functionality of USE_BDB to
> return with the BDB_INCLUDE_DIR, BDB_LIB_NAME.
> 
> The db-ports.gz is a patch to all of the ports that were not using the
> bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.
> 
> I have tested that all of these ports will build using
> bsd.database.mk.  Maintainers please send in your approval for these
> changes.

It's OK for mail/dspam and mail/dspam-devel. Thanks for this work.

-- 
IOnut - Unregistered ;) FreeBSD "user"
  "Intellectual Property" is   nowhere near as valuable   as "Intellect"

After a time, you may find that "having" is not so pleasing a thing,
after all, as "wanting."  It is not logical, but it is often true.
		-- Spock, "Amok Time", stardate 3372.7
Comment 23 sergei freebsd_committer 2006-01-11 22:37:40 UTC
Scot,

On 2006-01-06 at 09:27 -0600, Scot Hetzel wrote:
> The db-ports.gz is a patch to all of the ports that were not using the
> bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.

Approved for sysutils/cfengine2 port. Thanks!

Sergei
Comment 24 Scot Hetzel 2006-01-12 16:40:37 UTC
Attached is a new patch the ports.  This patch includes all the
previous changes to the ports, plus the patches to KNOBS and
Mk/bsd.database.mk, as well as the following additional ports.

  M devel/kdesdk3/Makefile
+M devel/kdevelop/Makefile
+M mail/cyrus-imapd2/Makefile
+M mail/cyrus-imapd22/Makefile
+M mail/cyrus-imapd23/Makefile
+M mail/postfix/Makefile
+A mail/postfix/files/patch-src-util-dict_db.c
+M mail/postfix/scripts/configure.postfix
 M mail/postfix-current/Makefile
+A mail/postfix-current/files/patch-src::util::dict_db.c
+M mail/postfix1/Makefile
+A mail/postfix1/files/patch-src-util-dict_db.c
+M mail/postfix1/scripts/configure.postfix
+M mail/postfix21/Makefile
+A mail/postfix21/files/patch-src::util::dict_db.c
+M mail/postfix21/scripts/configure.postfix

Maintainers of these additional ports have been contacted, and
awaiting their approval.

Removed patch to misc/krecipes as another PR had already updated the port.

Also attached is some text to add to UPDATING.

Scot

On 1/6/06, Scot Hetzel <swhetzel@gmail.com> wrote:
> The db-bsd.database.mk-diff updates the functionality of USE_BDB to
> return with the BDB_INCLUDE_DIR, BDB_LIB_NAME.
>
> The db-ports.gz is a patch to all of the ports that were not using the
> bsd.database.mk to include the Berkeley, MySQL, and SQLITE ports.
>
> I have tested that all of these ports will build using
> bsd.database.mk.  Maintainers please send in your approval for these
> changes.
>
> NOTE:
> 1. A few of the ports have additional patches that allow them to build
> with newer version of Berkeley DB.
> 2. Create the security/xca/files directory before applying patch the
> db-ports patch
>
> Thanks,
>
> Scot W. Hetzel
> ============================================================
> Index: KNOBS
> - Add BDB to KNOBS
>
> Index: Mk/bsd.database.mk
>  USE_BDB will return the first BDB version found, when it is defined as either:
>
>  USE_BDB=yes
>  USE_BDB=3+
>
>  So when you have db41 and db43 installed, USE_BDB will set the port to db41.
>  By defining WITH_BDB_HIGHEST when building the port, USE_BDB will
> set the port to db43.
>
> - Added BROKEN_WITH_BDB
>  - var to set the version(s) of Berkeley DB that the port won't use/compile
>
> - Added WANT_BDB_VAR
>  - var that MAINTAINER can set to specify that the port will only use
> a specific BDB port
>
> - Added WITH_BDB_VER and <UNIQUENAME>_WITH_BDB_VER
>  - WITH_BDB_VER is a global port variable to select the version of
> BDB all ports will use
>  - <UNIQUENAME>_WITH_BDB_VER is a port specific variable that
> overrides WITH_BDB_VER
>  NOTE: If a port uses WITH_BDB_VER after a '.include bsd.port.pre.mk' to select
>  BDB version, then the port must add:
>
>  .if defined(${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER)
>  WITH_BDB_VER= ${${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER}
>  .endif
>
>  before '.include bsd.port.pre.mk'
>
> - Added BDB_LIB_NAME and BDB_LIB_CXX_NAME
>  - used to define the BDB library (i.e. db-4.2, db_cxx-4.2)
>
> - Added BDB_INCLUDE_DIR and BDB_LIB_DIR
>  - used to specify the location of the BDB headers and libraries
>
> - Added OBSOLETE_BDB_VAR
>  - used to define old variables that no longer select BDB or the BDB version.
>    If a variable was used to select a BDB version, and is defined
> when making the port,
>    then the following message is displayed:
>
>    Obsolete variable(s) ${BAD_VAR} use WITH_BDB_VER or
> ${UNIQUENAME:U:S,-,_,}_WITH_BDB_VER
>    to select the Berkeley DB version
>
>    If the variable was used to add BDB as an option to LIB_DEPENDS
>    (.i.e. OPTIONS=, WITH_BERKELEYDB), then the port defines IGNORE as either:
>
>    Use 'make config' to enable Berkeley DB support.
>        or
>    Use WITH_BDB to enable Berkeley DB support.
>
>    then bsd.database.mk adds the "Obsolete variable..." to IGNORE.
>
> NOTE:  When creating a new port, try to minimize the use of:
>
> USE_BDB=        yes
> WITH_BDB_VER?=  3
> .if ${WITH_BDB_VER} == 3
> SET_SOME_VAR=   x
> .elif ${WITH_BDB_VER} > 3
> SET_SOME_VAR=   y
> .endif
>
> As it prevents the port from automatically detecting the available BDB
> version that is installed
> examples of ports that do require this are:
>
> mail/lmtpd
> mail/popular
> misc/libhome
> net/openldap22-server
> net/openldap23-server
>
> As they set variables to different values (i.e CONFIGURE_ARGS)
>
> ============================================================
>
> Index: archivers/rpm4/Makefile
> glewis@FreeBSD.org
>
>        M archivers/rpm4/Makefile
>
> Index: astro/roadmap/Makefile
> nick@netdot.net
>
>        M astro/roadmap/Makefile
>
> Index: audio/libsndfile/Makefile
> ahze@FreeBSD.org
>
>        M audio/libsndfile/Makefile
>
> Index: audio/lplayer/Makefile
> sylvioc@gmail.com
>
>        M audio/lplayer/Makefile
>
> Index: audio/xmms-imms/Makefile
> green@FreeBSD.org
>
>        M audio/xmms-imms/Makefile
>
> Index: chinese/libtabe/Makefile
> kcwu@ck.tp.edu.tw
>
>        M chinese/libtabe/Makefile
>
> Index: chinese/p5-Lingua-ZH-TaBE/Makefile
> clsung@FreeBSD.org
>
>        M chinese/p5-Lingua-ZH-TaBE/Makefile
>
> Index: chinese/xcin25/Makefile
> kcwu@ck.tp.edu.tw
>
>        M chinese/xcin25/Makefile
>
> Index: chinese/xsim/Makefile
> ports@FreeBSD.org
>
>        M chinese/xsim/Makefile
>        A chinese/xsim/files/patch-configure
>
> Index: comms/kpsk/Makefile      1.0     http://kpsk.sourceforge.net
> ports@FreeBSD.org
>
>        M comms/kpsk/Makefile
>        A comms/kpsk/files/patch-kpsk_logcore.cpp - fix for Berkeley DB 4.1+
>
> Index: databases/dbtool/Makefile        1.6     http://www.daemon.de/DBTOOL/
> ports@FreeBSD.org
>  - removed unneeded REINPLACE_CMDS
>    - Author changed all occurances of stdin to from_stdin in version 1.5.
>    - No '==' in configure script
>  - Fails to build with Berkeley DB, caused by DB variable being
> defined in dbtool.h
>    and then used in <db.h> when <db_cxx.h> is included.
>    FIXED: renamed DB and PW to DB_ENV_VAR and PW_ENV_VAR.
>
>        M databases/dbtool/Makefile
>        A databases/dbtool/files/patch-config.cc - fix Berkeley DB build
>        A databases/dbtool/files/patch-dbtool.cc - fix Berkeley DB build
>        A databases/dbtool/files/patch-dbtool.h - fix Berkeley DB build
>        A databases/dbtool/files/patch-engine.cc - fix for Berkeley DB 4.1+
>
> Index: databases/p5-BerkeleyDB/Makefile
> clsung@FreeBSD.org
>
>        M databases/p5-BerkeleyDB/Makefile
>
> Index: databases/py-bsddb/Makefile
> perky@FreeBSD.org
>
>        M databases/py-bsddb/Makefile
>        M databases/py-bsddb/files/setup.py
>
> Index: databases/py-bsddb3/Makefile
> perky@FreeBSD.org
>
>        M databases/py-bsddb3/Makefile
>        M databases/py-bsddb3/distinfo
>
> Index: databases/rdfdb/Makefile 0.46    http://www.guha.com/rdfdb
> ports@FreeBSD.org
>
>        M databases/rdfdb/Makefile
>        A databases/rdfdb/files/patch-librdf::db.c - fix for Berkeley DB 4.1+
>        M databases/rdfdb/files/patch-makefile
>
> Index: databases/ruby-bdb/Makefile
> knu@FreeBSD.org
>
>        M databases/ruby-bdb/Makefile
>
> Index: deskutils/gtkjournal/Makefile
> adamw@FreeBSD.org
>
>        M deskutils/gtkjournal/Makefile
>
> Index: deskutils/ktagebuch/Makefile
> markus@FreeBSD.org
>
>        M deskutils/ktagebuch/Makefile
>
> Index: deskutils/logjam/Makefile
> mike.patterson@unb.ca
>
>        M deskutils/logjam/Makefile
>
> Index: deskutils/mcatalog/Makefile
> bsd-sharp-list@forge.novell.com
>
>        M deskutils/mcatalog/Makefile
>
> Index: devel/apr/Makefile       1.2.2   http://apr.apache.org
> rodrigc@crodrigues.org
>  - the configure script for apr-util, fails to find gdbm.
>   FIXED: added APR_UTIL_CONF_ARGS+=--with_gdbm=${LOCALBASE},
>  - side effect - causes the detection of Berkeley DB to use db4.3
>   instead of db4.2 when both db4.2 and db4.3 are installed. Caused
>   by the gdbm detection adding -I/usr/local/include to CPPFLAGS.
>   FIXED: patched the gdbm detection routine to save the old CPPFLAGS,
>   and then restoring the old CPPFLAGS, before trying to detect the next
>   library (patch-apr-util_build_dbm.m4, patch-apr-util_configure).
>
>        M devel/apr/Makefile
>        A devel/apr/files/patch-apr-util_build_dbm.m4
>        A devel/apr/files/patch-apr-util_configure
>
> Index: devel/cvstrac/Makefile
> bms@FreeBSD.org
>
>        M devel/cvstrac/Makefile
>
> Index: devel/ice/Makefile
> shoesoft@gmx.net
>
>        M devel/ice/Makefile
>        M devel/ice/files/patch-Make.rules
>
> Index: devel/kdesdk3/Makefile
> kde@FreeBSD.org
>
>        M devel/kdesdk3/Makefile
>
> Index: devel/libopensync/Makefile
> ahze@FreeBSD.org
>
>        M devel/libopensync/Makefile
>
> Index: devel/tcl-neo/Makefile
> mi@aldan.algebra.com
>
>        M devel/tcl-neo/Makefile
>
> Index: dns/bind9-dlz/Makefile
> dinoex@FreeBSD.org
>
>        M dns/bind9-dlz/Makefile
>        M dns/bind9-dlz/files/configure.bind9-dlz
>        M dns/bind9-dlz/files/db42-bind922.patch - update to db43
>        M dns/bind9-dlz/files/db42-bind931.patch - update to db43
>
> Index: dns/fastresolve/Makefile
> martin@matuska.org
>
>        M dns/fastresolve/Makefile
>
> Index: dns/powerdns/Makefile
> tremere@cainites.net
>
>        M dns/powerdns/Makefile
>
> Index: editors/nvi-devel/Makefile
> dd@FreeBSD.org
>
>        M editors/nvi-devel/Makefile
>
> Index: editors/poedit/Makefile
> ports@FreeBSD.org
>
>        M editors/poedit/Makefile
>
> Index: finance/gnucash/Makefile
> ports@FreeBSD.org
>  - configure script fails to detect the db library, but does detect headers
>   FIXED: Hard coded DB_LIBS in configure script, and then used post-patch
>   to set DB_LIBS to the correct BDB_LIB_NAME.
>
>        M finance/gnucash/Makefile
>        M finance/gnucash/files/patch-configure
>
> Index: finance/qhacc/Makefile
> ports@FreeBSD.org
>
>        M finance/qhacc/Makefile
>
> Index: finance/qtstalker/Makefile
> lioux@FreeBSD.org
>
>        M finance/qtstalker/Makefile
>
> Index: games/amy/Makefile
> thorsten@tgreiner.net
>
>        M games/amy/Makefile
>
> Index: games/gcompris2/Makefile
> gnome@FreeBSD.org
>
>        M games/gcompris2/Makefile
>
> Index: graphics/f-spot/Makefile
> bsd-sharp-list@forge.novell.com
>
>        M graphics/f-spot/Makefile
>
> Index: lang/gambas/Makefile
> thierry@FreeBSD.org
>
>        M lang/gambas/Makefile
>
> Index: lang/munger/Makefile
> jimmy@jamesbailie.com
>
>        M lang/munger/Makefile
>
> Index: lang/pike72/Makefile     7.2.570 http://pike.roxen.com
> kiwi@oav.net
>
>        M lang/pike72/Makefile
>        A lang/pike72/files/patch-modules_Mysql_mysql.c - fix for MySQL 4.1+
>
> Index: lang/scriba/Makefile     2.0b0   http://www.scriptbasic.com
> ports@FreeBSD.org
>
>        M lang/scriba/Makefile
>        M lang/scriba/files/patch-extensions-bdb-interface.c - fix for BDB 4.1+
>        A lang/scriba/files/patch-extensions-mysql-interface.c - fix for MySQL 4.1+
>        M lang/scriba/files/patch-make_gcc.jim
>
> Index: lang/tinycobol/Makefile
> ports@FreeBSD.org
>
>        M lang/tinycobol/Makefile
>        A lang/tinycobol/files/patch-configure
>
> Index: mail/avenger/Makefile
> dm+bugs+avenger@mailavenger.org
>
>        M mail/avenger/Makefile
>
> Index: mail/bmf/Makefile
> seanc@FreeBSD.org
>
>        M mail/bmf/Makefile
>
> Index: mail/bogofilter/Makefile
> matthias.andree@gmx.de
>
>        M mail/bogofilter/Makefile
>
> Index: mail/bogofilter-qdbm/Makefile
> matthias.andree@gmx.de
>
>        M mail/bogofilter-qdbm/Makefile
>
> Index: mail/bogofilter-sqlite/Makefile
> matthias.andree@gmx.de
>
>        M mail/bogofilter-sqlite/Makefile
>
> Index: mail/drac/Makefile
> ports@FreeBSD.org
>
>        M mail/drac/Makefile
>        M mail/drac/files/patch-aa
>
> Index: mail/dspam/Makefile
> itetcu@people.tecnik93.com
>
>        M mail/dspam/Makefile
>
> Index: mail/dspam-devel/Makefile
> itetcu@people.tecnik93.com
>
>        M mail/dspam-devel/Makefile
>
> Index: mail/exim/Makefile
> krion@FreeBSD.org
>
>        M mail/exim/Makefile
>
> Index: mail/isync/Makefile
> ports@FreeBSD.org
>
>        M mail/isync/Makefile
>
> Index: mail/kiltdown/Makefile
> ports@FreeBSD.org
>
>        M mail/kiltdown/Makefile
>
> Index: mail/lmtpd/Makefile
> kiwi@oav.net
>  - if BDB is in libhome, and BDB is selected in lmtpd, setting WITH_BDB_VER has
>   no effect as the version used in libhome is used.
>  - if no BDB is in libhome, and BDB is selected in lmtpd, the compile will fail.
>   FIXED
>  - changed default BDB from db3 to db41, makes WITH_BDB_HIGHEST work
> with this port.
>
>        M mail/lmtpd/Makefile
>
> Index: mail/mutt-devel/Makefile
> udo.schweigert@siemens.com
>  - When multiple versions of BDB 4.x are installed, and WITH_BDB_VER > 4, the
>   library is set to -ldb4 instead of requested library. FIXED
>  - unneeded patch files/patch-hcache-db, replaced by REINPLACE_CMD in post-patch
>
>        M mail/mutt-devel/Makefile
>        R mail/mutt-devel/patch-hcache-db
>
> Index: mail/mutt-ng/Makefile
> vsevolod@FreeBSD.org
>  - When multiple versions of BDB 4.x are installed, and WITH_BDB_VER > 4, the
>   library is set to -ldb4 instead of requested library.
>   FIXED replaced by REINPLACE_CMD in post-patch
>
>        M mail/mutt-ng/Makefile
>        M mail/mutt-ng/files/patch-configure
>
> Index: mail/perdition/Makefile
> clement@FreeBSD.org
>  - Add BDB_INCLUDE_DIR to CFLAGS
>  - Set db library in post-patch
>  - remove no longer needed patches
>
>        M mail/perdition/Makefile
>        R mail/perdition/files/patch-makebdb-Makefile.in
>        R mail/perdition/files/patch-makebdb-makebdb.c
>        R mail/perdition/files/patch-perdition-db-bdb-Makefile.in
>        R mail/perdition/files/patch-perdition-db-bdb-perditiondb_bdb.h
>
> Index: mail/popular/Makefile
> pav@FreeBSD.org
>
>        M mail/popular/Makefile
>        M mail/popular/pkg-plist
>        M mail/popular/files/patch-configure
>
> Index: mail/postfix-current/Makefile
> mnag@FreeBSD.org
>
>        M mail/postfix-current/Makefile
>
> Index: mail/prayer/Makefile
> ports@FreeBSD.org
>
>        M mail/prayer/Makefile
>
> Index: mail/qsf/Makefile
> ports@FreeBSD.org
>
>        M mail/qsf/Makefile
>
> Index: mail/sendmail/Makefile
> dinoex@FreeBSD.org
>
>        M mail/sendmail/Makefile
>
> Index: mail/smx/Makefile
> dinoex@FreeBSD.org
>
>        M mail/smx/Makefile
>
> Index: mail/spamprobe/Makefile
> ports@FreeBSD.org
>
>        M mail/spamprobe/Makefile
>
> Index: misc/hotkeys/Makefile
> amp0928@rit.edu
>
>        M misc/hotkeys/Makefile
>
> Index: misc/krecipes/Makefile
> hank@millerfarm.com
>
>        M misc/krecipes/Makefile
>
> Index: misc/libhome/Makefile
> kiwi@oav.net
>  - changed default BDB from db3 to db41, makes WITH_BDB_HIGHEST work
> with this port.
>
>        M misc/libhome/Makefile
>
> Index: net/cdonkey/Makefile     0.9.0   http://cdonkey.suche.org
> ports@FreeBSD.org
>
>        M net/cdonkey/Makefile
>        A net/cdonkey/files/patch-db_macro.h - fix for BDB 4.2+
>
> Index: net/dctc/Makefile        0.84.1  http://ac2i.homelinux.com/dctc
> ports@FreeBSD.org
>  - Fails to find db41 library. FIXED
>  - Fails to find db_env_create in db-4.2. (db-4.2 port built with uniquenames)
>   FIXED - added post-patch to change db_env_create to
> db_env_create_4002 in configure
>
>        M net/dctc/Makefile
>          net/dctc/files/fix-configure.in - add check for db$major$minor
>        A net/dctc/files/patch-configure - add check for db$major$minor
>
> Index: net/dctc-gui/Makefile    0.66    http://ac2i.homelinux.com/dctc
> lioux@FreeBSD.org
>  - Fails to find db41 library. FIXED
>  - Fails to find db_env_create in db-4.2. (db-4.2 port built with uniquenames)
>   FIXED - added post-patch to change db_env_create to
> db_env_create_4002 in configure
>
>        M net/dctc-gui/Makefile
>          net/dctc-gui/files/fix-configure.in - add check for db$major$minor
>        A net/dctc-gui/files/patch-configure - add check for db$major$minor
>
> Index: net/gift-openft/Makefile
> shoesoft@gmx.net
>
>        M net/gift-openft/Makefile
>        M net/gift-openft/files/patch-configure
>
> Index: net/gnunet/Makefile
> ports@FreeBSD.org
>
>        M net/gnunet/Makefile
>
> Index: net/netatalk/Makefile    2.0.3   http://netatalk.sourceforge.net
> marcus@FreeBSD.org
>
>        M net/netatalk/Makefile
>          net/netatalk/files/fix-macros_db3-check.m4    - fix for BDB 4.3+
>        A net/netatalk/files/patch-bin_cnid_cnid_index.c        - fix for BDB 4.3+
>        M net/netatalk/files/patch-configure    - fix for BDB 4.3+
>        A net/netatalk/files/patch-etc_cnid_dbd_dbif.c  - fix for BDB 4.3+
>
> Index: net/openldap22-server/Makefile
> vsevolod@FreeBSD.org
>
>        M net/openldap22-server/Makefile
>
> Index: net/openldap23-server/Makefile
> vsevolod@FreeBSD.org
>
>        M net/openldap23-server/Makefile
>
> Index: net/rtg/Makefile
> so14k@so14k.com
>
>        M net/rtg/Makefile
>
> Index: net/torrentflux/Makefile
> ports@FreeBSD.org
>
>        M net/torrentflux/Makefile
>
> Index: net-im/jabberd/Makefile
> kirk@strauser.com
>
>        M net-im/jabberd/Makefile
>
> Index: net-im/sulci/Makefile
> dsh@vlink.ru
>
>        M net-im/sulci/Makefile
>
> Index: news/inn/Makefile        2.4.1   http://www.isc.org/products/INN
> clement@FreeBSD.org
>
>        M news/inn/Makefile
>        M news/inn/files/patch-configure
>        A news/inn/files/patch-frontends::ovdb_stat.c   - fix for BDB 4.3+
>        A news/inn/files/patch-storage::ovdb::ovdb-private.h    - fix for BDB 4.2+
>        A news/inn/files/patch-storage::ovdb::ovdb.c    - fix for BDB 4.3+
>
> Index: news/inn-current/Makefile        20040118        http://www.isc.org/products/INN
> clement@FreeBSD.org
>
>        M news/inn-current/Makefile
>        M news/inn-current/files/patch-configure
>        A news/inn-current/files/patch-frontends::ovdb_stat.c   - fix for BDB 4.3+
>        A news/inn-current/files/patch-storage::ovdb::ovdb.c    - fix for BDB 4.3+
>
> Index: news/inn-stable/Makefile 20040707        http://www.isc.org/products/INN
> clement@FreeBSD.org
>
>        M news/inn-stable/Makefile
>        M news/inn-stable/files/patch-configure
>        A news/inn-stable/files/patch-frontends::ovdb_stat.c    - fix for BDB 4.3+
>        A news/inn-stable/files/patch-storage::ovdb::ovdb.c     - fix for BDB 4.3+
>
> Index: news/klibido/Makefile
> conrads@cox.net
>
>        M news/klibido/Makefile
>
> Index: print/panda/Makefile
> ports@FreeBSD.org
>  - Fails to find db_create in db-4.2. (db-4.2 port built with uniquenames)
>   FIXED - added post-patch to change db_create to db_create_4002 in configure
>  - Add BDB_INCLUDE_DIR to CPPFLAGS and BDB_LIB_DIR to LDFLAGS
>  - No longer need to patch the configure script, due to post-patch
> replacing -ldb
>
>        M print/panda/Makefile
>        R print/panda/files/patch-configure
>
> Index: security/cyrus-sasl2/Makefile
> ume@FreeBSD.org
>
>        M security/cyrus-sasl2/Makefile
>
> Index: security/cyrus-sasl2-saslauthd/Makefile
> ume@FreeBSD.org
>
>        M security/cyrus-sasl2-saslauthd/Makefile
>
> Index: security/finger_mysql/Makefile
> onatan@gmail.com
>
>        M security/finger_mysql/Makefile
>
> Index: security/pks/Makefile
> gtodd@bellanet.org
>
>        M security/pks/Makefile
>
> Index: security/sks/Makefile
> johans@stack.nl
>
>        M security/sks/Makefile
>
> Index: security/xca/Makefile    0.5.1   http://www.hohnstaedt.de/xca.html
> curly@e-card.bg
>
>        M security/xca/Makefile
>        A security/xca/files/patch-widgets::MainWindow.cpp - fix for BDB 4.3+
>        A security/xca/files/patch-widgets::MainWindow.h - fix for BDB 4.3+
>
> Index: sysutils/bacula-server/Makefile
> Lars.Koeller@Uni-Bielefeld.DE
>
>        M sysutils/bacula-server/Makefile
>
> Index: sysutils/cfengine2/Makefile
> sergei@FreeBSD.org
>  - when multiple db* are installed, port would link with db41 and db
>   specified by WITH_BDB_VER.
>   FIXED: Fixed with post-patch of configure script
>
>        M sysutils/cfengine2/Makefile
>
> Index: sysutils/sge/Makefile
> brooks@FreeBSD.org
>  - fix build for other versions of Berkeley DB besides 4.2
>
>        M sysutils/sge/Makefile
>        M sysutils/sge/pkg-plist
>        M sysutils/sge/files/aimk.private
>        M sysutils/sge/files/patch-scripts_distinst
>
> Index: textproc/modlogan/Makefile
> netchild@FreeBSD.org
>
>        M textproc/modlogan/Makefile
>
> Index: textproc/redland/Makefile
> chuck@pkix.net
>
>        M textproc/redland/Makefile
>
> Index: textproc/refdb/Makefile
> paulh@logicsquad.net
>
>        M textproc/refdb/Makefile
>
> Index: www/crawl/Makefile
> petef@FreeBSD.org
>  - crawl wasn't building with any version of db*, due to it patching
>   wrong file (configure.in instead of configure). FIXED
>
>        M www/crawl/Makefile
>
> Index: www/dpsearch/Makefile
> ports@FreeBSD.org
>
>        M www/dpsearch/Makefile
>
> Index: www/mnogosearch/Makefile
> lawrance@FreeBSD.org
>
>        M www/mnogosearch/Makefile
>
> Index: www/mnogosearch31/Makefile
> ports@FreeBSD.org
>
>        M www/mnogosearch31/Makefile
>
> Index: www/mod_mysqluserdir/Makefile
> apache@FreeBSD.org
>
>        M www/mod_mysqluserdir/Makefile
>
> Index: www/mod_v2h/Makefile
> apache@FreeBSD.org
>
>        M www/mod_v2h/Makefile
>
> Index: www/oops/Makefile
> marck@FreeBSD.org
>
>        M www/oops/Makefile
>
> Index: www/squidguard/Makefile  1.2.0   http://www.squidguard.org/
> ports@tyfon.net
>  - Fails to find db_version in db-4.2. (db-4.2 port built with uniquenames)
>   FIXED - added post-patch to change db_version to db_version_4002 in configure
>  - Use post-patch target to replace db library with BDB_LIB_NAME in configure
>
>        M www/squidguard/Makefile
>        R www/squidguard/files/patch-ab
>        A www/squidguard/files/patch-src_main.c - fix for BDB 4.2
>        A www/squidguard/files/patch-src_sgDB.c - fix for BDB 4.1+
>
>
>



--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 25 tmclaugh 2006-01-15 06:51:33 UTC
You can remove deskutils/mcatalog and graphics/f-spot from the patch.  I
just committed the changes while doing updates for those two ports.
Sorry for the confussion.

Tom

-- 
| tmclaugh at sdf.lonestar.org             tmclaugh at FreeBSD.org |
| FreeBSD                                   http://www.FreeBSD.org |
| BSD#                    http://www.mono-project.com/Mono:FreeBSD |
Comment 26 Scot Hetzel 2006-02-02 15:40:29 UTC
Attached is the updated patches.  Theses patches have been updated to
the latest FreeBSD ports (01-Feb-06).  The only changes between the
previous patch and this patch are:

1. BROKEN_WITH_BDB -> IGNORE_WITH_BDB
     I think the variable should be changed to IGNORE_BDB_VER as it's
meaning is clearer. If a commiter thinks this change is appropriate,
just sed the patch before applying it to the FreeBSD ports.

    sed -i .bak -e 's/IGNORE_WITH_BDB/IGNORE_BDB_VER/g' db-ports4

2. New port added (*/gnucash-docs). Fixed build with BDB.  The port
has a build dependancy on BDB (db4), but the configure script was
defaulting to using the base systems db instead of db4.  This resulted
in ldd not showing any db4 library linked to dbadd.

3. Added BDB_BUILD_DEPENDS variable.  This allows a port to specify a
build dependancy on the BDB libs, without requiring a library
dependancy.  Currently, it is only used by one port (*/gnucash-docs).

Scot

db-ports4.gz - The patch
db-changes  - cvs list of files that have been added/modified/removed
UPDATING.dbx - message to add to UPDATING about this change

--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 27 Yen-Ming Lee freebsd_committer 2006-04-03 07:04:36 UTC
Responsible Changed
From-To: vsevolod->leeym

I will take care of this PR.
Comment 28 dfilter freebsd_committer 2006-12-19 01:27:20 UTC
leeym       2006-12-19 01:27:09 UTC

  FreeBSD ports repository

  Modified files:
    www/squidguard       Makefile 
  Added files:
    www/squidguard/files patch-src_main.c patch-src_sgDB.c 
  Removed files:
    www/squidguard/files patch-ab 
  Log:
  - utilize USE_BDB
  
  PR:             89023
  
  Revision  Changes    Path
  1.15      +11 -3     ports/www/squidguard/Makefile
  1.3       +0 -28     ports/www/squidguard/files/patch-ab (dead)
  1.1       +14 -0     ports/www/squidguard/files/patch-src_main.c (new)
  1.1       +27 -0     ports/www/squidguard/files/patch-src_sgDB.c (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 29 dfilter freebsd_committer 2006-12-19 06:54:48 UTC
leeym       2006-12-19 06:54:42 UTC

  FreeBSD ports repository

  Modified files:
    misc/libhome         Makefile 
  Log:
  - utilize USE_BDB
  
  PR:             89023
  Submitted by:   swhetzel at gmail.com
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.15      +27 -19    ports/misc/libhome/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 30 dfilter freebsd_committer 2006-12-19 16:18:51 UTC
leeym       2006-12-19 16:18:44 UTC

  FreeBSD ports repository

  Modified files:
    mail/lmtpd           Makefile 
  Log:
  - utilize USE_BDB
  
  PR:             89023
  Submitted by:   swhetzel at gmail.com
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.19      +34 -15    ports/mail/lmtpd/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 31 dfilter freebsd_committer 2007-01-01 15:25:42 UTC
leeym       2007-01-01 15:25:35 UTC

  FreeBSD ports repository

  Modified files:
    security/pks         Makefile 
  Log:
  - utilize USE_BDB
  
  PR:             89023
  Submitted by:   swhetzel at gmail.com
  
  Revision  Changes    Path
  1.12      +5 -4      ports/security/pks/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 32 Yen-Ming Lee freebsd_committer 2007-03-20 01:00:17 UTC
State Changed
From-To: open->closed

Most of the ports depending on BerkeleyDB are now utilizing USE_BDB, so close this PR.