Bug 89393 - can't install OpenOffice 2.0.0 from port
Summary: can't install OpenOffice 2.0.0 from port
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-21 20:40 UTC by andrew
Modified: 2007-04-01 12:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrew 2005-11-21 20:40:22 UTC
As root, I compiled and installed the OpenOffice 2.0.0 port, using the options -DWITHOUT_MOZILLA -dWITH_KDE AND LOCALISED_LANG=en_UK
No obvious errors observed.

When I login as myself, and run openoffice.org-2.0.0, it goes thorugh the normal rigmarole. I select already registered A(I am, I have OO2.0 on a Windows box),
eventually it opens the normal wiondow. I close the window, and get a dialog popup saying "Error saving document File://home/andrew/.openoffice/user/bnasic/script.xlc: General Error. General input/output error".

There is also a button labeled "OK" and no button labelled "Oh, Shit" or "That Sucks" as found with certain other applications in similar circumstances. (Its definitely NOT OK!"

When you press the button, you get a similar message with the file "dialog.xlc"

I tried to report the problem at OpenOffice.org, but I have forgotten my password, and the "mail you a "change password" URL function does not work, so I cant login to report that the "mail you a "change password" URL function does not work"" (recursive error reporting stress is getting me down worse than nested quote stress - and all the diodes in my left leg ...).

Fix: 

No idea!
How-To-Repeat: It seems to happen every time. I cleaned, cvsup'ed, recompiled, reinstalled, and exactly the same happened.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2005-11-21 21:20:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer(s).
Comment 2 Erwin Lansing freebsd_committer 2006-11-25 12:19:25 UTC
State Changed
From-To: open->feedback

Is this still a problem after the recent upgrades?
Comment 3 Erwin Lansing freebsd_committer 2006-12-29 18:48:55 UTC
State Changed
From-To: feedback->closed

Feedback timeout. Let us know if you still experience problems.
Comment 4 Erwin Lansing freebsd_committer 2006-12-30 19:26:25 UTC
State Changed
From-To: closed->open

Reopen with feedback: 

I am concerned about the feedback-timeout - this is the first 
communication I have had about this - my ISP had problems and lost a 
lot of my e-mail, and accidentlaly altered my password so I could not 
log in for a bit. The timeout may be too short. 

I tried this afternoon to install openoffice on FreeBSD 6.2-PRERELEASE 
using 
portupgrade -NP openoffice 
and 
portupgrade -NP openoffice.org 

I also tried using sysinstall (post install configuration) 

Although it offers me choices of several versions, eg 
openoffice-1.0 
openoffice-1.1 
openoffice-2.0 

none of the choices will install. I am pretty sure the problem 
relates to confusion as to whether the port/package is called openoffice 
or openoffice.org 

I cannot attempt install from port at present owing to lack of HD space. 
- as fast as I get more disk space, it fills up :-{ 

PS I want a PACKAGE  for FreeBSD on UltraSparc - my U60 machine has 
insufficient space to compile openoffice too. Please! 

regards 

Andrew
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2007-04-01 12:23:57 UTC
State Changed
From-To: open->closed

openoffice has been updated many times since this PR was submitted.  I'm 
sorry that we did not handle it earlier.