Bug 89422 - comms/gnokii: post-build failure when postgresql is installed
Summary: comms/gnokii: post-build failure when postgresql is installed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-22 16:00 UTC by Scot Hetzel
Modified: 2005-11-30 00:53 UTC (History)
0 users

See Also:


Attachments
file.diff (869 bytes, patch)
2005-11-22 16:00 UTC, Scot Hetzel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scot Hetzel 2005-11-22 16:00:36 UTC
   The port fails to get past the post-build stage when databases/mysql*-client and databases/postgresql*-client are both installed (may also happen when only databases/postgresql*-client is installed).  The port gives the following error:

sed: 1: "s/^DB_LIBS = libfile.la ...": unescaped newline inside substitute pattern

Fix: The problem is a missing "/" at the end of the second -e expression for the REPLACE_CMD that is enabled when WITH_PGSQL is defined.
How-To-Repeat: Install both databases/mysql*-client and database/postgresql*-client.  Then build the port with WITH_SMSD defined.

# make configure -DWITH_SMSD
:
# make post-build -DWITH_SMSD
sed: 1: "s/^DB_LIBS = libfile.la ...": unescaped newline inside substitute pattern
*** Error code 1

Stop in /usr/ports/comms/gnokii.
Comment 1 Edwin Groothuis freebsd_committer 2005-11-22 16:03:13 UTC
Maintainer of comms/gnokii,

Please note that PR ports/89422 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/89422

-- 
Edwin Groothuis
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2005-11-22 16:03:18 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 3 Guido Falsi freebsd_committer 2005-11-22 18:55:08 UTC
On Tue, Nov 22, 2005 at 04:03:13PM +0000, Edwin Groothuis wrote:
> Maintainer of comms/gnokii,
> 
> Please note that PR ports/89422 has just been submitted.
> 
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
> 
> The full text of the PR can be found at:
>     http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/89422

Sorry, this got past me. I approve the patch.

-- 
Guido Falsi <mad@madpilot.net>
Comment 4 Sam Lawrance freebsd_committer 2005-11-30 00:53:51 UTC
State Changed
From-To: feedback->closed

Committed, thanks!