Bug 90073 - possible fix to unbreak biology/L-Breeder
possible fix to unbreak biology/L-Breeder
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 14:30 UTC by fernan
Modified: 2006-01-02 21:29 UTC (History)
1 user (show)

See Also:


Attachments
L-Breeder.diff (8.26 KB, patch)
2005-12-07 14:30 UTC, fernan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description fernan 2005-12-07 14:30:04 UTC
	
	
	L-Breeder is currently marked unfetchable:
	http://people.freebsd.org/~fenner/portsurvey/biology.html#L-Breeder

	So I tried to investigate the problem and I'm now submitting my
	homework so it doesn't get lost. 

	This is what I noticed:

	i) L-Breeder upstream sources have "stagnated for some time, but
	now a new simplified version is available" (sic, from the web
	site)

	So, the fetch issue is resolved. And the pkg-descr is also
	updated to reflect the new home page. However:	

	ii) L-Breeder is now called LBreeder. I have changed PORTNAME to
	reflect this, although I don't know if this is the right thing
	to do. Should the port be moved to biology/LBreeder? Or perhaps
	just leaving PORTNAME pointing to the old name and then work
	inside the Makefile to point the build/install to the correct
	name?

	iii) the sources have been reorganized so I have to update the
	port's Makefile to reflect this. The attached patch works for me
	under FreeBSD-4.11 (although it's possible that I may have missed a
	dependency if I already have a required library installed in my
	box. Sorry, I don't have a tinderbox-like setup to test builds)

	iv) the program does not have a version number, nor did I find
	one by looking inside the sources. To avoid changing too much
	the port I just left PORTVERSION at 1.0 and bumped PORTREVISION
	to 6
	
	Finally, do note that I am not a user of LBreeder, so I cannot
	test the program myself. I just noticed that by calling the
	executable I get a black X screen, that I can quit by
	pressing 'q' as documented in Readme.txt, but I can't tell
	myself if this is the expected behaviour. Nor do I know how to
	use the example files. Caveat emptor.
Comment 1 Edwin Groothuis freebsd_committer 2005-12-07 20:17:11 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 Edwin Groothuis freebsd_committer 2006-01-02 21:29:36 UTC
State Changed
From-To: feedback->closed

Committed, thanks!