Bug 90887 - missing dependency in munin-node
Summary: missing dependency in munin-node
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-24 21:30 UTC by anarcat+register
Modified: 2005-12-26 07:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description anarcat+register 2005-12-24 21:30:04 UTC
Munin-node fails to start miserably after an install, complaining about a missing Net/Server/Fork.pm module.

Fix: 

should be trivial enough to just add a dependency to net/p5-Net-Server.

Workaround: portinstall p5-Net-Server
How-To-Repeat: 
portinstall munin-node
echo 'munin_node_enable="YES"' >> /etc/rc.conf
/usr/local/etc/rc.d/munin-node.sh start
Comment 1 Lupe Christoph 2005-12-25 11:32:19 UTC
On Saturday, 2005-12-24 at 16:29:01 -0500, Antoine Beaupre wrote:

> >Number:         90887
> >Category:       ports
> >Synopsis:       missing dependency in munin-node
> >Confidential:   no
> >Severity:       serious
> >Priority:       medium
> >Responsible:    freebsd-ports-bugs
> >State:          open
> >Quarter:        
> >Keywords:       
> >Date-Required:
> >Class:          sw-bug
> >Submitter-Id:   current-users
> >Arrival-Date:   Sat Dec 24 21:30:04 GMT 2005
> >Closed-Date:
> >Last-Modified:
> >Originator:     Antoine Beaupre
> >Release:        FreeBSD 4.11-RELEASE-p13 i386
> >Organization:
> Koumbit Networks
> >Environment:
> System: FreeBSD lethe.koumbit.net 4.11-RELEASE-p13 FreeBSD 4.11-RELEASE-p13 #1: Wed Nov 9 00:57:31 EST 2005 anarcat@lethe.koumbit.net:/usr/obj/usr/src/sys/LETHE i386

> a moderatly recent ports collection.

> /var/db/pkg/perl-5.6.2_2 and use.perl port

> >Description:

> Munin-node fails to start miserably after an install, complaining about a missing Net/Server/Fork.pm module.

> >How-To-Repeat:

> portinstall munin-node
> echo 'munin_node_enable="YES"' >> /etc/rc.conf
> /usr/local/etc/rc.d/munin-node.sh start

> >Fix:

> should be trivial enough to just add a dependency to net/p5-Net-Server.

You mean like this?

RUN_DEPENDS=	${SITE_PERL}/Net/Server/Fork.pm:${PORTSDIR}/net/p5-Net-Server
BUILD_DEPENDS=	${RUN_DEPENDS}

Has been in Makefile since the very beginning. The problem is something else:

.if ${OSVERSION} < 500000
RUN_DEPENDS=	${LOCALBASE}/etc/rc.subr:${PORTSDIR}/sysutils/rc_subr
.endif

A '+' is missing. Can a port committer please add it with this patch?

--- Makefile.orig	Fri Nov  4 09:11:31 2005
+++ Makefile	Sun Dec 25 12:31:17 2005
@@ -7,6 +7,7 @@
 
 PORTNAME=	munin
 PORTVERSION=	1.2.4
+PORTREVISION=	1
 CATEGORIES=	sysutils perl5
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	munin
@@ -22,7 +23,7 @@
 .include <bsd.port.pre.mk>
 
 .if ${OSVERSION} < 500000
-RUN_DEPENDS=	${LOCALBASE}/etc/rc.subr:${PORTSDIR}/sysutils/rc_subr
+RUN_DEPENDS+=	${LOCALBASE}/etc/rc.subr:${PORTSDIR}/sysutils/rc_subr
 .endif
 
 .if ${PERL_LEVEL} < 500800

Thank you,
Lupe Christoph
-- 
| You know we're sitting on four million pounds of fuel, one nuclear     |
| weapon and a thing that has 270,000 moving parts built by the lowest   |
| bidder. Makes you feel good, doesn't it?                               |
| Rockhound in "Armageddon", 1998, about the Space Shuttle               |
Comment 2 Sergey Matveychuk freebsd_committer 2005-12-26 07:11:31 UTC
State Changed
From-To: open->closed

Committed. Thanks!