Bug 91906 - [ehci] [hang] FreeBSD hangs while booting with USB legacy support on (MSI 865PE Neo2-P)
Summary: [ehci] [hang] FreeBSD hangs while booting with USB legacy support on (MSI 865...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-17 14:30 UTC by Fred H
Modified: 2017-12-31 22:37 UTC (History)
0 users

See Also:


Attachments
dmesg.txt (6.48 KB, text/plain; x-mac-type="0"; x-mac-creator="0")
2007-01-31 09:49 UTC, warren
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fred H 2006-01-17 14:30:09 UTC
Hello,

I'm trying to install FreeBSD 6 on my computer but the system hangs during
the boot process.

The last line that appears on the screen is :
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xfebffc00-0xfebfffff irq 23 at device 29.7 on pci0

When I turn off the USB legacy support in BIOS, there is no problem.

But this is not a good solution for me because I have an USB keyboard.
So when I the legacy support is not active, I can't choose "Boot FreeBSD
with USB keyboard" in the loader...

My motherboard is a MSI 865PE Neo2-P (Intel 865PE chipset).

Thanks.

Fred H
Comment 1 warren 2007-01-31 09:49:10 UTC
Hi,

I also am having a similar problem and not sure whether to log a 
separate bug entry for this. In any case the problem is that I have 
tried to install FreeBSD 6.1 and FreeBSD 6.2 without any luck on a Dell 
OptiPlex 320. However it hangs in the boot process once it probes the 
usb port the usb keyboard is plugged into.

Details as follows:

ohci0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xdfff7000
ioapic0: routing intpin 16 (PCI IRQ16) to vector 50
ohci0: [GIANT-LOCKED]
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xdfff8000-0xdfff8fff irq 17 
at device 19.1 on pci0
ohci1: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xdfff8000
ioapic0: routing intpin 7 (PCI IRQ 17) to vector 51
ohci1: [GIANT-LOCKED]
usb1: OHCI version 1.0, legacy support

At this stage it just hangs.

If i boot the PC without the keyboard plugged in and then plug it in 
once all the usb ports have been probed by FreeBSD it then picks up the 
keyboard and I can install FreeBSD. That is the usb keyboard is plugged 
in after the following section in the boot phase:

usb5: waiting for BIOS to give up control
usb5: EHCI version 1.0
usb5: compnaion controllers, 2 ports each: usb0 usb1 usb2 usb4
usb5: <EHCI (generic) USB 2.0 controller> on ehci0
usb5: USB revision 2.0
uhub5: ATI EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub5: 10 ports with 10 removable, self powered
.
.
.
Obviously once it reboots, it hangs again in the same place if the 
keyboard is left in.
I cant test without USB legacy support as the Dell BIOS doesnt offer 
this option, nor have the luxury of trying to use a PS2 keyboard.
I have tried booting with safe mode as well, but no luck. I also tried 
creating a 6.1 ISO without OHCI support and just EHCI and UHCI support 
and still no luck.

I then recompiled the kernel and created a 6.1 ISO with just UHCI 
support (no EHCI or OHCI support) and the box then booted ok and i could 
install the OS.
I did not try this approach with 6.2, but im assuming ti would probably 
behave the same.

I have attached a dmesg from a successful 6.2 boot when the keyboard was 
plugged in after the usb ports had been probed (this is with the GENERIC 
kernel).
By the way I also notice that it reports a bad signature in the MP 
config table - which you can see in the dmesg. Please let me know if you 
need anything else.

Thanks,
Warren
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:07 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped