Bug 92414 - [patch] net/vnc Xvnc server doesn't run with XDMCP options
Summary: [patch] net/vnc Xvnc server doesn't run with XDMCP options
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-27 09:50 UTC by Akihiro KAYAMA
Modified: 2006-05-18 17:12 UTC (History)
0 users

See Also:


Attachments
file.diff (389 bytes, patch)
2006-01-27 09:50 UTC, Akihiro KAYAMA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Akihiro KAYAMA 2006-01-27 09:50:01 UTC
Xvnc, which is modified X server to draw desktop remotely with vnc
protocol, can be managed with X Display Manager via XDMCP when
combined with option -query. 

But FreeBSD port version of Xvnc seemed to fail to create a session
with xdm, due to xdm error "Decline No valid address".

Fix: This is because of an uninitialized variable bug of XFree 4.3.0 source
tree which current vnc port use. Simply apply the following patch, or
perhaps it is better choice to use fixed X source tree like X.org
6.9.0.
How-To-Repeat: execute xdm:
% /usr/X11R6/bin/xdm -debug 1

execute Xvnc server:
% /usr/local/bin/Xvnc :59 -query localhost -once  securitytypes=none Log='*:stderr:9'

Xvnc fails to start and outputs following error messages:
Fatal server error:
XDMCP fatal error: Session declined No valid address
Comment 1 Edwin Groothuis freebsd_committer 2006-01-27 09:56:41 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 Joerg Wunsch 2006-05-18 08:39:30 UTC
I've got the same problem, and found the patch submitted in the PR in
a mailing list entry (on the RealVNC list) via Google.  Tried it, and
it solved my problem as well.

Environment: FreeBSD 6.0
Xvnc started from inetd, as in the configuration example about
inetd mode that can be found in the RealVNC documentation.

I rebuilt the port with Akihiro-san's patch as a locally-added
patch file, and the problem went away.
-- 
cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)
Comment 3 Pav Lucistnik freebsd_committer 2006-05-18 17:12:46 UTC
State Changed
From-To: feedback->closed

Committed, thanks!