Bug 92445 - [patch] change all bogus uses of BROKEN to IGNORE
Summary: [patch] change all bogus uses of BROKEN to IGNORE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-28 04:40 UTC by Mark Linimon
Modified: 2006-07-05 03:42 UTC (History)
0 users

See Also:


Attachments
file.diff (9.02 KB, patch)
2006-01-28 04:40 UTC, Mark Linimon
no flags Details | Diff
file.diff (15.81 KB, patch)
2006-01-28 04:40 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2006-01-28 04:40:02 UTC
bsd.*.mk and friends have grown several cases where BROKEN is used where
IGNORE is really meant.  This causes the cluster to try to build certain
ports, when we already know it will not be possible to do so.  (As a
refresher: BROKEN implies temporary failure which the cluster should keep
trying to build in case it has gone away; IGNORE implies that there is an
incompatibility or some kind of conflict, and it makes no sense to try to
install.)

It turns out that most of the BROKEN_WITH_xyz assignements actually
correctly _set_ IGNORE internally now, but this confusing usage needs
to go away.

This needs to be tested on the cluster, but it also needs approval of
various maintainers as well.
Comment 1 gnats freebsd_committer 2006-01-28 04:42:43 UTC
Responsible Changed
From-To: freebsd-ports-bugs->portmgr

Requires testing on the cluster.
Comment 2 Kris Kennaway 2006-01-28 20:54:02 UTC
On Sat, Jan 28, 2006 at 04:42:58AM +0000, GNU GNATS wrote:
> Synopsis: [patch] change all bogus uses of BROKEN to IGNORE
> 
> Responsible-Changed-From-To: freebsd-ports-bugs->portmgr
> Responsible-Changed-By: gnats
> Responsible-Changed-When: Sat Jan 28 04:42:43 UTC 2006
> Responsible-Changed-Why: 
> Requires testing on the cluster.
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=92445


This has the same issue as the database patch, i.e. BROKEN strings
need to be reworded before they make sense as IGNORE strings.

Kris
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2006-02-01 23:13:07 UTC
State Changed
From-To: open->suspended

I need to rework this patch.
Comment 4 Mark Linimon 2006-06-20 06:11:48 UTC
Here is the latest version of the patch.  The latest changes in the tree
are reflected, as well as accepting the to-be-deprecated BROKEN_WITH_*
forms for a transition period.

mcl

Index: Mk/bsd.autotools.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.autotools.mk,v
retrieving revision 1.23
diff -u -r1.23 bsd.autotools.mk
--- Mk/bsd.autotools.mk	23 Feb 2006 10:43:34 -0000	1.23
+++ Mk/bsd.autotools.mk	19 Jun 2006 05:18:44 -0000
@@ -77,7 +77,7 @@
 # XXX: temporary to highlight any missed ports in the conversion
 #
 .if defined(AUTOTOOL_libtool_inc)
-BROKEN+=libtool:${AUTOTOOL_libtool_inc}:inc construct no longer available
+IGNORE+= error: libtool:${AUTOTOOL_libtool_inc}:inc construct no longer available
 .endif
 
 #---------------------------------------------------------------------------
@@ -100,7 +100,7 @@
 # Make sure we specified a legal version of automake
 #
 . if !exists(${PORTSDIR}/devel/automake${AUTOMAKE_VERSION}/Makefile)
-BROKEN+=	Unknown AUTOMAKE version: ${AUTOMAKE_VERSION}
+IGNORE+=	cannot install: unknown AUTOMAKE version: ${AUTOMAKE_VERSION}
 . endif
 
 # Set up the automake environment
@@ -146,7 +146,7 @@
 # Make sure we specified a legal version of autoconf
 #
 . if !exists(${PORTSDIR}/devel/autoconf${AUTOCONF_VERSION}/Makefile)
-BROKEN+=	Unknown AUTOCONF version: ${AUTOCONF_VERSION}
+IGNORE+=	cannot install: unknown AUTOCONF version: ${AUTOCONF_VERSION}
 . endif
 
 # Set up the autoconf/autoheader environment
@@ -189,7 +189,7 @@
 # Make sure we specified a legal version of libtool
 #
 . if !exists(${PORTSDIR}/devel/libtool${LIBTOOL_VERSION}/Makefile)
-BROKEN+=	Unknown LIBTOOL version: ${LIBTOOL_VERSION}
+IGNORE+=	cannot install: unknown LIBTOOL version: ${LIBTOOL_VERSION}
 . endif
 
 # Set up the libtool environment
Index: Mk/bsd.database.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.database.mk,v
retrieving revision 1.12
diff -u -r1.12 bsd.database.mk
--- Mk/bsd.database.mk	16 Jun 2006 04:53:43 -0000	1.12
+++ Mk/bsd.database.mk	19 Jun 2006 05:42:02 -0000
@@ -25,7 +25,7 @@
 #				  Default: 41.
 # WANT_MYSQL_VER
 #				- Maintainer can set an arbitrary version of MySQL by using it.
-# BROKEN_WITH_MYSQL
+# IGNORE_WITH_MYSQL
 #				- This variable can be defined if the ports doesn't support
 #				  one or more version of MySQL.
 # WITH_MYSQL_VER
@@ -44,7 +44,7 @@
 # WANT_PGSQL_VER
 #				- Maintainer can set an arbitrary version of PostgreSQL by
 #				  using it.
-# BROKEN_WITH_PGSQL
+# IGNORE_WITH_PGSQL
 #				- This variable can be defined if the ports doesn't support
 #				  one or more versions of PostgreSQL.
 # PGSQL_VER
@@ -116,13 +116,17 @@
 
 # And now we are checking if we can use it
 .if defined(MYSQL${MYSQL_VER}_LIBVER)
+# compatability shim
 .if defined(BROKEN_WITH_MYSQL)
-.	for VER in ${BROKEN_WITH_MYSQL}
+IGNORE_WITH_MYSQL=${BROKEN_WITH_MYSQL}
+.endif
+.if defined(IGNORE_WITH_MYSQL)
+.	for VER in ${IGNORE_WITH_MYSQL}
 .		if (${MYSQL_VER} == "${VER}")
-IGNORE=		cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL ${BROKEN_WITH_MYSQL})
+IGNORE=		cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL ${IGNORE_WITH_MYSQL})
 .		endif
 .	endfor
-.endif # BROKEN_WITH_MYSQL
+.endif # IGNORE_WITH_MYSQL
 LIB_DEPENDS+=	mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
 .else
 IGNORE=		cannot install: unknown MySQL version: ${MYSQL_VER}
@@ -155,13 +159,17 @@
 
 # And now we are checking if we can use it
 .if defined(PGSQL${PGSQL_VER}_LIBVER)
+# compatability shim
 .if defined(BROKEN_WITH_PGSQL)
-.	for VER in ${BROKEN_WITH_PGSQL}
+IGNORE_WITH_PGSQL=${BROKEN_WITH_PGSQL}
+.endif
+.if defined(IGNORE_WITH_PGSQL)
+.	for VER in ${IGNORE_WITH_PGSQL}
 .		if (${PGSQL_VER} == "${VER}")
-IGNORE=		cannot install: does not work with postgresql${PGSQL_VER}-client PostgresSQL (${BROKEN_WITH_PGSQL} not supported)
+IGNORE=		cannot install: does not work with postgresql${PGSQL_VER}-client PostgresSQL (${IGNORE_WITH_PGSQL} not supported)
 .		endif
 .	endfor
-.endif # BROKEN_WITH_PGSQL
+.endif # IGNORE_WITH_PGSQL
 LIB_DEPENDS+=	pq.${PGSQL${PGSQL_VER}_LIBVER}:${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
 .else
 IGNORE=		cannot install: unknown PostgreSQL version: ${PGSQL_VER}
@@ -220,7 +228,7 @@
 
 # Detect bdb version
 _BDB_VER=	no
-_BDB_BROKEN=	no
+_BDB_IGNORE=	no
 
 # Override the user defined WITH_BDB_VER with the WANT_BDB_VER
 .if defined(WANT_BDB_VER)
@@ -242,7 +250,7 @@
 .  for dbx in ${_DB_${_MATCHED_DB_VER}P}
 .   if exists(${db${dbx}_FIND})
 _BRKDB=	no
-# Skip versions we are broken with
+# Skip versions we are incompatible with
 .    if defined(INVALID_BDB_VER)
 _CHK_BDB:=	${dbx}
 .     for BRKDB in ${INVALID_BDB_VER}
@@ -282,20 +290,20 @@
 # INVALID_BDB_VER is specified as VER+
 .   if ${_CHK_PLUS}  != "${VER}"
 .    if ${_BDB_VER} == "${_CHK_PLUS}
-_BDB_BROKEN=	yes
+_BDB_IGNORE=	yes
 .    else
 .     for VER_P in ${_DB_${_CHK_PLUS}P}
 .      if ${_BDB_VER} == "${VER_P}"
-_BDB_BROKEN=	yes
+_BDB_IGNORE=	yes
 .      endif
 .     endfor
 .    endif
 .   elif ${_BDB_VER} == "${VER}"
-_BDB_BROKEN=	yes
+_BDB_IGNORE=	yes
 .   endif
 .  endfor
 . endif
-. if ${_BDB_BROKEN} == "yes"
+. if ${_BDB_IGNORE} == "yes"
 IGNORE= cannot install: does not work with bdb version: ${_BDB_VER} (${INVALID_BDB_VER} not supported)
 . else
 # Now add the dependancy on Berkeley DB ${_BDB_VER) version
Index: Mk/bsd.gcc.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.gcc.mk,v
retrieving revision 1.7
diff -u -r1.7 bsd.gcc.mk
--- Mk/bsd.gcc.mk	21 Jan 2006 17:37:01 -0000	1.7
+++ Mk/bsd.gcc.mk	19 Jun 2006 05:15:20 -0000
@@ -78,7 +78,7 @@
 .endfor
 
 .if !defined(_GCCVERSION_OKAY)
-BROKEN=	Unknown version of GCC specified (USE_GCC=${USE_GCC})
+IGNORE=	Unknown version of GCC specified (USE_GCC=${USE_GCC})
 .endif
 
 #
@@ -94,7 +94,7 @@
 . endif
 .endfor
 .if !defined(_GCCVERSION)
-BROKEN=		Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})
+IGNORE=		Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})
 .endif
 
 #
Index: Mk/bsd.gnome.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.gnome.mk,v
retrieving revision 1.129
diff -u -r1.129 bsd.gnome.mk
--- Mk/bsd.gnome.mk	14 Jun 2006 02:51:02 -0000	1.129
+++ Mk/bsd.gnome.mk	19 Jun 2006 05:22:46 -0000
@@ -613,18 +613,18 @@
 # Then use already expanded USE_GNOME_IMPL to expand USE_GNOME.
 # Also, check to see if each component has a desktop requirement.  If it does,
 # and if the user's chosen desktop is not of the same version, mark the
-# port as broken.
+# port as IGNORE.
 . for component in ${USE_GNOME}
 .      if defined(GNOME_DESKTOP_VERSION) && \
 	defined(${component}_GNOME_DESKTOP_VERSION)
 .         if ${GNOME_DESKTOP_VERSION}!=${${component}_GNOME_DESKTOP_VERSION}
-BROKEN=	${PORTNAME} wants to use the GNOME
-BROKEN+=${${component}_GNOME_DESKTOP_VERSION} desktop, but you wish to use
-BROKEN+=the GNOME ${GNOME_DESKTOP_VERSION} desktop
+IGNORE=	cannot install: ${PORTNAME} wants to use the GNOME
+IGNORE+=${${component}_GNOME_DESKTOP_VERSION} desktop, but you wish to use
+IGNORE+=the GNOME ${GNOME_DESKTOP_VERSION} desktop
 .         endif
 .      endif
 .  if ${_USE_GNOME_ALL:M${component}}==""
-BROKEN=	Unknown component ${component}
+IGNORE=	cannot install: unknown component ${component}
 .  endif
 _USE_GNOME+=	${${component}_USE_GNOME_IMPL} ${component}
 . endfor
@@ -647,7 +647,7 @@
 						done;
 .else
 .  if ${USE_GNOME:Mltverhack}!=""
-BROKEN=	${PORTNAME} uses the ltverhack GNOME component but does not use libtool
+IGNORE=	cannot install: ${PORTNAME} uses the ltverhack GNOME component but does not use libtool
 .  endif
 .endif
 
Index: Mk/bsd.gstreamer.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.gstreamer.mk,v
retrieving revision 1.20
diff -u -r1.20 bsd.gstreamer.mk
--- Mk/bsd.gstreamer.mk	9 Jun 2006 18:00:26 -0000	1.20
+++ Mk/bsd.gstreamer.mk	19 Jun 2006 05:19:54 -0000
@@ -246,7 +246,7 @@
 BUILD_DEPENDS+=	${${ext}_GST80_PREFIX}${${ext}_NAME}${${ext}_GST80_SUFX}>=${${ext}_GST80_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}${${ext}_GST80_SUFX}
 RUN_DEPENDS+=	${${ext}_GST80_PREFIX}${${ext}_NAME}${${ext}_GST80_SUFX}>=${${ext}_GST80_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}${${ext}_GST80_SUFX}
 . else
-BROKEN=	Unknown gstreamer-plugin -- ${ext}
+IGNORE=	cannot install: unknown gstreamer-plugin -- ${ext}
 . endif
 .endfor
 .endif
@@ -256,7 +256,7 @@
 BUILD_DEPENDS+=	${${ext}_GST_PREFIX}${${ext}_NAME}>=${${ext}_GST_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}
 RUN_DEPENDS+=	${${ext}_GST_PREFIX}${${ext}_NAME}>=${${ext}_GST_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}
 . else
-BROKEN=	Unknown gstreamer-plugin -- ${ext}
+IGNORE=	cannot install: unknown gstreamer-plugin -- ${ext}
 . endif
 .endfor
 .endif
Index: Mk/bsd.kde.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.kde.mk,v
retrieving revision 1.61
diff -u -r1.61 bsd.kde.mk
--- Mk/bsd.kde.mk	5 Jun 2006 19:23:51 -0000	1.61
+++ Mk/bsd.kde.mk	19 Jun 2006 05:23:30 -0000
@@ -68,7 +68,7 @@
 USE_QT_VER=		3
 PREFIX=			${KDE_PREFIX}
 .else
-IGNORE=			Unsupported value in USE_KDELIBS_VER
+IGNORE=			cannot install: unsupported value in USE_KDELIBS_VER
 .endif # ${USE_KDELIBS_VER} == 3
 .endif # defined(USE_KDELIBS_VER)
 
@@ -128,7 +128,7 @@
 CONFIGURE_ENV+=	MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
 .endif # !defined(QT_NONSTANDARD)
 .else
-IGNORE=			Unsupported value of USE_QT_VER
+IGNORE=			cannot install: unsupported value of USE_QT_VER
 .endif # defined(USE_QT_VER)
 
 # End of USE_QT_VER section
Index: Mk/bsd.php.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.php.mk,v
retrieving revision 1.30
diff -u -r1.30 bsd.php.mk
--- Mk/bsd.php.mk	16 Jun 2006 04:53:43 -0000	1.30
+++ Mk/bsd.php.mk	19 Jun 2006 05:42:48 -0000
@@ -18,7 +18,7 @@
 # The port can set these options in its Makefile before bsd.ports.pre.mk:
 #
 # DEFAULT_PHP_VER=N - Use PHP version N if PHP is not yet installed.
-# BROKEN_WITH_PHP=N - The port doesn't work with PHP version N.
+# IGNORE_WITH_PHP=N - The port doesn't work with PHP version N.
 # USE_PHPIZE=yes    - Use to build a PHP extension.
 # USE_PHPEXT=yes    - Use to build, install and register a PHP extension.
 # USE_PHP_BUILD=yes - Set PHP also as a build dependency.
@@ -70,10 +70,14 @@
 .endif
 PHP_EXT_INC?=	""
 
+# compatability shim
 .if defined(BROKEN_WITH_PHP)
-.	for VER in ${BROKEN_WITH_PHP}
+IGNORE_WITH_PHP=${BROKEN_WITH_PHP}
+.endif
+.if defined(IGNORE_WITH_PHP)
+.	for VER in ${IGNORE_WITH_PHP}
 .		if ${PHP_VER} == "${VER}"
-BROKEN=		Doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${BROKEN_WITH_PHP})
+IGNORE=		cannot install: doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${IGNORE_WITH_PHP})
 .		endif
 .	endfor
 .endif
Index: Mk/bsd.port.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.port.mk,v
retrieving revision 1.534
diff -u -r1.534 bsd.port.mk
--- Mk/bsd.port.mk	16 Jun 2006 04:53:43 -0000	1.534
+++ Mk/bsd.port.mk	19 Jun 2006 05:15:20 -0000
@@ -1204,7 +1204,7 @@
 
 .if defined(PORTVERSION)
 .if ${PORTVERSION:M*[-_,]*}x != x
-BROKEN=			PORTVERSION ${PORTVERSION} may not contain '-' '_' or ','
+IGNORE=			PORTVERSION ${PORTVERSION} may not contain '-' '_' or ','
 .endif
 DISTVERSION?=	${PORTVERSION:S/:/::/g}
 .elif defined(DISTVERSION)
@@ -1540,7 +1540,7 @@
 .elif ${WANT_OPENLDAP_VER} == 24
 LIB_DEPENDS+=		ldap-2.4.1:${PORTSDIR}/net/openldap24${_OPENLDAP_FLAVOUR}-client
 .else
-BROKEN=				unknown OpenLDAP version: ${WANT_OPENLDAP_VER}
+IGNORE=				unknown OpenLDAP version: ${WANT_OPENLDAP_VER}
 .endif
 .endif
 
@@ -1558,7 +1558,7 @@
 
 .if defined(WANT_FAM_SYSTEM)
 .if defined(WITH_FAM_SYSTEM) && ${WITH_FAM_SYSTEM}!=${WANT_FAM_SYSTEM}
-BROKEN=	The port wants to use ${WANT_FAM_SYSTEM} as its FAM system and you wish to use ${WITH_FAM_SYSTEM}
+IGNORE=	The port wants to use ${WANT_FAM_SYSTEM} as its FAM system and you wish to use ${WITH_FAM_SYSTEM}
 .endif
 FAM_SYSTEM=	${WANT_FAM_SYSTEM}
 .elif defined(WITH_FAM_SYSTEM)
@@ -1580,7 +1580,7 @@
 .if defined(FAM_SYSTEM_${FAM_SYSTEM:U})
 LIB_DEPENDS+=	${FAM_SYSTEM_${FAM_SYSTEM:U}}
 .else
-BROKEN=			unknown FAM system: ${FAM_SYSTEM}
+IGNORE=			unknown FAM system: ${FAM_SYSTEM}
 .endif
 .endif # USE_FAM
 
Index: Mk/bsd.ruby.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.ruby.mk,v
retrieving revision 1.151
diff -u -r1.151 bsd.ruby.mk
--- Mk/bsd.ruby.mk	17 May 2006 03:18:15 -0000	1.151
+++ Mk/bsd.ruby.mk	19 Jun 2006 05:24:21 -0000
@@ -114,12 +114,12 @@
 
 .if defined(RUBY)
 .if !exists(${RUBY})
-BROKEN=	You set the variable RUBY to "${RUBY}", but it does not seem to exist.  Please specify an already installed ruby executable.
+IGNORE=	cannot install: you set the variable RUBY to "${RUBY}", but it does not seem to exist.  Please specify an already installed ruby executable.
 .endif
 
 _RUBY_TEST!=		${RUBY} -e 'begin; require "rbconfig"; rescue LoadError; puts "error"; end'
 .if !empty(_RUBY_TEST)
-BROKEN=	You set the variable RUBY to "${RUBY}", but it failed to include rbconfig.  Please specify a properly installed ruby executable.
+IGNORE=	cannot install: you set the variable RUBY to "${RUBY}", but it failed to include rbconfig.  Please specify a properly installed ruby executable.
 .endif
 
 _RUBY_CONFIG=		${RUBY} -r rbconfig -e 'C = Config::CONFIG' -e
@@ -147,7 +147,7 @@
 RUBY_WRKSRC=		${WRKDIR}/ruby-${RUBY_VERSION}
 #MASTER_SITE_SUBDIR_RUBY=	snapshots
 .elif defined(RUBY_VER) && ${RUBY_VER} == 1.7
-BROKEN=	Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead.
+IGNORE=	Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead.
 .else
 RUBY_VERSION?=		1.6.8
 RUBY_DISTVERSION?=	${RUBY_VERSION}-2004.07.28
Index: Mk/bsd.sdl.mk
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/Mk/bsd.sdl.mk,v
retrieving revision 1.9
diff -u -r1.9 bsd.sdl.mk
--- Mk/bsd.sdl.mk	21 Jan 2006 17:37:01 -0000	1.9
+++ Mk/bsd.sdl.mk	19 Jun 2006 05:24:38 -0000
@@ -145,7 +145,7 @@
 _USE_SDL=
 .for component in ${USE_SDL}
 . if ${_USE_SDL_ALL:M${component}}==""
-BROKEN=	Unknown SDL component ${component}
+IGNORE=	cannot install: unknown SDL component ${component}
 . endif
 _USE_SDL+=	${_REQUIRES_${component}} ${component}
 .endfor
Index: benchmarks/sysbench/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/benchmarks/sysbench/Makefile,v
retrieving revision 1.6
diff -u -r1.6 Makefile
--- benchmarks/sysbench/Makefile	5 Jun 2006 20:46:51 -0000	1.6
+++ benchmarks/sysbench/Makefile	19 Jun 2006 05:36:17 -0000
@@ -31,7 +31,7 @@
 .if defined(WITH_POSTGRESQL)
 USE_PGSQL=	yes
 DEFAULT_PGSQL_VER?=	80
-BROKEN_WITH_PGSQL=	73 74
+IGNORE_WITH_PGSQL=	73 74
 CONFIGURE_ARGS+=	--with-pgsql
 .else
 CONFIGURE_ARGS+=	--with-pgsql=no
Index: databases/ip4r/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/databases/ip4r/Makefile,v
retrieving revision 1.2
diff -u -r1.2 Makefile
--- databases/ip4r/Makefile	19 Jan 2006 04:21:46 -0000	1.2
+++ databases/ip4r/Makefile	19 Jun 2006 05:00:11 -0000
@@ -20,7 +20,7 @@
 # 74 is not strictly true, but requires extracting the appropriate
 # postgresql-contrib tarball, and associated heavy lifting.
 # In order to keep this port simple, we assume >= 8.0
-BROKEN_WITH_PGSQL=	73 74
+IGNORE_WITH_PGSQL=	73 74
 
 MAKE_ARGS=	USE_PGXS=1
 
Index: databases/mysql-administrator/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/databases/mysql-administrator/Makefile,v
retrieving revision 1.29
diff -u -r1.29 Makefile
--- databases/mysql-administrator/Makefile	20 May 2006 17:40:09 -0000	1.29
+++ databases/mysql-administrator/Makefile	19 Jun 2006 05:25:10 -0000
@@ -28,7 +28,7 @@
 USE_ICONV=	yes
 USE_GNOME=	libglade2 gnomehack
 USE_MYSQL=	yes
-BROKEN_WITH_MYSQL=	323
+IGNORE_WITH_MYSQL=	323
 GNU_CONFIGURE=	yes
 
 GUI_CONFIG_COOKIE=	${WRKDIR}/.gui_configure_done
Index: databases/mysql-connector-odbc/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/databases/mysql-connector-odbc/Makefile,v
retrieving revision 1.20
diff -u -r1.20 Makefile
--- databases/mysql-connector-odbc/Makefile	4 May 2006 21:40:00 -0000	1.20
+++ databases/mysql-connector-odbc/Makefile	19 Jun 2006 05:00:11 -0000
@@ -17,7 +17,7 @@
 COMMENT=	ODBC driver for MySQL${MYSQL_VER} / ${DRIVER_MANAGER}
 
 USE_MYSQL=		yes
-BROKEN_WITH_MYSQL=	323
+IGNORE_WITH_MYSQL=	323
 
 USE_GMAKE=	yes
 USE_AUTOTOOLS=	libtool:15 libltdl:15
Index: databases/mysql-query-browser/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/databases/mysql-query-browser/Makefile,v
retrieving revision 1.1
diff -u -r1.1 Makefile
--- databases/mysql-query-browser/Makefile	18 Apr 2006 17:35:28 -0000	1.1
+++ databases/mysql-query-browser/Makefile	19 Jun 2006 05:36:33 -0000
@@ -36,7 +36,7 @@
 USE_GNOME=	libglade2 gnomehack gtkhtml3 intltool
 USE_MYSQL=	yes
 DEFAULT_MYSQL_VER=	50
-BROKEN_WITH_MYSQL=	323
+IGNORE_WITH_MYSQL=	323
 GNU_CONFIGURE=	yes
 
 GUI_CONFIG_COOKIE=	${WRKDIR}/.gui_configure_done
Index: databases/mysqlcc/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/databases/mysqlcc/Makefile,v
retrieving revision 1.9
diff -u -r1.9 Makefile
--- databases/mysqlcc/Makefile	4 May 2006 21:40:02 -0000	1.9
+++ databases/mysqlcc/Makefile	19 Jun 2006 05:00:12 -0000
@@ -19,7 +19,7 @@
 BUILD_DEPENDS=	qmake:${PORTSDIR}/devel/qmake
 
 USE_MYSQL=	yes
-BROKEN_WITH_MYSQL=323
+IGNORE_WITH_MYSQL=323
 
 GNU_CONFIGURE=	yes
 USE_QT_VER=	3
Index: databases/pecl-paradox/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/databases/pecl-paradox/Makefile,v
retrieving revision 1.2
diff -u -r1.2 Makefile
--- databases/pecl-paradox/Makefile	17 Feb 2006 16:37:42 -0000	1.2
+++ databases/pecl-paradox/Makefile	19 Jun 2006 05:37:40 -0000
@@ -22,7 +22,7 @@
 USE_PHPIZE=	yes
 USE_PHPEXT=	yes
 DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
 PHP_MODNAME=	paradox
 
 CONFIGURE_ARGS+=	--with-paradox=${LOCALBASE}
Index: databases/pgadmin3/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/databases/pgadmin3/Makefile,v
retrieving revision 1.25
diff -u -r1.25 Makefile
--- databases/pgadmin3/Makefile	21 May 2006 14:04:42 -0000	1.25
+++ databases/pgadmin3/Makefile	19 Jun 2006 05:26:13 -0000
@@ -16,7 +16,7 @@
 
 USE_GETTEXT=	yes
 USE_PGSQL=	yes
-BROKEN_WITH_PGSQL=	73
+IGNORE_WITH_PGSQL=	73
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS=	--with-wx=${X11BASE} --with-wx-config=${WX_CONFIG}
 CONFIGURE_TARGET=	--build=${ARCH}-portbld-freebsd${OSREL}
@@ -32,7 +32,7 @@
 .include <bsd.port.pre.mk>
 
 .if ${OSVERSION} < 500000
-BROKEN=		requires wchar_t
+IGNORE=		cannot install: requires wchar_t
 .endif
 
 .include <bsd.port.post.mk>
Index: deskutils/phprojekt/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/deskutils/phprojekt/Makefile,v
retrieving revision 1.4
diff -u -r1.4 Makefile
--- deskutils/phprojekt/Makefile	15 Apr 2006 11:47:38 -0000	1.4
+++ deskutils/phprojekt/Makefile	19 Jun 2006 05:00:12 -0000
@@ -16,7 +16,7 @@
 
 USE_PHP=	yes
 DEFAULT_PHP_VER=4
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 WANT_PHP_MOD=	yes
 
 NO_BUILD=	yes
Index: devel/bugzilla/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/devel/bugzilla/Makefile,v
retrieving revision 1.45
diff -u -r1.45 Makefile
--- devel/bugzilla/Makefile	13 May 2006 06:57:44 -0000	1.45
+++ devel/bugzilla/Makefile	19 Jun 2006 08:26:42 -0000
@@ -59,7 +59,7 @@
 .ifdef WITH_MYSQL
 RUN_DEPENDS+=	${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
 USE_MYSQL=	yes
-BROKEN_WITH_MYSQL=	323
+IGNORE_WITH_MYSQL=	323
 .endif
 
 .ifdef WITH_PGSQL
Index: devel/pear-PHPUnit2/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/devel/pear-PHPUnit2/Makefile,v
retrieving revision 1.14
diff -u -r1.14 Makefile
--- devel/pear-PHPUnit2/Makefile	4 May 2006 21:40:59 -0000	1.14
+++ devel/pear-PHPUnit2/Makefile	19 Jun 2006 05:00:12 -0000
@@ -23,7 +23,7 @@
 NO_PACKAGE=	"Conflicting dependences between PHP4 and PHP5"
 
 DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
 
 CATEGORY=	PHPUnit2
 FILES=		Extensions/ExceptionTestCase.php \
Index: devel/pear-PHP_Beautifier/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/devel/pear-PHP_Beautifier/Makefile,v
retrieving revision 1.8
diff -u -r1.8 Makefile
--- devel/pear-PHP_Beautifier/Makefile	4 May 2006 21:41:00 -0000	1.8
+++ devel/pear-PHP_Beautifier/Makefile	19 Jun 2006 05:00:12 -0000
@@ -20,7 +20,7 @@
 NO_PACKAGE=     Conflicting dependences between PHP4 and PHP5
 
 DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
 
 CATEGORY=	PHP
 FILES=		Beautifier.php Beautifier/Filter.php Beautifier/Decorator.php \
Index: devel/pecl-operator/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/devel/pecl-operator/Makefile,v
retrieving revision 1.2
diff -u -r1.2 Makefile
--- devel/pecl-operator/Makefile	12 Feb 2006 10:45:39 -0000	1.2
+++ devel/pecl-operator/Makefile	19 Jun 2006 05:37:53 -0000
@@ -20,7 +20,7 @@
 USE_PHP=	yes
 USE_PHPEXT=	yes
 DEFAULT_PHP_VER=	5
-BROKEN_WITH_PHP=	4
+IGNORE_WITH_PHP=	4
 PHP_MODNAME=	${PORTNAME}
 
 post-extract::
Index: graphics/jpgraph/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/graphics/jpgraph/Makefile,v
retrieving revision 1.19
diff -u -r1.19 Makefile
--- graphics/jpgraph/Makefile	8 Jun 2006 08:35:30 -0000	1.19
+++ graphics/jpgraph/Makefile	19 Jun 2006 05:26:39 -0000
@@ -18,7 +18,7 @@
 WRKSRC=		${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
 USE_PHP=	gd
 DEFAULT_PHP_VER=4
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 
 NO_CDROM=	The free version cannot be used in a commercial context
 
Index: lang/php4-extensions/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/lang/php4-extensions/Makefile,v
retrieving revision 1.8
diff -u -r1.8 Makefile
--- lang/php4-extensions/Makefile	31 Jan 2006 23:00:21 -0000	1.8
+++ lang/php4-extensions/Makefile	19 Jun 2006 05:00:13 -0000
@@ -17,7 +17,7 @@
 COMMENT=	A "meta-port" to install PHP extensions
 
 DEFAULT_PHP_VER=4
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 USE_PHP_BUILD=	yes
 
 NO_BUILD=	yes
Index: lang/php5-extensions/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/lang/php5-extensions/Makefile,v
retrieving revision 1.11
diff -u -r1.11 Makefile
--- lang/php5-extensions/Makefile	19 Mar 2006 22:19:08 -0000	1.11
+++ lang/php5-extensions/Makefile	19 Jun 2006 05:00:13 -0000
@@ -17,7 +17,7 @@
 COMMENT=	A "meta-port" to install PHP extensions
 
 DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
 USE_PHP_BUILD=	yes
 
 NO_BUILD=	yes
Index: net/phpldapadmin/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/net/phpldapadmin/Makefile,v
retrieving revision 1.18
diff -u -r1.18 Makefile
--- net/phpldapadmin/Makefile	14 May 2006 03:54:52 -0000	1.18
+++ net/phpldapadmin/Makefile	19 Jun 2006 05:38:05 -0000
@@ -19,7 +19,7 @@
 NO_BUILD=	yes
 USE_PHP=	gettext ldap openssl pcre session xml
 PHP_VER=	5
-BROKEN_WITH_PHP=	4
+IGNORE_WITH_PHP=	4
 
 .if defined(WITH_SUPHP)
 
Index: net-p2p/torrentflux/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/net-p2p/torrentflux/Makefile,v
retrieving revision 1.3
diff -u -r1.3 Makefile
--- net-p2p/torrentflux/Makefile	11 May 2006 22:49:51 -0000	1.3
+++ net-p2p/torrentflux/Makefile	19 Jun 2006 05:27:19 -0000
@@ -23,7 +23,7 @@
 USE_PHP=		pcre session sqlite
 WANT_PHP_WEB=		yes
 DEFAULT_PHP_VER?=	5
-BROKEN_WITH_PHP=	4
+IGNORE_WITH_PHP=	4
 USE_PYTHON_RUN=		yes
 
 EXTRA_PATCHES+=		${PATCHDIR}/extra-patch-*
Index: print/phppdflib/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/print/phppdflib/Makefile,v
retrieving revision 1.7
diff -u -r1.7 Makefile
--- print/phppdflib/Makefile	6 May 2006 14:31:27 -0000	1.7
+++ print/phppdflib/Makefile	19 Jun 2006 05:00:13 -0000
@@ -17,7 +17,7 @@
 USE_PHP=	yes
 WANT_PHP_MOD=	yes
 
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 
 WRKSRC=		${WRKDIR}/phppdflib
 USE_BZIP2=	yes
Index: security/pecl-filter/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/security/pecl-filter/Makefile,v
retrieving revision 1.1
diff -u -r1.1 Makefile
--- security/pecl-filter/Makefile	24 Jan 2006 17:09:46 -0000	1.1
+++ security/pecl-filter/Makefile	19 Jun 2006 05:00:13 -0000
@@ -24,7 +24,7 @@
 PHP_MODNAME=	filter
 
 DEFAULT_PHP_VER=	5
-BROKEN_WITH_VER=	4
+IGNORE_WITH_VER=	4
 
 CONFIGURE_ARGS+=	--with-pcre-dir=${LOCALBASE}
 
Index: security/pfw/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/security/pfw/Makefile,v
retrieving revision 1.14
diff -u -r1.14 Makefile
--- security/pfw/Makefile	29 May 2006 10:59:03 -0000	1.14
+++ security/pfw/Makefile	19 Jun 2006 05:38:20 -0000
@@ -21,7 +21,7 @@
 USE_PHP=	session	pcre sqlite
 WANT_PHP_WEB=	yes
 DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
 NO_BUILD=	yes
 
 PFW_PREFIX?=	${PREFIX}/www/pfw
Index: security/php4-cryptopp/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/security/php4-cryptopp/Makefile,v
retrieving revision 1.5
diff -u -r1.5 Makefile
--- security/php4-cryptopp/Makefile	22 May 2006 19:41:10 -0000	1.5
+++ security/php4-cryptopp/Makefile	19 Jun 2006 05:38:33 -0000
@@ -23,7 +23,7 @@
 USE_PERL5=	yes
 USE_PHP=	yes
 USE_PHPEXT=	yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 DEFAULT_PHP_VER=4
 
 CONFIGURE_ARGS=	--with-cryptopp
Index: shells/bush/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/shells/bush/Makefile,v
retrieving revision 1.6
diff -u -r1.6 Makefile
--- shells/bush/Makefile	13 May 2006 04:15:20 -0000	1.6
+++ shells/bush/Makefile	19 Jun 2006 05:27:46 -0000
@@ -30,7 +30,7 @@
 MAKEFILE=		GNUmakefile
 USE_SDL=		sdl image
 USE_MYSQL=		yes
-BROKEN_WITH_MYSQL=	323
+IGNORE_WITH_MYSQL=	323
 REINPLACE_ARGS=		-i ""
 
 WRKSRC=			${WRKDIR}/${PORTNAME}-${PORTVERSION}
Index: sysutils/dtc/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/sysutils/dtc/Makefile,v
retrieving revision 1.7
diff -u -r1.7 Makefile
--- sysutils/dtc/Makefile	16 May 2006 09:26:45 -0000	1.7
+++ sysutils/dtc/Makefile	19 Jun 2006 05:38:42 -0000
@@ -25,7 +25,7 @@
 
 .if defined(WITH_PHP5)
 DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
 USE_PHP+=	bz2 gd mbstring mcrypt mysql mysqli openssl pcre \
 		pear session sockets xml zlib
 .endif
Index: www/abcache/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/abcache/Makefile,v
retrieving revision 1.10
diff -u -r1.10 Makefile
--- www/abcache/Makefile	22 May 2006 19:50:14 -0000	1.10
+++ www/abcache/Makefile	19 Jun 2006 05:39:14 -0000
@@ -19,7 +19,7 @@
 USE_PHP=	yes
 USE_PHPIZE=	yes
 WITH_PHP_MOD=	yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 DEFAULT_PHP_VER=4
 
 CONFIGURE_ARGS+=--enable-bware_cache=shared
Index: www/autoindex/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/autoindex/Makefile,v
retrieving revision 1.4
diff -u -r1.4 Makefile
--- www/autoindex/Makefile	11 Dec 2005 17:39:41 -0000	1.4
+++ www/autoindex/Makefile	19 Jun 2006 05:00:14 -0000
@@ -17,7 +17,7 @@
 
 WRKSRC=		${WRKDIR}/${PORTNAME}
 
-BROKEN_WITH_PHP=	5
+IGNORE_WITH_PHP=	5
 USE_PHP=	session
 CONFLICTS=	AutoIndex-2*
 NO_BUILD=	yes
Index: www/autoindex2/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/autoindex2/Makefile,v
retrieving revision 1.7
diff -u -r1.7 Makefile
--- www/autoindex2/Makefile	13 Apr 2006 08:55:54 -0000	1.7
+++ www/autoindex2/Makefile	19 Jun 2006 05:00:14 -0000
@@ -18,7 +18,7 @@
 
 USE_PHP=	session
 DEFAULT_PHP_VER=	5
-BROKEN_WITH_PHP=	4
+IGNORE_WITH_PHP=	4
 CONFLICTS=	AutoIndex-1*
 LATEST_LINK=	AutoIndex2
 NO_BUILD=	yes
Index: www/campsite/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/campsite/Makefile,v
retrieving revision 1.9
diff -u -r1.9 Makefile
--- www/campsite/Makefile	24 May 2006 14:21:44 -0000	1.9
+++ www/campsite/Makefile	19 Jun 2006 05:00:14 -0000
@@ -32,7 +32,7 @@
 
 USE_APACHE=	YES
 
-BROKEN_WITH_PHP=	5
+IGNORE_WITH_PHP=	5
 USE_PHP=	mysql curl pcre xml xmlrpc
 WANT_PHP_CLI=	YES
 USE_PHP_BUILD=	YES
Index: www/fluxcms/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/fluxcms/Makefile,v
retrieving revision 1.2
diff -u -r1.2 Makefile
--- www/fluxcms/Makefile	8 May 2006 10:02:13 -0000	1.2
+++ www/fluxcms/Makefile	19 Jun 2006 05:39:23 -0000
@@ -26,7 +26,7 @@
 
 USE_PHP=	dom xml simplexml iconv mysql xsl session pcre
 
-BROKEN_WITH_PHP=	4
+IGNORE_WITH_PHP=	4
 DEFAULT_PHP_VER=	5
 
 .include <bsd.port.pre.mk>
Index: www/mod_auth_cookie_mysql/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/mod_auth_cookie_mysql/Makefile,v
retrieving revision 1.6
diff -u -r1.6 Makefile
--- www/mod_auth_cookie_mysql/Makefile	4 Dec 2005 14:08:55 -0000	1.6
+++ www/mod_auth_cookie_mysql/Makefile	19 Jun 2006 05:00:14 -0000
@@ -18,7 +18,7 @@
 USE_MYSQL=	YES
 
 # If someone can test it with MySQL 4.1 ;-)
-BROKEN_WITH_MYSQL=	41
+IGNORE_WITH_MYSQL=	41
 
 USE_APACHE=	13
 
Index: www/mod_auth_cookie_mysql2/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/mod_auth_cookie_mysql2/Makefile,v
retrieving revision 1.6
diff -u -r1.6 Makefile
--- www/mod_auth_cookie_mysql2/Makefile	4 Dec 2005 16:22:33 -0000	1.6
+++ www/mod_auth_cookie_mysql2/Makefile	19 Jun 2006 05:00:14 -0000
@@ -16,7 +16,7 @@
 
 USE_MYSQL=	YES
 # If someone can test it with MySQL 5.0 ;-)
-BROKEN_WITH_MYSQL=	50
+IGNORE_WITH_MYSQL=	50
 
 USE_APACHE=	20+
 
Index: www/pecl-tidy/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/pecl-tidy/Makefile,v
retrieving revision 1.1
diff -u -r1.1 Makefile
--- www/pecl-tidy/Makefile	22 Mar 2006 09:09:49 -0000	1.1
+++ www/pecl-tidy/Makefile	19 Jun 2006 05:39:34 -0000
@@ -21,7 +21,7 @@
 USE_PHP=	yes
 USE_PHPEXT=	yes
 PHP_MODNAME=	tidy
-BROKEN_WITH_PHP=	5
+IGNORE_WITH_PHP=	5
 
 CONFIGURE_ARGS=	--enable-tidy
 
Index: www/php-dyn/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/php-dyn/Makefile,v
retrieving revision 1.7
diff -u -r1.7 Makefile
--- www/php-dyn/Makefile	22 May 2006 19:42:37 -0000	1.7
+++ www/php-dyn/Makefile	19 Jun 2006 05:39:47 -0000
@@ -19,7 +19,7 @@
 USE_PHP=	yes
 USE_PHPIZE=	yes
 WITH_PHP_MOD=	yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 DEFAULT_PHP_VER=4
 
 CONFIGURE_ARGS=	--enable-php_dyn=shared
Index: www/php-screw/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/php-screw/Makefile,v
retrieving revision 1.11
diff -u -r1.11 Makefile
--- www/php-screw/Makefile	22 May 2006 19:43:26 -0000	1.11
+++ www/php-screw/Makefile	19 Jun 2006 05:39:56 -0000
@@ -22,7 +22,7 @@
 
 USE_PHP=	yes
 USE_PHPIZE=	yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 DEFAULT_PHP_VER=4
 
 CONFIGURE_ARGS+=--enable-php_screw=shared
Index: www/php-templates/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/php-templates/Makefile,v
retrieving revision 1.11
diff -u -r1.11 Makefile
--- www/php-templates/Makefile	27 Apr 2006 05:53:58 -0000	1.11
+++ www/php-templates/Makefile	19 Jun 2006 05:40:05 -0000
@@ -24,7 +24,7 @@
 
 USE_PHP=	yes
 USE_PHPIZE=	yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
 
 CONFIGURE_ARGS=	--enable-templates=shared
 
Index: www/siteframe/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/siteframe/Makefile,v
retrieving revision 1.2
diff -u -r1.2 Makefile
--- www/siteframe/Makefile	7 Jun 2006 12:11:46 -0000	1.2
+++ www/siteframe/Makefile	19 Jun 2006 05:00:14 -0000
@@ -19,10 +19,10 @@
 WITH_APACHE2=	yes
 USE_PHP=	mysqli simplexml xml session gd
 DEFAULT_PHP_VER=	5
-BROKEN_WITH_PHP=	4
+IGNORE_WITH_PHP=	4
 USE_MYSQL=	yes
 DEFAULT_MYSQL_VER=	41
-BROKEN_WITH_MYSQL=	40
+IGNORE_WITH_MYSQL=	40
 
 NO_PACKAGE=	Conflicting Apache dependencies
 
Index: www/usermanager/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/usermanager/Makefile,v
retrieving revision 1.5
diff -u -r1.5 Makefile
--- www/usermanager/Makefile	11 Oct 2005 20:41:15 -0000	1.5
+++ www/usermanager/Makefile	19 Jun 2006 05:00:14 -0000
@@ -16,7 +16,7 @@
 
 WRKSRC=		${WRKDIR}/ftp
 
-BROKEN_WITH_PHP=	5
+IGNORE_WITH_PHP=	5
 USE_PHP=	mysql pcre posix session
 
 NO_BUILD=	yes
Index: www/xaraya/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/www/xaraya/Makefile,v
retrieving revision 1.5
diff -u -r1.5 Makefile
--- www/xaraya/Makefile	14 Apr 2006 18:14:59 -0000	1.5
+++ www/xaraya/Makefile	19 Jun 2006 05:00:15 -0000
@@ -22,7 +22,7 @@
 .else
 USE_PHP=	mysql
 .endif
-BROKEN_WITH_PHP=	5
+IGNORE_WITH_PHP=	5
 NO_BUILD=	yes
 WRKSRC=		${WRKDIR}/${PORTNAME}-1.0.0-rc3
 
Index: x11-toolkits/php-gtk/Makefile
===================================================================
RCS file: /home/FreeBSD/pcvs/ports/x11-toolkits/php-gtk/Makefile,v
retrieving revision 1.25
diff -u -r1.25 Makefile
--- x11-toolkits/php-gtk/Makefile	13 May 2006 05:00:37 -0000	1.25
+++ x11-toolkits/php-gtk/Makefile	19 Jun 2006 05:16:08 -0000
@@ -20,7 +20,7 @@
 USE_PHP=	pcre
 USE_PHP_BUILD=	yes
 WANT_PHP_CLI=	yes
-BROKEN_WITH_PHP=	5
+IGNORE_WITH_PHP=	5
 USE_GMAKE=	yes
 USE_PERL5_BUILD=yes
 USE_GNOME=	gtk12
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2006-06-20 07:29:25 UTC
State Changed
From-To: suspended->open

New patch submitted.
Comment 6 Michael Nottebrock freebsd_committer 2006-06-21 05:15:29 UTC
No objections from kde@
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2006-06-27 21:14:13 UTC
State Changed
From-To: open->analyzed

Accepted for a test build on the cluster.
Comment 8 Mark Linimon freebsd_committer freebsd_triage 2006-07-05 03:42:41 UTC
State Changed
From-To: analyzed->closed

Committed.