Bug 92450 - net/honeyd doesn't build because of missing library "edit.5"
Summary: net/honeyd doesn't build because of missing library "edit.5"
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-28 11:50 UTC by Thomas Schweikle
Modified: 2006-01-29 23:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Schweikle 2006-01-28 11:50:01 UTC
              Go to "/usr/ports/net/honeyd", then "make install"

nms# make install
===>   honeyd-1.0_1 depends on file: /usr/local/lib/libdnet.a - found
===>   honeyd-1.0_1 depends on file: /usr/local/lib/libevent.a - found
===>   honeyd-1.0_1 depends on file: /usr/local/bin/python - found
===>   honeyd-1.0_1 depends on shared library: edit.5 - not found
===>    Verifying install for edit.5 in /usr/ports/devel/libedit
===>   Returning to build of honeyd-1.0_1
Error: shared library "edit.5" does not exist
*** Error code 1

Stop in /usr/ports/net/honeyd.

I am sure libedit is there, since I have installed i previously:
> libedit-2.6.9_2     Command line editing library

But this installs a newer version of this library than expected by honeyd: libedit.so.6

Fix: 

Accept the higher version of libedit too (should work, since on Gentoo this is the used library building honeyd).
How-To-Repeat:               cd /usr/ports/net/honeyd; make install
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2006-01-28 12:05:32 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports-bugs

Make it a ports bug.
Comment 2 Pav Lucistnik freebsd_committer 2006-01-29 23:27:30 UTC
State Changed
From-To: open->closed

Fixed, thank you for reporting it!