Bug 92590 - [MAINTAINER] www/mod_perl2: fix plist for apache21 and higher
Summary: [MAINTAINER] www/mod_perl2: fix plist for apache21 and higher
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Vasil Dimov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-31 08:30 UTC by Lars Eggert
Modified: 2006-02-27 15:13 UTC (History)
1 user (show)

See Also:


Attachments
mod_perl2-2.0.2,3.patch (585 bytes, patch)
2006-01-31 08:30 UTC, Lars Eggert
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Eggert 2006-01-31 08:30:04 UTC
Fix plist for apache21 and higher.
Tested by Marco van Tol <marco@tols.org>

Generated with FreeBSD Port Tools 0.63
Comment 1 Vasil Dimov freebsd_committer 2006-02-24 07:53:49 UTC
Responsible Changed
From-To: freebsd-ports-bugs->vd

I will take it
Comment 2 Vasil Dimov freebsd_committer 2006-02-24 14:24:03 UTC
This patch fixes the issue with include dir if apache 2.1+ is used but
there seems to be one more problem in that case. Can you look at the
following - several more files are installed if apache 2.1+ is used.
(easily reproduced if USE_APACHE=2.0+ is changed with USE_APACHE=2.1+)


...
Creating package /tmp/packages/All/mod_perl2-2.0.2,3.tbz
Registering depends: apache-2.1.9_5 expat-2.0.0_1 libiconv-1.9.2_2 perl-5.8.8.
Creating bzip'd tar ball in '/tmp/packages/All/mod_perl2-2.0.2,3.tbz'
Deleting mod_perl2-2.0.2,3 
pkg_delete: unable to completely remove directory '/usr/local/lib/perl5/site_perl/5.8.8/mach/auto/APR'
pkg_delete: unable to completely remove directory '/usr/local/lib/perl5/site_perl/5.8.8/mach/APR'
pkg_delete: couldn't entirely delete package (perhaps the packing list is
incorrectly specified?)
================================================================
Deleting perl-5.8.8 libiconv-1.9.2_2 expat-2.0.0_1 apache-2.1.9_5 
Removing stale symlinks from /usr/bin...
    Removing /usr/bin/perl
    Removing /usr/bin/perl5
Done.
Cleaning up /etc/make.conf... Done.
Cleaning up /etc/manpath.config... Done.

=== Checking filesystem state
list of extra files and directories in / (not present before this port was installed but present after it was deinstalled)
3646812        8 drwxr-xr-x    3 root             wheel                 512 Feb 24 14:13 usr/local/lib/perl5/site_perl/5.8.8/mach/auto/APR
3646863        8 drwxr-xr-x    2 root             wheel                 512 Feb 24 14:13 usr/local/lib/perl5/site_perl/5.8.8/mach/auto/APR/ThreadMutex
3646864       24 -r-xr-xr-x    1 root             wheel               11550 Feb 24 14:12 usr/local/lib/perl5/site_perl/5.8.8/mach/auto/APR/ThreadMutex/ThreadMutex.so
3646865        0 -r--r--r--    1 root             wheel                   0 Feb 24 14:12 usr/local/lib/perl5/site_perl/5.8.8/mach/auto/APR/ThreadMutex/ThreadMutex.bs
3647186        8 drwxr-xr-x    2 root             wheel                 512 Feb 24 14:13 usr/local/lib/perl5/site_perl/5.8.8/mach/APR
3647204       16 -r--r--r--    1 root             wheel                4260 Feb 24 14:13 usr/local/lib/perl5/site_perl/5.8.8/mach/APR/ThreadMutex.pm
================================================================
build ended at Fri Feb 24 14:14:03 UTC 2006
Comment 3 Lars Eggert 2006-02-24 14:32:53 UTC
On Feb 24, 2006, at 15:24, Vasil Dimov wrote:
> This patch fixes the issue with include dir if apache 2.1+ is used but
> there seems to be one more problem in that case. Can you look at the
> following - several more files are installed if apache 2.1+ is used.
> (easily reproduced if USE_APACHE=2.0+ is changed with USE_APACHE=2.1+)

Sorry, as the message in the Makefile says, I can only test mod_perl2  
this with apache20. I'm happy if interested people submit patches to  
make it work with newer apache versions, but I can't test them or  
trace down bugs.

(I'd be happy to transfer maintainership to someone with cycles to  
maintain and test mod_perl2 against multiple apache versions.)

Lars
-- 
Lars Eggert                                     NEC Network Laboratories
Comment 4 Vasil Dimov freebsd_committer 2006-02-27 15:12:31 UTC
State Changed
From-To: open->closed

Committed with some additions, thanks!