Bug 93100 - emulators/vmware-tools5 fails to build when WITH_VMWARE_GTK defined
Summary: emulators/vmware-tools5 fails to build when WITH_VMWARE_GTK defined
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: matusita
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-09 16:40 UTC by Scot Hetzel
Modified: 2006-02-12 14:30 UTC (History)
0 users

See Also:


Attachments
vmware-guestd5.diff (3.19 KB, patch)
2006-02-09 16:54 UTC, Scot Hetzel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scot Hetzel 2006-02-09 16:40:05 UTC
When I try to build/install the vmware-tools5 port, I receive several error message from make:
"/usr/ports/Mk/bsd.gnome.mk", line 605: "Malformed conditional (${_USE_GNOME_ALL:Mglib12=="")
"/usr/ports/Mk/bsd.gnome.mk", line 605: Need an operator
"/usr/ports/Mk/bsd.gnome.mk", line 605: Malformed conditional (${_USE_GNOME_ALL:Mgtk12}=="")
"/usr/ports/Mk/bsd.gnome.mk", line 605: Need an operator

The cause of this problem is that 'USE_GNOME= glib12 gtk12' is defined below bsd.port.pre.mk.  If it is defined above bsd.port.pre.mk, then this error doesn't occur.

After I fixed this problem, I discovered that the port would fail when installing the X server VM-Ware modules.  The reason it failed is because the ${X11BASE}/lib/modules/input directory wasn't created (affects xorg, and XFree86-4).  The port will also fail when there is no ${X11BASE}/lib/modules/drivers direcotory when installed on a system with XFree86-4.  The reason for these failures is that the mtree files BSD.x11-4.dist and BSD.x11.dist don't create these sub directories.

Fix: 

See the followup email with the fix.
How-To-Repeat: cd /usr/ports/emulators/vmware-tools5
make WITH_VMWARE_GTK=yes extract

"/usr/ports/Mk/bsd.gnome.mk", line 605: Malformed conditional (${_USE_GNOME_ALL:Mglib12}=="")
"/usr/ports/Mk/bsd.gnome.mk", line 605: Need an operator
"/usr/ports/Mk/bsd.gnome.mk", line 605: Malformed conditional (${_USE_GNOME_ALL:Mgtk12}=="")
"/usr/ports/Mk/bsd.gnome.mk", line 605: Need an operator
"/usr/ports/Mk/bsd.port.mk", line 1835: if-less endif
"/usr/ports/Mk/bsd.port.mk", line 1835: Need an operator
"/usr/ports/Mk/bsd.port.mk", line 5442: if-less endif
"/usr/ports/Mk/bsd.port.mk", line 5442: Need an operator
make: fatal errors encountered -- cannot continue
Comment 1 Edwin Groothuis freebsd_committer 2006-02-09 16:44:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->matusita

Over to maintainer
Comment 2 Scot Hetzel 2006-02-09 16:54:12 UTC
Attached is the patch to fix the the problem reported in PR93100, when
installing vmware-tools5 and having WITH_VMWARE_GTK defined, and no
${X11BASE}/lib/modules/[drivers,input] directories.

Scot
--
DISCLAIMER:
No electrons were mamed while sending this message. Only slightly bruised.
Comment 3 matusita freebsd_committer 2006-02-12 14:30:02 UTC
State Changed
From-To: open->closed

Committed, thank you!