Bug 93988 - www/mod_auth_pgsql2 broken [PATCH included]
Summary: www/mod_auth_pgsql2 broken [PATCH included]
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-apache mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-01 16:40 UTC by Marton Kenyeres
Modified: 2006-03-03 14:49 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marton Kenyeres 2006-03-01 16:40:07 UTC
www/mod_auth_pgsql when compiled from ports and enabled in httpd.conf gives the following error:

Syntax error on line xx of /usr/local/etc/apache2/httpd.conf:
Cannot load /usr/local/libexec/apache2/mod_auth_pgsql.so into server:
/usr/local/libexec/apache2/mod_auth_pgsql.so: Undefined symbol "PQexec"

This is probably caused by a typo in the port's Makefile. The attached one-line change seems to cause the module to link against libpq, and make it work.

Cheers,
m.

Fix: 

AP_INC?=       ${LOCALBASE}/include
-AP_LIBS?=      ${LOCALBASE}/lib -lpq
+AP_LIB?=       ${LOCALBASE}/lib -lpq
 AP_FAST_BUILD= YES
 AP_GENPLIST=   YES
 PORTDOCS=      mod_auth_pgsql.html--2Xe48SotpNTyoscNbOY7NxrLFMXnztgFAzg5OL5w4flo8zrG
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- Makefile.orig       Wed Mar  1 17:31:47 2006
+++ Makefile    Wed Mar  1 17:32:27 2006
@@ -19,7 +19,7 @@
 LATEST_LINK=   mod_auth_pgsql2
How-To-Repeat: Build the www/mod_auth_pgsql2 port, enable it in httpd.conf, and restart the apache server.
Comment 1 Edwin Groothuis freebsd_committer 2006-03-01 16:44:19 UTC
Responsible Changed
From-To: freebsd-ports-bugs->apache

Over to maintainer
Comment 2 Mathieu Arnold freebsd_committer 2006-03-03 14:49:53 UTC
State Changed
From-To: open->closed

committed