Bug 94006 - [NEW PORT] emulators/mednafen: Portable multi-system emulator
[NEW PORT] emulators/mednafen: Portable multi-system emulator
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 01:10 UTC by acardenas
Modified: 2006-06-11 11:58 UTC (History)
0 users

See Also:


Attachments
mednafen-0.5.2.shar (4.09 KB, text/plain)
2006-03-02 01:10 UTC, acardenas
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description acardenas 2006-03-02 01:10:01 UTC
Mednafen is a portable, utilizing OpenGL and SDL, argument(command-line)-driven multi-system emulator with 
many advanced features. The Atari Lynx, GameBoy, GameBoy Color, GameBoy Advance, NES, PC Engine(TurboGrafx 16), 
and SuperGrafx are emulated. Mednafen has the ability to remap hotkey functions and virtual system inputs to 
a keyboard, a joystick, or both simultaneously. Save states are supported, as is real-time game rewinding. 
Screen snapshots may be taken at the press of a button, and are saved in the popular PNG file format. 

Mednafen is distributed under the terms of the GNU GPL. 

Due to the threaded model of emulation used in Mednafen, and limitations of SDL, a joystick is preferred over 
a keyboard to play games, as the joystick will have slightly less latency, although the latency differences 
may not be perceptible to most people.

WWW:	http://mednafen.com/
Comment 1 acardenas 2006-05-23 05:20:00 UTC
- New shar file
- Updated to 0.6.1

- PCE: The HuC6280 disassembler now gives @ZP hints for BBR and BBS instructions.
- NES: Increased the effectiveness of frame-skipping.
- Removed unnecessary sound buffer copying if the source format == device format in SexyAL, which is true most of the time.
- Fixed a bug in the settings loading code that forced the user to resort to manual creation of ~/.mednafen/mednafen.cfg on some operating systems(*BSD, OS/X).
- It was being caused by 'errno' being modified between the attempt to open the settings file, and the test 'if(errno == ENOENT)'.
- Silent sound will now be outputted when in step mode in the debugger. Windows users' ears rejoice!
- Added a strtod() replacement that recognizes both "." and "," as valid radix characters, regardless of the current locale, and modified settings.cpp to use it.

--- mednafen-0.6.1.shar begins here ---
# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	mednafen
#	mednafen/files
#	mednafen/files/pkg-message.in
#	mednafen/pkg-descr
#	mednafen/Makefile
#	mednafen/pkg-plist
#	mednafen/distinfo
#
echo c - mednafen
mkdir -p mednafen > /dev/null 2>&1
echo c - mednafen/files
mkdir -p mednafen/files > /dev/null 2>&1
echo x - mednafen/files/pkg-message.in
sed 's/^X//' >mednafen/files/pkg-message.in << 'END-of-mednafen/files/pkg-message.in'
X###############################################################################
X
X1) Run mednafen [OPTION] [FILE]
X2) See complete documentation on %%DOCSDIR%%/mednafen.html
X3) Enjoy it ;)
X
X###############################################################################
END-of-mednafen/files/pkg-message.in
echo x - mednafen/pkg-descr
sed 's/^X//' >mednafen/pkg-descr << 'END-of-mednafen/pkg-descr'
XMednafen is a portable, utilizing OpenGL and SDL, argument(command-line)-driven
Xmulti-system emulator with many advanced features. The Atari Lynx, GameBoy,
XGameBoy Color, GameBoy Advance, NES, PC Engine(TurboGrafx 16), and SuperGrafx
Xare emulated. Mednafen has the ability to remap hotkey functions and virtual
Xsystem inputs to a keyboard, a joystick, or both simultaneously. Save states
Xare supported, as is real-time game rewinding. Screen snapshots may be taken at
Xthe press of a button, and are saved in the popular PNG file format. 
X
XMednafen is distributed under the terms of the GNU GPL. 
X
XDue to the threaded model of emulation used in Mednafen, and limitations of SDL
Xa joystick is preferred over a keyboard to play games, as the joystick will have
Xslightly less latency, although the latency differences may not be perceptible
Xto most people.
X
XWWW:	http://mednafen.com/
END-of-mednafen/pkg-descr
echo x - mednafen/Makefile
sed 's/^X//' >mednafen/Makefile << 'END-of-mednafen/Makefile'
X# New ports collection makefile for:	mednafen
X# Date created:		2006-02-28
X# Whom:			Charlie & <root@bsd.org.pe>
X#
X# $FreeBSD$
X#
X
XPORTNAME=	mednafen
XPORTVERSION=	0.6.1
XCATEGORIES=	emulators games
XMASTER_SITES=	http://mednafen.com/releases/
X
XMAINTAINER=	acardenas@bsd.org.pe
XCOMMENT=	Portable multi-system emulator
X
XLIB_DEPENDS=	cdio.6:${PORTSDIR}/sysutils/libcdio \
X		sndfile.1:${PORTSDIR}/audio/libsndfile \
X		vorbis.3:${PORTSDIR}/audio/libvorbis
X
XUSE_BZIP2=	yes
XUSE_X_PREFIX=	yes
XUSE_GMAKE=	yes
XGNU_CONFIGURE=	yes
XUSE_SDL=	sdl net
XCPPFLAGS+=	-I${LOCALBASE}/include -I${X11BASE}/include
XLDFLAGS+=	-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
XCONFIGURE_TARGET=	--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
XCONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
XWRKSRC=	${WRKDIR}/${PORTNAME}
XSUB_FILES=	pkg-message
X
XOPTIONS=	NLS	"Native Language Support"	on
X
X.include <bsd.port.pre.mk>
X
X.if defined(WITHOUT_NLS)
XCONFIGURE_ARGS+=	--disable-nls
XPLIST_SUB+=	NLS="@comment "
X.else
XUSE_GETTEXT=	yes
XPLIST_SUB+=	NLS=""
XFLAG_NLS=	true
X.endif
X
Xpre-configure:
X	@${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
X
Xpost-install:
X.if !defined(NOPORTDOCS)
X	@${MKDIR} ${DOCSDIR}
X	@${INSTALL_DATA} ${WRKSRC}/Documentation/mednafen.html ${DOCSDIR}
X.endif
X	@${CAT} ${PKGMESSAGE}
X
X.include <bsd.port.post.mk>
END-of-mednafen/Makefile
echo x - mednafen/pkg-plist
sed 's/^X//' >mednafen/pkg-plist << 'END-of-mednafen/pkg-plist'
Xbin/mednafen
X%%NLS%%share/locale/es/LC_MESSAGES/mednafen.mo
X%%NLS%%share/locale/ru/LC_MESSAGES/mednafen.mo
X%%PORTDOCS%%%%DOCSDIR%%/mednafen.html
X%%PORTDOCS%%@dirrm %%DOCSDIR%%
END-of-mednafen/pkg-plist
echo x - mednafen/distinfo
sed 's/^X//' >mednafen/distinfo << 'END-of-mednafen/distinfo'
XMD5 (mednafen-0.6.1.tar.bz2) = 4918b570f48f049021ead85b3b40edcb
XSHA256 (mednafen-0.6.1.tar.bz2) = e3021ce4cb60f479a01c963f471df47a6e48d3b1fdbf14875e09774dbc1e9c77
XSIZE (mednafen-0.6.1.tar.bz2) = 1435414
END-of-mednafen/distinfo
exit
--- mednafen-0.6.1.shar ends here ---

Greetings
ACM
-- 
Grupo de Usuarios GNU/Linux Arequipa - AQPGLUG
http://www.aqpglug.org.pe
Comment 2 acardenas 2006-05-23 05:20:06 UTC
- New shar file
- Updated to 0.6.1

- PCE: The HuC6280 disassembler now gives @ZP hints for BBR and BBS instructions.
- NES: Increased the effectiveness of frame-skipping.
- Removed unnecessary sound buffer copying if the source format == device format in SexyAL, which is true most of the time.
- Fixed a bug in the settings loading code that forced the user to resort to manual creation of ~/.mednafen/mednafen.cfg on some operating systems(*BSD, OS/X).
- It was being caused by 'errno' being modified between the attempt to open the settings file, and the test 'if(errno == ENOENT)'.
- Silent sound will now be outputted when in step mode in the debugger. Windows users' ears rejoice!
- Added a strtod() replacement that recognizes both "." and "," as valid radix characters, regardless of the current locale, and modified settings.cpp to use it.

--- mednafen-0.6.1.shar begins here ---
# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	mednafen
#	mednafen/files
#	mednafen/files/pkg-message.in
#	mednafen/pkg-descr
#	mednafen/Makefile
#	mednafen/pkg-plist
#	mednafen/distinfo
#
echo c - mednafen
mkdir -p mednafen > /dev/null 2>&1
echo c - mednafen/files
mkdir -p mednafen/files > /dev/null 2>&1
echo x - mednafen/files/pkg-message.in
sed 's/^X//' >mednafen/files/pkg-message.in << 'END-of-mednafen/files/pkg-message.in'
X###############################################################################
X
X1) Run mednafen [OPTION] [FILE]
X2) See complete documentation on %%DOCSDIR%%/mednafen.html
X3) Enjoy it ;)
X
X###############################################################################
END-of-mednafen/files/pkg-message.in
echo x - mednafen/pkg-descr
sed 's/^X//' >mednafen/pkg-descr << 'END-of-mednafen/pkg-descr'
XMednafen is a portable, utilizing OpenGL and SDL, argument(command-line)-driven
Xmulti-system emulator with many advanced features. The Atari Lynx, GameBoy,
XGameBoy Color, GameBoy Advance, NES, PC Engine(TurboGrafx 16), and SuperGrafx
Xare emulated. Mednafen has the ability to remap hotkey functions and virtual
Xsystem inputs to a keyboard, a joystick, or both simultaneously. Save states
Xare supported, as is real-time game rewinding. Screen snapshots may be taken at
Xthe press of a button, and are saved in the popular PNG file format. 
X
XMednafen is distributed under the terms of the GNU GPL. 
X
XDue to the threaded model of emulation used in Mednafen, and limitations of SDL
Xa joystick is preferred over a keyboard to play games, as the joystick will have
Xslightly less latency, although the latency differences may not be perceptible
Xto most people.
X
XWWW:	http://mednafen.com/
END-of-mednafen/pkg-descr
echo x - mednafen/Makefile
sed 's/^X//' >mednafen/Makefile << 'END-of-mednafen/Makefile'
X# New ports collection makefile for:	mednafen
X# Date created:		2006-02-28
X# Whom:			Charlie & <root@bsd.org.pe>
X#
X# $FreeBSD$
X#
X
XPORTNAME=	mednafen
XPORTVERSION=	0.6.1
XCATEGORIES=	emulators games
XMASTER_SITES=	http://mednafen.com/releases/
X
XMAINTAINER=	acardenas@bsd.org.pe
XCOMMENT=	Portable multi-system emulator
X
XLIB_DEPENDS=	cdio.6:${PORTSDIR}/sysutils/libcdio \
X		sndfile.1:${PORTSDIR}/audio/libsndfile \
X		vorbis.3:${PORTSDIR}/audio/libvorbis
X
XUSE_BZIP2=	yes
XUSE_X_PREFIX=	yes
XUSE_GMAKE=	yes
XGNU_CONFIGURE=	yes
XUSE_SDL=	sdl net
XCPPFLAGS+=	-I${LOCALBASE}/include -I${X11BASE}/include
XLDFLAGS+=	-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
XCONFIGURE_TARGET=	--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
XCONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
XWRKSRC=	${WRKDIR}/${PORTNAME}
XSUB_FILES=	pkg-message
X
XOPTIONS=	NLS	"Native Language Support"	on
X
X.include <bsd.port.pre.mk>
X
X.if defined(WITHOUT_NLS)
XCONFIGURE_ARGS+=	--disable-nls
XPLIST_SUB+=	NLS="@comment "
X.else
XUSE_GETTEXT=	yes
XPLIST_SUB+=	NLS=""
XFLAG_NLS=	true
X.endif
X
Xpre-configure:
X	@${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
X
Xpost-install:
X.if !defined(NOPORTDOCS)
X	@${MKDIR} ${DOCSDIR}
X	@${INSTALL_DATA} ${WRKSRC}/Documentation/mednafen.html ${DOCSDIR}
X.endif
X	@${CAT} ${PKGMESSAGE}
X
X.include <bsd.port.post.mk>
END-of-mednafen/Makefile
echo x - mednafen/pkg-plist
sed 's/^X//' >mednafen/pkg-plist << 'END-of-mednafen/pkg-plist'
Xbin/mednafen
X%%NLS%%share/locale/es/LC_MESSAGES/mednafen.mo
X%%NLS%%share/locale/ru/LC_MESSAGES/mednafen.mo
X%%PORTDOCS%%%%DOCSDIR%%/mednafen.html
X%%PORTDOCS%%@dirrm %%DOCSDIR%%
END-of-mednafen/pkg-plist
echo x - mednafen/distinfo
sed 's/^X//' >mednafen/distinfo << 'END-of-mednafen/distinfo'
XMD5 (mednafen-0.6.1.tar.bz2) = 4918b570f48f049021ead85b3b40edcb
XSHA256 (mednafen-0.6.1.tar.bz2) = e3021ce4cb60f479a01c963f471df47a6e48d3b1fdbf14875e09774dbc1e9c77
XSIZE (mednafen-0.6.1.tar.bz2) = 1435414
END-of-mednafen/distinfo
exit
--- mednafen-0.6.1.shar ends here ---

Greetings
ACM
-- 
Grupo de Usuarios *BSD Peru - BSDPeru
http://www.bsd.org.pe
Comment 3 pav freebsd_committer 2006-06-11 11:58:07 UTC
State Changed
From-To: open->closed

New port added, thank you!