Bug 94442 - [PATCH] www/mod_ruby: build fails with apache22
[PATCH] www/mod_ruby: build fails with apache22
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Dirk Meyer
Depends on:
  Show dependency treegraph
Reported: 2006-03-14 10:30 UTC by hiroto.kagotani
Modified: 2006-03-18 15:56 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description hiroto.kagotani 2006-03-14 10:30:13 UTC
make in www/mod_ruby stops if I already have installed www/apache22.

# make
===>  Building for mod_ruby-1.2.5
cc -O2 -fno-strict-aliasing -pipe   -fPIC -Wall  -O2 -fno-strict-aliasing -pipe    -I. -I/usr/local/lib/ruby/1.8/i386-freebsd6 -I/usr/local/include/apache22    -c mod_ruby.c
In file included from /usr/local/include/apache22/httpd.h:43,
                 from mod_ruby.h:49,
                 from mod_ruby.c:33:
/usr/local/include/apache22/ap_config.h:25:17: apr.h: No such file or directory

This is caused by www/mod_ruby's assumption that apr headers are
thestored in apache's include directory, though they are actually
stored in /usr/local/include/apr-1 directory for apache21 and 22.


.include <bsd.port.pre.mk>

+.if exists(${LOCALBASE}/bin/apr-1-config)
+CONFIGURE_ARGS+=--with-apr-includes="`${LOCALBASE}/bin/apr-1-config --includedir`"
        @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} ${RUBY_FLAGS} configure.rb ${CONFIGURE_ARGS}
 .if !defined(WITHOUT_PTHREADS)--6ztgoG1gcybggg3RphKeiyXgTifybI5rvllCgcZPfg5zdak8
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- Makefile.orig       Mon Feb 20 17:53:14 2006
+++ Makefile    Tue Mar 14 09:19:26 2006
@@ -35,6 +35,10 @@
Comment 1 Edwin Groothuis freebsd_committer 2006-03-14 10:32:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Over to maintainer
Comment 2 Dirk Meyer freebsd_committer 2006-03-18 15:54:51 UTC
State Changed
From-To: open->closed

commited with changes. 

make APACHE_PORT=www/apache22 
failed on a clean system. 
apr-1c-onfig does not exist on the first run.