Bug 94560 - updating graphics/exiv2 [PATCH]
Summary: updating graphics/exiv2 [PATCH]
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Michael Johnson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-16 15:09 UTC by Mikhail T.
Modified: 2006-04-23 15:12 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (2.11 KB, patch)
2006-03-16 15:09 UTC, Mikhail T.
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail T. 2006-03-16 15:09:56 UTC
The software is now available on the new location (redirected to by
the old). A slightly newer version is offered there:

From the vendor's changelog:

Changes from version 0.9 to 0.9.1
---------------------------------

* Exiv2 library
- 0000451: [exif] Fixed bug where an invalid Exif tag was created for
   the user comment, when the tag was newly added to an image.
   (Thanks to Anatoliy Kovalenko for reporting this bug)
 - Added enum MetadataId and Image::supportsMetadata() to check what
   metadata an image class supports. Changed CrwImage to silently
   ignore calls to Iptc related functions instead of throwing an Error.
   (Thanks to Will Stokes for suggesting the check feature)
 - Cleaned up some #include statements (mentioned here because this
   may lead to unexpected compiler errors).

The port compiled cleanly on beast.freebsd.org (an Alpha machine), so,
I think, it can be unmarked broken on Alpha.

BTW, are we supposed to install the .la library file at all?
Comment 1 Edwin Groothuis freebsd_committer 2006-03-16 15:32:11 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ahze

Over to maintainer
Comment 2 Michael Johnson freebsd_committer 2006-04-23 15:11:49 UTC
State Changed
From-To: open->closed

Committed, Thanks!