Bug 94745 - mail/mutt-devel: Add a gpgme switch
Summary: mail/mutt-devel: Add a gpgme switch
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Renato Botelho
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-20 18:50 UTC by Ed Schouten
Modified: 2006-03-21 10:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Schouten 2006-03-20 18:50:16 UTC
A cool thing about the development branch of the gnupg application is
the gpgme library, which allows you to write applications using gnupg in
an easy manner (instead of throwing messages through pipes and such).

As of Mutt 1.5.<insert the correct number here>, there are compilation
switches called '--{en,dis}able-gpgme', which allows you to link Mutt
against the gpgme library, so you can just add the line 'set
crypt_use_gpgme' to your muttrc, instead of that awful 'set
pgp_..._command' stuff.

Fix: Voila :)

%%%


I also tested it on my workstation:

	http://g-rave.nl/junk/mutt-gpgme.png--N7OSomhPntVtzeWS34Wmeo1TgA4pC3R7AYWu6Cz3OfXus5Xy
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- mail/mutt-devel/Makefile	Fri Mar 17 12:24:16 2006
+++ mail/mutt-devel/Makefile	Mon Mar 20 19:39:53 2006
@@ -45,6 +45,9 @@
 # If you want mutt to use the idn library define:
 #  WITH_MUTT_IDN
 #
+# If you want to make use of the gpgme interface define:
+#  WITH_MUTT_GPGME
+#
 # If you want to enable extended quoting functions define:
 #  WITH_MUTT_QUOTE_PATCH
 #  This is a default knob and can be disabled by WITHOUT_MUTT_QUOTE_PATCH
@@ -362,6 +365,12 @@
 CONFIGURE_ARGS+=	--with-idn
 .else
 CONFIGURE_ARGS+=	--without-idn
+.endif
+.if defined(WITH_MUTT_GPGME)
+LIB_DEPENDS+=	gpgme:${PORTSDIR}/security/gpgme
+CONFIGURE_ARGS+=	--enable-gpgme
+.else
+CONFIGURE_ARGS+=	--disable-gpgme
 .endif
 
 PATCH_DIST_STRIP=	-p1
%%%
How-To-Repeat: Install mail/mutt-devel from Ports. You won't be able to use it
in combination with gpgme.
Comment 1 Edwin Groothuis freebsd_committer 2006-03-20 18:56:12 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 Udo.Schweigert 2006-03-20 19:45:12 UTC
Please commit this patch:

diff -ru  /usr/ports/mail/mutt-devel/Makefile ./Makefile
--- /usr/ports/mail/mutt-devel/Makefile	Sat Mar 18 06:07:30 2006
+++ ./Makefile	Mon Mar 20 20:02:55 2006
@@ -45,6 +45,9 @@
 # If you want mutt to use the idn library define:
 #  WITH_MUTT_IDN
 #
+# If you want to make use of the gpgme interface define:
+#  WITH_MUTT_GPGME
+#
 # If you want to enable extended quoting functions define:
 #  WITH_MUTT_QUOTE_PATCH
 #  This is a default knob and can be disabled by WITHOUT_MUTT_QUOTE_PATCH
@@ -297,6 +300,9 @@
 .if defined(WITH_MUTT_IDN)
 LIB_DEPENDS+=	idn:${PORTSDIR}/dns/libidn
 .endif
+.if defined(WITH_MUTT_GPGME)
+LIB_DEPENDS+=	gpgme:${PORTSDIR}/security/gpgme
+.endif
 .if ! defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
 post-patch::
 	@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-outlook
@@ -362,6 +368,11 @@
 CONFIGURE_ARGS+=	--with-idn
 .else
 CONFIGURE_ARGS+=	--without-idn
+.endif
+.if defined(WITH_MUTT_GPGME)
+CONFIGURE_ARGS+=	--enable-gpgme
+.else
+CONFIGURE_ARGS+=	--disable-gpgme
 .endif
 
 PATCH_DIST_STRIP=	-p1
Comment 3 Renato Botelho freebsd_committer 2006-03-20 22:06:50 UTC
State Changed
From-To: feedback->open

Feedback recieved
Comment 4 Renato Botelho freebsd_committer 2006-03-20 22:07:00 UTC
Responsible Changed
From-To: freebsd-ports-bugs->garga

I'll take it.
Comment 5 Renato Botelho freebsd_committer 2006-03-21 10:10:45 UTC
State Changed
From-To: open->closed

Committed. Thanks!