Bug 95656 - devel/monotone: upgrade to 0.26
Summary: devel/monotone: upgrade to 0.26
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Jean Milanez Melo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-12 16:00 UTC by Lapo Luchini
Modified: 2006-04-24 15:16 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lapo Luchini 2006-04-12 16:00:28 UTC

    
Comment 1 Jean Milanez Melo freebsd_committer 2006-04-13 02:17:45 UTC
Responsible Changed
From-To: freebsd-ports-bugs->jmelo

I'll take it.
Comment 2 Jean Milanez Melo freebsd_committer 2006-04-13 16:56:11 UTC
State Changed
From-To: open->feedback

Ask for maintainer about build problems.
Comment 3 Jean Milanez Melo freebsd_committer 2006-04-13 16:59:15 UTC
Dear maintainer,

There are build errors on your update patch. Could you take a look and 
fix it?

Tinderbox build logs:
http://main.bh.freebsdbrasil.com.br:9090/tb/errors/5.5-FreeBSD/monotone-0.26.log
http://main.bh.freebsdbrasil.com.br:9090/tb/errors/6.1-FreeBSD/monotone-0.26.log

Thanks.

-- Jean
Comment 4 lapo.luchini 2006-04-14 09:26:55 UTC
Unfortunately that website seems to be down right now or, at least,
inaccessible from Italy.

Could you please send the log to me in private e-mail?

Else I fear I can't do nothing: I falied to reproduce it, as on the
three -STABLE box I tried it on I had no build errors... (two are i386,
one amd64)

    Lapo
Comment 5 lapo.luchini 2006-04-14 19:22:09 UTC
I also portinstalled it with no errors on a i386 5.4-RELEASE-p4, I'm
really curious what the problem is on that tinderbox...
Comment 6 Jean Milanez Melo freebsd_committer 2006-04-17 19:23:20 UTC
Lapo Luchini wrote:
> Unfortunately that website seems to be down right now or, at least,
> inaccessible from Italy.
> 
> Could you please send the log to me in private e-mail?
> 
> Else I fear I can't do nothing: I falied to reproduce it, as on the
> three -STABLE box I tried it on I had no build errors... (two are i386,
> one amd64)
> 
>     Lapo

Hi,

The machine was turned off at weekend, please try again either:

 
http://main.bh.freebsdbrasil.com.br:9090/tb/errors/5.5-FreeBSD/monotone-0.26.log
http://main.bh.freebsdbrasil.com.br:9090/tb/errors/6.1-FreeBSD/monotone-0.26.log

or:

http://201.17.165.158:9090/tb/errors/5.5-FreeBSD/monotone-0.26.log
http://201.17.165.158:9090/tb/errors/6.1-FreeBSD/monotone-0.26.log


Thanks.

-- Jean
Comment 7 lapo.luchini 2006-04-18 10:33:34 UTC
Ohh, I see: a build dependance on perl was missing (it is used to add a
line to the new HTML manual).
This itself would have led me to "convert" it to a "sed" call, but perl
it is also needed in many tests in the test suite, so I guess this is
the best thing to do:

--- Makefile.orig       Tue Apr 18 11:25:14 2006
+++ Makefile    Tue Apr 18 11:27:49 2006
@@ -16,6 +16,7 @@
 LIB_DEPENDS=   boost_regex.3:${PORTSDIR}/devel/boost
 
 USE_GCC=       3.4+
+USE_PERL5_BUILD=yes
 USE_REINPLACE= yes
 USE_ICONV=     yes
 USE_GMAKE=     yes
Comment 8 Jean Milanez Melo freebsd_committer 2006-04-24 15:16:35 UTC
State Changed
From-To: feedback->closed

Committed, with minor changes. Added pkg-message to inform users about 
the update. Thanks!