Bug 96013 - [maintainer update] textproc/gsed: fix build on 4.X
Summary: [maintainer update] textproc/gsed: fix build on 4.X
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Sergey Matveychuk
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-18 17:20 UTC by Gabor Kovesdan
Modified: 2006-04-20 06:52 UTC (History)
0 users

See Also:


Attachments
file.diff (2.43 KB, patch)
2006-04-18 17:20 UTC, Gabor Kovesdan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kovesdan 2006-04-18 17:20:16 UTC
The build error is caused by a 'bool' datatype introduced in gsed 4.1.5.
GCC 2.95 is pre-C99 and doesn't handle the 'bool' datatype properly.
The attached patch fixes the problem on FreeBSD 4.x

Patch by: Rainer Alves <rainer.alves@gmail.com>
Comment 1 Sergey Matveychuk freebsd_committer 2006-04-19 11:15:34 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sem

lock for build tests
Comment 2 Sergey Matveychuk 2006-04-19 18:18:51 UTC
A patch is broken:
===>  Patching for gsed-4.1.4
===>  Applying extra patch
/a/ports/textproc/gsed/files/extrapatch-lib-regexec.c
4 out of 4 hunks failed--saving rejects to lib/regexec.c.rej
*** Error code 4

Stop in /a/ports/textproc/gsed.

I think, your MUA changed tabs with spaces. Resend the patch as an
attachment please.
-- 
Sem.
Comment 3 Sergey Matveychuk freebsd_committer 2006-04-19 18:19:25 UTC
State Changed
From-To: open->feedback

Ask for maintainer fix.
Comment 4 Gabor Kovesdan 2006-04-19 18:31:40 UTC
Yes, it got corrupted somehow... so I've made it online, please grab it 
to avoid the corruption:

http://tux.t-hosting.hu/gsed-4.15-freebsd4.diff

Thanks,

Gabor Kovesdan
Comment 5 Sergey Matveychuk freebsd_committer 2006-04-20 06:52:21 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!