Bug 96244 - graphics/png -- update for NO_OBJ and NO_PROFILE
graphics/png -- update for NO_OBJ and NO_PROFILE
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Andrey A. Chernov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 05:00 UTC by freebsd
Modified: 2006-04-24 15:05 UTC (History)
0 users

See Also:


Attachments
file.diff (573 bytes, patch)
2006-04-24 05:00 UTC, freebsd
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description freebsd 2006-04-24 05:00:38 UTC
	Please ignore the release/environment for this PR; source system
	is actually 6.1-RC.

	Building libpng results in the following legitimate warnings:

===>  Patching for png-1.2.8_3
===>  Applying FreeBSD patches for png-1.2.8_3
===>  Configuring for png-1.2.8_3
===>  Building for png-1.2.8_3
"/usr/share/mk/bsd.compat.mk", line 36: warning: NOOBJ is deprecated in favor of NO_OBJ
"/usr/share/mk/bsd.compat.mk", line 36: warning: NOPROFILE is deprecated in favor of NO_PROFILE

	This is caused by ${WRKSRC}/scripts/makefile.freebsd using the old
	NOOBJ and NOPROFILE nomenclature.

	files/patch-aa already tinkers with makefile.freebsd, so it would be
	best to update files/patch-aa to include a fix for this.  Below is a
	patch to files/patch-aa.

Fix: Apply the below patch to files/patch-aa.  If this doesn't work, let
	me know and I can provide the full files/patch-aa replacement.

How-To-Repeat: 	Build libpng on a system which uses the new NO_OBJ/NO_PROFILE tweaks.
Comment 1 Edwin Groothuis freebsd_committer 2006-04-24 05:04:20 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ache

Over to maintainer
Comment 2 Andrey A. Chernov freebsd_committer 2006-04-24 15:05:23 UTC
State Changed
From-To: open->closed

Committed