Bug 96508 - [fix] www/mod_jk: support for apache >2.0
Summary: [fix] www/mod_jk: support for apache >2.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Palle Girgensohn
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-29 12:20 UTC by Šimun Mikecin
Modified: 2006-08-14 08:52 UTC (History)
0 users

See Also:


Attachments
file.diff (1.58 KB, patch)
2006-04-29 12:20 UTC, Šimun Mikecin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Šimun Mikecin 2006-04-29 12:20:19 UTC
Installing mod_jk port on apache 2.1 or 2.2 installs mod_jk.so module in the
right directory, but in the package database it gets recorded wrongly:
/usr/local/libexec/apache2/mod_jk.so
instead of:
/usr/local/libexec/apache21/mod_jk.so
or:
/usr/local/libexec/apache22/mod_jk.so
Also port installs *conf.sample files in /usr/local/etc/apache2/ instead of
/usr/local/etc/apache21/ or /usr/local/etc/apache22/.
With this patch www/mod_jk-apache2 helper port can be removed, since this
port now autodetects the version of apache installed on the system.

How-To-Repeat: Try installing this port on system with apache 2.1 or apache 2.2 installed.
Comment 1 Edwin Groothuis freebsd_committer 2006-04-29 12:24:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->girgen

Over to maintainer
Comment 2 Palle Girgensohn freebsd_committer 2006-08-14 08:51:09 UTC
State Changed
From-To: open->closed

The port updated and a fix similar to the suggested is applied. 

Thanks!