Bug 96707 - [PATCH] textproc/libxslt does not compile under FreeBSD 4.x
[PATCH] textproc/libxslt does not compile under FreeBSD 4.x
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: gnome
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 10:10 UTC by sven
Modified: 2006-05-04 01:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sven 2006-05-03 10:10:07 UTC
	The port textproc/libxslt does not compile under FreeBSD 4.x.

Fix: Install the extra patch file
	/usr/ports/textproc/libxslt/files/patch-libexslt_crypto.c as:




This files will fix the problem and will not break 5.x and later.--z4cnHgCNf8nkHcLtbNOp1uaqvWRZPndQiFkrXetaNKLupQnq
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- libexslt/crypto.c.orig	Wed May  3 10:57:11 2006
+++ libexslt/crypto.c	Wed May  3 10:58:24 2006
@@ -318,6 +318,7 @@
 #define PLATFORM_SHA1 GCRY_MD_SHA1
 
 #ifdef HAVE_SYS_SELECT_H
+#include <sys/types.h>
 #include <sys/select.h>		/* needed by gcrypt.h 4 Jul 04 */
 #endif
 #include <gcrypt.h>
How-To-Repeat: 	Install under FreeBSD 4.x.
Comment 1 Edwin Groothuis freebsd_committer 2006-05-03 10:12:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer
Comment 2 Joe Marcus Clarke freebsd_committer 2006-05-04 01:45:25 UTC
State Changed
From-To: open->closed

Committed, thanks!