Bug 97876 - mail/fetchmail -- rc.subr script doesn't work on 4.x
Summary: mail/fetchmail -- rc.subr script doesn't work on 4.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Simon Barner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-25 05:00 UTC by Jeremy Chadwick
Modified: 2006-05-25 17:28 UTC (History)
0 users

See Also:


Attachments
file.diff (277 bytes, patch)
2006-05-25 05:00 UTC, Jeremy Chadwick
no flags Details | Diff
file.diff (320 bytes, patch)
2006-05-25 05:00 UTC, Jeremy Chadwick
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Chadwick 2006-05-25 05:00:36 UTC
	fetchmail daemon startup script (for rc.subr) is not 4.x compatible.

	The problem is that the fetchmail.sh script tries to blindly call
	/etc/rc.subr, which is only available on 5.x and 6.x.  This is
	incorrect; it needs to use %%RC_SUBR%% which will be expanded
	properly at patch or install-time.

	See line 49 of files/fetchmail.in for what I mean.  :-)

	I've also cleaned up a typo in the Makefile.

Fix: Apply the below patches.
How-To-Repeat: 	Try to start /usr/local/etc/rc.d/fetchmail.sh on a 4.x box.
Comment 1 Edwin Groothuis freebsd_committer 2006-05-25 05:04:17 UTC
Responsible Changed
From-To: freebsd-ports-bugs->barner

Over to maintainer
Comment 2 Simon Barner freebsd_committer 2006-05-25 17:28:36 UTC
State Changed
From-To: open->closed

Committed. Thanks!