Bug 99233 - [UPDATE] x11-toolkits/paragui: fix on !i386
Summary: [UPDATE] x11-toolkits/paragui: fix on !i386
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Shaun Amott
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-21 00:40 UTC by Alejandro Pulver
Modified: 2006-06-21 03:06 UTC (History)
0 users

See Also:


Attachments
paragui.diff (1.09 KB, patch)
2006-06-21 00:40 UTC, Alejandro Pulver
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Pulver freebsd_committer 2006-06-21 00:40:09 UTC

This simple patch fixes the building of this application in non-i386 architectures. The problem is that it was using a 32-bit variable to hold a memory address, which fails in 64-bit machines. I have replaced the 32-bit data type with "ptrdiff_t".
Comment 1 Edwin Groothuis freebsd_committer 2006-06-21 00:44:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->shaun

Over to maintainer
Comment 2 Shaun Amott freebsd_committer 2006-06-21 03:05:34 UTC
State Changed
From-To: open->closed

Committed, thanks.