Bug 99393 - update math/mumps to version 4.6.3
update math/mumps to version 4.6.3
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Thierry Thomas
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 23:50 UTC by giffunip
Modified: 2006-06-24 22:41 UTC (History)
0 users

See Also:


Attachments
file.diff (861 bytes, patch)
2006-06-23 23:50 UTC, giffunip
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description giffunip 2006-06-23 23:50:16 UTC
A new version of the powerful solver has been released. Changes include:

* Reduced memory usage for symmetric matrices (compressed CB)
* Reduced memory allocation for parallel executions
* Scheduler parameters for parallel executions modified
* Memory estimates (that were too large) corrected with
  2Dcyclic Schur complement option
* Portability improved (C/Fortran interfacing for strings)
* The situation leading to Warning "RHS associated in MUMPS_301"
  no more occurs.
* Parameters INFO/RINFO from the Scilab/Matlab API are now called
  INFOG/RINFOG in order to match the MUMPS user's guide.
Comment 1 Thierry Thomas freebsd_committer 2006-06-24 13:25:58 UTC
State Changed
From-To: open->feedback


Compilation fails: 

ar vr  libpord.a graph.o gbipart.o gbisect.o ddcreate.o ddbisect.o nestdiss.o  multisector.o gelim.o bucket.o tree.o  symbfac.o interface.o sort.o minpriority.o 
ar: creating libpord.a 
a - graph.o 
a - gbipart.o 
a - gbisect.o 
a - ddcreate.o 
a - ddbisect.o 
a - nestdiss.o 
a - multisector.o 
a - gelim.o 
a - bucket.o 
a - tree.o 
a - symbfac.o 
a - interface.o 
a - sort.o 
a - minpriority.o 
ranlib libpord.a 
if [ "../PORD/lib/" != "" ] ; then  cd src; cp ../PORD/lib//libpord.a ../lib/libpord.a; fi; 
(cd src ; make double) 
/usr/local/bin/gfortran41 -O -ff2c -I../libseq -Dpord -I. -I../include -c dmumps_bloc2.F 
cc1: error: unrecognized command line option "-ff2c" 
*** Error code 1 

Stop in /work/a/ports/math/mumps/work/MUMPS_4.6.3/src. 
*** Error code 1 



Comment 2 Thierry Thomas freebsd_committer 2006-06-24 13:25:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->thierry


Take it.
Comment 3 Thierry Thomas freebsd_committer 2006-06-24 16:44:38 UTC
On Sat 24 jun 06 at 17:06:06 +0200, pfgshield-freebsd@yahoo.com <pfgshield-freebsd@yahoo.com>
 wrote:
> > if [ "../PORD/lib/" != "" ] ; then  cd src; cp ../PORD/lib//libpord.a
> > ../lib/libpord.a; fi;
> > (cd src ; make double)
> > /usr/local/bin/gfortran41 -O -ff2c -I../libseq -Dpord -I. -I../include -c
> > dmumps_bloc2.F
> > cc1: error: unrecognized command line option "-ff2c"
> > *** Error code 1
> > 
> 
> It builds fine here! Can you confirm the previous port builds with your
> gfortran compiler?

You're right: 4.6.2 used to build fine, but now it fails with the same
error.

> Also please do a gfortran41 --version

It is up-to-date:

gfortran41 --version
GNU Fortran 95 (GCC) 4.1.2 20060616 (prerelease)
Copyright (C) 2006 Free Software Foundation, Inc.

GNU Fortran comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of GNU Fortran
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING

Wich one do you run?
-- 
Th. Thomas.
Comment 4 Thierry Thomas freebsd_committer 2006-06-24 17:24:50 UTC
On Sat 24 jui 06 at 17:53:47 +0200, pfgshield-freebsd@yahoo.com <pfgshield-freebsd@yahoo.com>
 wrote:
> I can't reproduce it, but maybe gfortran has become stricter in the ordering of
> the command options. This might work:

Thanks, but I get the same failure:

if [ "../PORD/lib/" != "" ] ; then  cd src; cp ../PORD/lib//libpord.a ../lib/libpord.a; fi;
(cd src ; make double)
/usr/local/bin/gfortran41 -ff2c -O -I../libseq -Dpord -I. -I../include -c dmumps_bloc2.F
cc1: error: unrecognized command line option "-ff2c"
*** Error code 1

Stop in /work/a/ports/math/mumps/work/MUMPS_4.6.3/src.
*** Error code 1

However it does not seem to be an incompatibility between gfortran and
-ff2c, because the first occurence passes:

===>  Building for mumps-4.6.3
(cd libseq; make)
/usr/local/bin/gfortran41 -ff2c -O -c mpi.f
gcc41 -O2 -fno-strict-aliasing -pipe -I. -c mpic.c
gcc41 -O2 -fno-strict-aliasing -pipe -I. -c elapse.c
ar vr libmpiseq.a mpi.o mpic.o elapse.o
ar: creating libmpiseq.a
a - mpi.o
a - mpic.o
a - elapse.o
...
-- 
Th. Thomas.
Comment 5 pfgshield-freebsd 2006-06-24 18:19:54 UTC
--- Thierry Thomas <thierry@FreeBSD.org> ha scritto: 
...
> 
> However it does not seem to be an incompatibility between gfortran and
> -ff2c, because the first occurence passes:
> 

I don't know what to say. maybe the new gfortran is broken :(. When gfortran is
adopted for all the ports tree we won't need -ff2c.

    Pedro.


Chiacchiera con i tuoi amici in tempo reale! 
 http://it.yahoo.com/mail_it/foot/*http://it.messenger.yahoo.com
Comment 6 Thierry Thomas freebsd_committer 2006-06-24 22:35:50 UTC
State Changed
From-To: feedback->closed


I cannot build it inside my tinderbox, but it builds fine in a "normal" 
environment, I have not understood why... 

It passes succesfully the tests (./csimpletest, ./dsimpletest, etc.); 
BTW, you could call these tests from a regression-test target.