Bug 99809 - audio/openal - patch to fix build error for x86/CPUTYPE
Summary: audio/openal - patch to fix build error for x86/CPUTYPE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-05 18:20 UTC by Erik Greenwald
Modified: 2006-07-05 18:54 UTC (History)
1 user (show)

See Also:


Attachments
audio_openal.patch (705 bytes, patch)
2006-07-05 18:20 UTC, Erik Greenwald
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Greenwald 2006-07-05 18:20:17 UTC
When the CPUTYPE is set on an x86 box, and nasm happens to be 
installed, audio/openal tries to use nasm and causes "bad objects" 
in archive files (as the "-f elf" flag is not set), causing the 
build to fail. The reason is because the 'type' flag is only set for
linux... This patch changes that *linux*) to *bsd*) allowing the 
build to succeed (with the optimized asm version being used). 

This has been tested on p4-xeon, amd32-athlon, and amd64-opteron, both
with CPUTYPE unset and set.

I seem to have forgotten my password to the creative repo (or users
weren't migrated when they changed from CVS to SVN), so I have not
committed my fix there, but will as soon as I get access.

Thanks!
Comment 1 Rong-En Fan freebsd_committer 2006-07-05 18:54:27 UTC
State Changed
From-To: open->closed

Committed. Thanks.