Bug 172532

Summary: [rc] [patch] service routing restart always fails
Product: Base System Reporter: Enji Cooper <ngie>
Component: confAssignee: freebsd-bugs (Nobody) <bugs>
Status: Open ---    
Severity: Affects Only Me    
Priority: Normal    
Version: Unspecified   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.diff none

Description Enji Cooper freebsd_committer 2012-10-09 23:30:15 UTC
Before patch...

# service routing restart
delete net ::ffff:0.0.0.0: gateway ::1
delete net ::0.0.0.0: gateway ::1
delete net 3ffe::: gateway em1
delete net fe80::: gateway ::1
delete net ff02::: gateway ::1
ifconfig: interface auto does not exist
add net ::ffff:0.0.0.0: gateway ::1
add net ::0.0.0.0: gateway ::1
add net 3ffe::: gateway em1
add net fe80::: gateway ::1
add net ff02::: gateway ::1

After patch...

# service routing restart
delete net ::ffff:0.0.0.0: gateway ::1
delete net ::0.0.0.0: gateway ::1
delete net 3ffe::: gateway em1
delete net fe80::: gateway ::1
delete net ff02::: gateway ::1
add net ::ffff:0.0.0.0: gateway ::1
add net ::0.0.0.0: gateway ::1
add net 3ffe::: gateway em1
add net fe80::: gateway ::1
add net ff02::: gateway ::1

Fix: Patch attached with submission follows:
How-To-Repeat: 1. Set network_interfaces="auto".
2. Run `service routing restart` with IPv6 enabled.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-10-10 01:24:49 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-rc

Over to maintainer(s).
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:22 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped