Bug 194255

Summary: Port Update: finance/frontaccounting - Version update and a fix for USE_APACHE.
Product: Ports & Packages Reporter: ek
Component: Individual Port(s)Assignee: Johannes Jost Meixner <xmj>
Status: Closed FIXED    
Severity: Affects Only Me CC: xmj
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
frontaccounting-2.3.22_port-update.diff none

Description ek 2014-10-08 20:32:50 UTC
Created attachment 148114 [details]
frontaccounting-2.3.22_port-update.diff

NOTE: I previously submitted a fix before the new version was released (BUG #193883) which has not currently been accepted and can now be discarded and replaced by this PR.

	Version updated to 2.3.22 and a fix for the USE_APACHE to use 22+ as opposed to 24+ (although, 24+ should be the standard now..?)

	Also, I believe I was the maintainer of the port previously but I seem to no longer be listed as so. Can someone please place me as the maintainer of this port once again?
Comment 1 Johannes Jost Meixner freebsd_committer 2014-10-18 05:39:43 UTC
*** Bug 193883 has been marked as a duplicate of this bug. ***
Comment 2 Johannes Jost Meixner freebsd_committer 2014-10-18 05:48:25 UTC
I'll take it.
Comment 3 commit-hook freebsd_committer 2014-10-18 15:27:37 UTC
A commit references this bug:

Author: xmj
Date: Sat Oct 18 15:27:24 UTC 2014
New revision: 371137
URL: https://svnweb.freebsd.org/changeset/ports/371137

Log:
  finance/frontaccounting: upgrade to 2.3.22

  - Upgrade to 2.3.22
  - Depend on Apache 2.2 or later.
  - Add dependency on mod_php5 or CGI when used with Apache
  - Add NLS option
  - (re-)assign maintainer to ek@purplehat.org

  PR:		194255
  Differential Revision:	https://reviews.freebsd.org/D964
  Submitted by:	ek@purplehat.org
  Approved by:	swills (mentor)

Changes:
  head/finance/frontaccounting/Makefile
  head/finance/frontaccounting/distinfo
  head/finance/frontaccounting/pkg-plist
Comment 4 Johannes Jost Meixner freebsd_committer 2014-10-18 15:28:41 UTC
Committed, with minor changes. Thanks!
Comment 5 commit-hook freebsd_committer 2015-05-21 10:09:09 UTC
A commit references this bug:

Author: marino
Date: Thu May 21 10:08:47 UTC 2015
New revision: 386921
URL: https://svnweb.freebsd.org/changeset/ports/386921

Log:
  finance/frontaccounting: Upgrade version 2.3.22 => 2.3.24

  The version update was done because the port had to address missing PHP
  modules anyway.  Why here:

   * Add the missing hash, ctype, zlib modules
   * leverage new options framework to simply options handling
   * implement NLS option (was listed, but not implemented)
   * explicitly list DOCS option (implemented but unselectable)
   * Rename MYSQL option to MYSQL_SERVER because MySQL client is
     installed unconditionally so the option name was misleading
   * Unsuppress install commands
   * Wrap compound commands in parentheses for multijob support
   * Wrap to 80 columns
   * Remove bogus post-install cat pkgmessage target
   * Remove 120 bogus @dir lines introduced in [2]

  PR:		200265
  PR:		194255 [2]
  Reported by:	marino
  Initial fix:	maintainer (ek - purplehat.org)
  rest of fixes:	marino

Changes:
  head/finance/frontaccounting/Makefile
  head/finance/frontaccounting/distinfo
  head/finance/frontaccounting/pkg-plist