Bug 196991

Summary: multimedia/{lib}x264: Update BUILD_DEPENDS to require yasm >= 1.2.0
Product: Ports & Packages Reporter: takefu
Component: Individual Port(s)Assignee: Kubilay Kocak <koobs>
Status: Closed FIXED    
Severity: Affects Only Me Keywords: needs-qa, patch, patch-ready
Priority: --- Flags: koobs: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Description Flags
libx264.patch none

Description takefu 2015-01-22 03:16:14 UTC
Created attachment 152000 [details]

# make
===>  License GPLv2 accepted by the user
===>   libx264-0.142.2455_2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by libx264-0.142.2455_2 for building
===>  Extracting for libx264-0.142.2455_2
=> SHA256 Checksum OK for x264/x264-snapshot-20140827-2245-stable.tar.bz2.
===>  Patching for libx264-0.142.2455_2
===>  Applying FreeBSD patches for libx264-0.142.2455_2
===>   libx264-0.142.2455_2 depends on package: yasm>=0.6.0 - found
===>   libx264-0.142.2455_2 depends on executable: bash - found
===>   libx264-0.142.2455_2 depends on executable: gmake - found
===>  Configuring for libx264-0.142.2455_2
Found yasm
Minimum version is yasm-1.2.0
If you really want to compile without asm, configure with --disable-asm.
===>  Script "configure" failed unexpectedly.
Please report the problem to koobs@FreeBSD.org [maintainer] and attach the
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop in /usr/ports/multimedia/libx264.
Comment 1 Bugzilla Automation freebsd_committer 2015-01-22 03:16:14 UTC
Auto-assigned to maintainer koobs@FreeBSD.org
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-01-22 06:32:23 UTC
I will update the BUILD_DEPENDS minimum version, but I'm curious which yasm you're using? 

The one from ports (devel/yasm) is version 1.2.0. Were you just using an old one to test?
Comment 3 takefu 2015-01-22 07:13:00 UTC
(In reply to Kubilay Kocak from comment #2)

When older than devel / yasm 1.2.0, fails to build.
Of course, does not occur problem in the latest version.

% ===>   libx264-0.142.2455_2 depends on package: yasm>=0.6.0 - found

Here I pass the inspection of yasm version.
Build fails after them.
Comment 4 commit-hook freebsd_committer 2015-01-27 04:38:55 UTC
A commit references this bug:

Author: koobs
Date: Tue Jan 27 04:38:12 UTC 2015
New revision: 377978
URL: https://svnweb.freebsd.org/changeset/ports/377978

  multimedia/{lib}x264: Update minimum yasm version

  Update the minimum version of yasm required in BUILD_DEPENDS.

  PR:		196991
  Submitted by:	takefu airport.fm

Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2015-01-27 04:39:45 UTC
Committed with changes (added change to multimedia/x264 as well). Thank you!